Loading ...
Sorry, an error occurred while loading the content.
 

Bug in VIM 7.3.46

Expand Messages
  • Simon Rushton
    Hope this is the best place for bug reports. ... I m using VIM 7.3.46 on Windows XP. I m writing sql and pkb files, so PL/SQL highlighting is being used, ...
    Message 1 of 3 , Feb 3, 2011
      Hope this is the best place for bug reports.

      > Environment
      I'm using VIM 7.3.46 on Windows XP.

      I'm writing sql and pkb files, so PL/SQL highlighting is being used,
      and I have the following bespoke lines in my vimrc file:

      :colorscheme murphy

      set ts=2

      set autoindent
      set expandtab

      > Bug
      When writing comments, i.e. prefixed with "--", if I insert the word
      "end" then the text is inserted correctly, but also the indented line
      jumps back to the start of the line, i.e. any white space at the start
      of the line is deleted.

      It doesn't always happen, and I haven't narrowed down exactly the
      conditions, but I can always reproduce it when I write a second
      comment line directly beneath the first.

      Thanks,

      Simon

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ben Fritz
      ... Since you re talking about syntax highlighting, doubtless you turn on syntax highlighting and filetype detection somewhere in your configuration. It does
      Message 2 of 3 , Feb 3, 2011
        On Feb 3, 7:18 am, Simon Rushton <simonrush...@...> wrote:
        > Hope this is the best place for bug reports.
        >
        > > Environment
        >
        > I'm using VIM 7.3.46 on Windows XP.
        >
        > I'm writing sql and pkb files, so PL/SQL highlighting is being used,
        > and I have the following bespoke lines in my vimrc file:

        Since you're talking about syntax highlighting, doubtless you turn on
        syntax highlighting and filetype detection somewhere in your
        configuration. It does not occur in the lines you list below. Possibly
        it happens in a "system .vimrc" file. Look at the output of :version
        to find where this is.

        >
        > :colorscheme murphy
        >
        > set ts=2
        >
        > set autoindent
        > set expandtab
        >

        When you turn on filetype detection, do you also turn on filetype and/
        or indent plugins? These are a very likely place for the behavior
        you've noticed.

        What does

        :verbose set indentexpr?

        tell you?


        > > Bug
        >
        > When writing comments, i.e. prefixed with "--", if I insert the word
        > "end" then the text is inserted correctly, but also the indented line
        > jumps back to the start of the line, i.e. any white space at the start
        > of the line is deleted.
        >
        > It doesn't always happen, and I haven't narrowed down exactly the
        > conditions, but I can always reproduce it when I write a second
        > comment line directly beneath the first.
        >

        Looks like a problem with either the indent plugin or indentkeys
        setting, if in your setup filetype indent and/or plugin are enabled.

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Simon Rushton
        Hey Ben, Thanks for your reply. see below: ... I don t turn anything on or change any config settings other than the changes I made to the bottom of the _vimrc
        Message 3 of 3 , Feb 9, 2011
          Hey Ben,

          Thanks for your reply.

          see below:

          On Thu, Feb 3, 2011 at 8:49 PM, Ben Fritz <fritzophrenic@...> wrote:
          >
          >
          > On Feb 3, 7:18 am, Simon Rushton <simonrush...@...> wrote:
          >> Hope this is the best place for bug reports.
          >>
          >> > Environment
          >>
          >> I'm using VIM 7.3.46 on Windows XP.
          >>
          >> I'm writing sql and pkb files, so PL/SQL highlighting is being used,
          >> and I have the following bespoke lines in my vimrc file:
          >
          > Since you're talking about syntax highlighting, doubtless you turn on
          > syntax highlighting and filetype detection somewhere in your
          > configuration. It does not occur in the lines you list below. Possibly
          > it happens in a "system .vimrc" file. Look at the output of :version
          > to find where this is.
          >

          I don't turn anything on or change any config settings other than the
          changes I made to the bottom of the _vimrc file as described.
          I just use the default settings and the highlighting works
          automatically for me - due to the file extention .

          >>
          >> :colorscheme murphy
          >>
          >> set ts=2
          >>
          >> set autoindent
          >> set expandtab
          >>
          >
          > When you turn on filetype detection, do you also turn on filetype and/
          > or indent plugins? These are a very likely place for the behavior
          > you've noticed.
          >
          > What does
          >
          > :verbose set indentexpr?
          >
          > tell you?
          >

          It says:
          Last set from C:\Program Files\Vim\vim73\indent\sqlanywhere.vim

          I haven't dived into this .vim script to figure out what's going on...

          >
          >> > Bug
          >>
          >> When writing comments, i.e. prefixed with "--", if I insert the word
          >> "end" then the text is inserted correctly, but also the indented line
          >> jumps back to the start of the line, i.e. any white space at the start
          >> of the line is deleted.
          >>
          >> It doesn't always happen, and I haven't narrowed down exactly the
          >> conditions, but I can always reproduce it when I write a second
          >> comment line directly beneath the first.
          >>
          >
          > Looks like a problem with either the indent plugin or indentkeys
          > setting, if in your setup filetype indent and/or plugin are enabled.
          >
          > --
          > You received this message from the "vim_dev" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.