Loading ...
Sorry, an error occurred while loading the content.

[BUG]: build failure with --enable-perlinterp=dynamic

Expand Messages
  • Britton Kerin
    For the source from the download page I get this and the latest stable perl (5.12.3), I get this: $ ./configure --prefix=$HOME/local
    Message 1 of 2 , Jan 30, 2011
    • 0 Attachment
      For the source from the download page I get this and the latest stable perl
      (5.12.3), I get this:

      $ ./configure --prefix=$HOME/local --enable-perlinterp=dynamic
      $ make

      [snip]

      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread
      -I/home/bkerin/local/include/gtk-2.0
      -I/home/bkerin/local/lib/gtk-2.0/include
      -I/home/bkerin/local/include/atk-1.0
      -I/home/bkerin/local/include/cairo
      -I/home/bkerin/local/include/gdk-pixbuf-2.0
      -I/home/bkerin/local/include/pango-1.0
      -I/home/bkerin/local/include/glib-2.0
      -I/home/bkerin/local/lib/glib-2.0/include
      -I/home/bkerin/local/include/pixman-1 -I/usr/include/freetype2
      -I/usr/include/libpng12 -g -O2 -D_FORTIFY_SOURCE=1
      -DDYNAMIC_PERL_DLL=\"libperl.a\" -fstack-protector
      -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
      -I/home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE -o
      objects/if_perl.o auto/if_perl.c
      if_perl.xs:128:1: warning: "Perl_croak_nocontext" redefined
      In file included from
      /home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE/perl.h:954,
      from ./vim.h:2154,
      from if_perl.xs:16:
      /home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE/embed.h:4941:1:
      warning: this is the location of the previous definition
      if_perl.xs:322: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
      ‘__attribute__’ before ‘*’ token
      if_perl.xs:429: error: ‘dll_Perl_Gthr_key_ptr’ undeclared here
      (not in a function)
      make[1]: *** [objects/if_perl.o] Error 1
      make[1]: Leaving directory `/home/bkerin/tmp/lb/vim73/src'
      make: *** [first] Error 2

      On the other hand, building with --enable-perlinterp=yes works. But then:

      $ ldd src/vim | grep perl
      $

      So it looks like the perl interpreter is loaded dynamically in this version
      anyway. So perhaps --enable-perlinterp=yes should not be an option, or else
      it should mean dynamic and --enable-perlinterp=dynamic should not be an option?

      Britton

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bram Moolenaar
      ... Check your configure output, using yes should produce a non-dynamic version but perhaps it got disabled by configure for some reason. I only have Perl
      Message 2 of 2 , Feb 1, 2011
      • 0 Attachment
        Britton Kerin wrote:

        > For the source from the download page I get this and the latest stable perl
        > (5.12.3), I get this:
        >
        > $ ./configure --prefix=$HOME/local --enable-perlinterp=dynamic
        > $ make
        >
        > [snip]
        >
        > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread
        > -I/home/bkerin/local/include/gtk-2.0
        > -I/home/bkerin/local/lib/gtk-2.0/include
        > -I/home/bkerin/local/include/atk-1.0
        > -I/home/bkerin/local/include/cairo
        > -I/home/bkerin/local/include/gdk-pixbuf-2.0
        > -I/home/bkerin/local/include/pango-1.0
        > -I/home/bkerin/local/include/glib-2.0
        > -I/home/bkerin/local/lib/glib-2.0/include
        > -I/home/bkerin/local/include/pixman-1 -I/usr/include/freetype2
        > -I/usr/include/libpng12 -g -O2 -D_FORTIFY_SOURCE=1
        > -DDYNAMIC_PERL_DLL=\"libperl.a\" -fstack-protector
        > -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
        > -I/home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE -o
        > objects/if_perl.o auto/if_perl.c
        > if_perl.xs:128:1: warning: "Perl_croak_nocontext" redefined
        > In file included from
        > /home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE/perl.h:954,
        > from ./vim.h:2154,
        > from if_perl.xs:16:
        > /home/bkerin/local/lib/perl5/5.12.3/i686-linux/CORE/embed.h:4941:1:
        > warning: this is the location of the previous definition
        > if_perl.xs:322: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
        > ‘__attribute__’ before ‘*’ token
        > if_perl.xs:429: error: ‘dll_Perl_Gthr_key_ptr’ undeclared here
        > (not in a function)
        > make[1]: *** [objects/if_perl.o] Error 1
        > make[1]: Leaving directory `/home/bkerin/tmp/lb/vim73/src'
        > make: *** [first] Error 2
        >
        > On the other hand, building with --enable-perlinterp=yes works. But then:
        >
        > $ ldd src/vim | grep perl
        > $
        >
        > So it looks like the perl interpreter is loaded dynamically in this version
        > anyway. So perhaps --enable-perlinterp=yes should not be an option, or else
        > it should mean dynamic and --enable-perlinterp=dynamic should not be an option?

        Check your configure output, using "yes" should produce a non-dynamic
        version but perhaps it got disabled by configure for some reason.

        I only have Perl 5.10.1 and it builds without warning there. Perhaps
        someone can make a fix for Perl 5.12?

        --
        hundred-and-one symptoms of being an internet addict:
        171. You invent another person and chat with yourself in empty chat rooms.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.