Loading ...
Sorry, an error occurred while loading the content.
 

Bug? Some problems with Vim7.3 with Lusty-explorer plugin

Expand Messages
  • lilydjwg
    I ve been using vim7.3 for some time, and find some problem with its ruby support. 1. $curbuf.number always returns 0 on my platform. See this thread for more
    Message 1 of 1 , Sep 11, 2010
      I've been using vim7.3 for some time, and find some problem with its
      ruby support.

      1. $curbuf.number always returns 0 on my platform. See this thread for
      more infomation
      https://groups.google.com/group/vim_use/browse_thread/thread/a122376e8dbc6d29
      Later I modified Lusty-explorer to not use the variable.

      2. When I am using Lusty-explorer with +perl and +ruby compiled in,
      Vim usually crashes. Terminal output:
      Vim: 拦截到致命信号(deadly signal) SEGV
      Vim: 结束。
      zsh: segmentation fault vim
      gdb backtrace when this happens:
      #0 __memset_sse2 () at ../sysdeps/i386/i686/multiarch/memset-sse2.S:160
      #1 0x00d1d6ac in Perl_sv_upgrade () from /usr/lib/libperl.so.5.10
      #2 0x00d1ea6a in Perl_sv_magicext () from /usr/lib/libperl.so.5.10
      #3 0x00d1fc11 in Perl_sv_magic () from /usr/lib/libperl.so.5.10
      #4 0x00d21882 in Perl_sv_setiv () from /usr/lib/libperl.so.5.10
      #5 0x08203691 in perl_buf_free (bp=0x847b890) at if_perl.xs:638
      #6 0x080742e3 in free_buffer (buf=0x847b890) at buffer.c:613
      #7 0x08073fec in close_buffer (win=0x0, buf=0x847b890, action=4)
      at buffer.c:468
      #8 0x08074de8 in do_buffer (action=4, start=0, dir=1, count=0, forceit=1)
      at buffer.c:1136
      #9 0x0807465e in do_bufdel (command=4, arg=0x84b8aa1 "", addr_count=0,
      start_bnr=12, end_bnr=1, forceit=1) at buffer.c:834
      #10 0x080cbb2c in ex_bunload (eap=0xbfff9f8c) at ex_docmd.c:4939
      #11 0x080c817d in do_one_cmd (cmdlinep=0xbfffa140, sourcing=1,
      cstack=0xbfffa148, fgetline=0, cookie=0x0) at ex_docmd.c:2656
      #12 0x080c5a56 in do_cmdline (cmdline=0x837c2d0 "bwipeout!", getline=0,
      cookie=0x0, flags=11) at ex_docmd.c:1122
      #13 0x080c5110 in do_cmdline_cmd (cmd=0x837c2d0 "bwipeout!") at ex_docmd.c:728
      #14 0x0820cf98 in vim_command (self=3084803600, str=3084486540) at if_ruby.c:731
      #15 0x010619a3 in ?? () from /usr/lib/libruby1.8.so.1.8
      ---Type <return> to continue, or q <return> to quit---

      I think I have no plugin that uses perl.

      3. swapfile name and backup file name changes to 8.3 style after
      invoking :LustyBufferExplorer. Here's how to reproduce it:

      * Open a file, eg Contents. The swapfile's name will be .Contents.swp
      * open another file
      * use Lusty-Explorer to switch to the previous file
      * use :sw to see the swapfile's name, it becomes Contents.swp
      * For longer file names, Vim will truncate it to 8.3 style

      The backup file name changes the same way.

      4. I tried Lusty-explorer on Windows XP with ruby1.9 (I got the
      gvim7.3 for vim.org . Vim crashes immediately when I invoke
      Lusty-explorer.

      I hope these problems can be solved soon. I really love vim7.3.

      PS:

      Except the last problem, they happens on Ubuntu10.10 and Archlinux.

      my Vim :version:

      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Aug 31 2010 12:55:01)
      编译者 lilydjwg@lilydjwg-desktop
      巨型版本 带 GTK2-GNOME 图形界面。 可使用(+)与不可使用(-)的功能:
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
      +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
      +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
      +file_in_path +find_in_path +float +folding -footer +fork() +gettext
      -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
      +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname
      +mouse +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm +mouse_netterm
      -mouse_sysmouse +mouse_xterm +multi_byte +multi_lang -mzscheme -netbeans_intg
      -osfiletype +path_extra -perl +persistent_undo +postscript +printer +profile
      +python -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs
      +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
      +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title
      -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
      +xsmp_interact +xterm_clipboard -xterm_save
      系统 vimrc 文件: "$VIM/vimrc"
      用户 vimrc 文件: "$HOME/.vimrc"
      用户 exrc 文件: "$HOME/.exrc"
      系统 gvimrc 文件: "$VIM/gvimrc"
      用户 gvimrc 文件: "$HOME/.gvimrc"
      系统菜单文件: "$VIMRUNTIME/menu.vim"
      $VIM 预设值: "/usr/local/share/vim"
      编译方式: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -DORBIT2=1 -pthread -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/directfb -I/usr/include/libpng12 -g -O2 -D_FORTIFY_SOURCE=1 -I/usr/lib/ruby/1.8/i486-linux -DRUBY_VERSION=18
      链接方式: gcc -L. -Wl,-Bsymbolic-functions -rdynamic -Wl,-export-dynamic -L/usr/local/lib -o vim -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lgnomeui-2 -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lXt -lncurses -lselinux -L/usr/lib/python2.6/config -lpython2.6 -lutil -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions -lruby1.8 -lrt -lm

      lilydjwg

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.