Loading ...
Sorry, an error occurred while loading the content.
 

Re: Encoding clash: cannot run :helptags after installing French-language help

Expand Messages
  • Bram Moolenaar
    ... What is your enc option set to when you use the :helptags command? I believe it should work when it is utf-8, then the latin1 files can be converted from
    Message 1 of 3 , May 2, 2010
      Tony Mechelynck wrote:

      > The French-language help includes a tags-fr. It works -- as long as I
      > don't want to install another helpfile in the same directory. Then
      > :helptags $VIM/vimfiles/doc gives an error on hebrew.frx which has a
      > different 'fileencoding' than the rest. The problem is that most of the
      > *.frx files are in 8-bit Latin1 (with âàçéêèëîïôûù but not œ) while
      > hebrew.frx is in UTF-8+BOM (with Hebrew letters in UTF-8), so even
      > removing the BOM doesn't clear the error: it's still Latin1 vs. UTF-8
      > (even though all help *tags*, |references|, 'options' etc. within all
      > files are in 7-bit ASCII). Trying to run :helptags on that directory
      > (e.g. as part of :UseVimball) then truncates tags-fr to zero length.
      >
      > Bram: I believe the E670 message (at ex_cmds.c line 6398) and the
      > corresponding check are more a hinder than a help.
      >
      > Another possibility would be to convert the whole French help to UTF-8,
      > but then it would no more be readable by "tiny" "small" or "normal"
      > -multi_byte versions of Vim. Anyway the README-fr says this help is for
      > Vim 6.2.017, and yet it is the only language which enjoys "full"
      > translation of the Vim help. Maybe we should declare that help
      > translation is a fiasco for lack of adequate manpower?

      What is your 'enc' option set to when you use the :helptags command?
      I believe it should work when it is utf-8, then the latin1 files can be
      converted from latin1 to utf-8 and the generated tags file is in utf-8.
      The digraph.txt file is also in latin1.

      --
      A)bort, R)etry, B)ang it with a large hammer

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ download, build and distribute -- http://www.A-A-P.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... I did it in gvim (Huge) for GTK2/Gnome2, with encoding set to UTF-8 (my system locale is en_US.UTF-8, and my vimrc sets enc to utf-8 within an if
      Message 2 of 3 , May 2, 2010
        On 02/05/10 19:37, Bram Moolenaar wrote:
        >
        > Tony Mechelynck wrote:
        >
        >> The French-language help includes a tags-fr. It works -- as long as I
        >> don't want to install another helpfile in the same directory. Then
        >> :helptags $VIM/vimfiles/doc gives an error on hebrew.frx which has a
        >> different 'fileencoding' than the rest. The problem is that most of the
        >> *.frx files are in 8-bit Latin1 (with âàçéêèëîïôûù but not œ) while
        >> hebrew.frx is in UTF-8+BOM (with Hebrew letters in UTF-8), so even
        >> removing the BOM doesn't clear the error: it's still Latin1 vs. UTF-8
        >> (even though all help *tags*, |references|, 'options' etc. within all
        >> files are in 7-bit ASCII). Trying to run :helptags on that directory
        >> (e.g. as part of :UseVimball) then truncates tags-fr to zero length.
        >>
        >> Bram: I believe the E670 message (at ex_cmds.c line 6398) and the
        >> corresponding check are more a hinder than a help.
        >>
        >> Another possibility would be to convert the whole French help to UTF-8,
        >> but then it would no more be readable by "tiny" "small" or "normal"
        >> -multi_byte versions of Vim. Anyway the README-fr says this help is for
        >> Vim 6.2.017, and yet it is the only language which enjoys "full"
        >> translation of the Vim help. Maybe we should declare that help
        >> translation is a fiasco for lack of adequate manpower?
        >
        > What is your 'enc' option set to when you use the :helptags command?
        > I believe it should work when it is utf-8, then the latin1 files can be
        > converted from latin1 to utf-8 and the generated tags file is in utf-8.
        > The digraph.txt file is also in latin1.
        >

        I did it in gvim (Huge) for GTK2/Gnome2, with 'encoding' set to UTF-8
        (my system locale is en_US.UTF-8, and my vimrc sets 'enc' to "utf-8"
        within an if clause: if has('multi_byte') | if &enc !~? '^u' | etc.). It
        truncated tags-fr to zero-length with error E670. I also have the
        following at the end of the vimrc section where I set 'enc' to UTF-8:

        set fencs=ucs-bom,utf-8,latin1
        setg bomb fenc=utf-8

        The file hebrew.frx (mentioned in the E670 error message) is distributed
        with a BOM but even after ":setl nobomb | x" I still got the error on a
        subsequent :helptags run (in the same gvim session).

        Yes, digraph.txt is also in 8-bit Latin1, and arabic.txt is in UTF-8 but
        without BOM, and its first multibyte codepoint is at line 282. English
        hebrew.txt (I don't have *.frx anymore, see below), is also in UTF-8
        without BOM, with the first multibyte codepoint at line 85.

        For some reason, "make install" which runs "make installruntime" which
        runs "make installrtbase" which runs "cd ../runtime/doc && make vimtags"
        which runs 'vim -u NONE -esX -c "helptags ++t ." -c quit', never gives
        me that error. Maybe it's the BOM after all.

        I finally did (before my OP actually)

        :!rm -vf tags-fr *.frx

        removing the whole French-language help.


        Best regards,
        Tony.
        --
        AMAZING BUT TRUE ...

        If all the salmon caught in Canada in one year were laid end to end
        across the Sahara Desert, the smell would be absolutely awful.

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.