Loading ...
Sorry, an error occurred while loading the content.

Re: vim-gnome: cannot use "set columns=1000 lines=1000" twice

Expand Messages
  • Tony Mechelynck
    ... Hm, yes, I see it also in 7.2.411 (owncompiled Huge +gui_gtk2 +gui_gnome). Clicking twice on the 2nd button from top right (Restore, then Maximize) repairs
    Message 1 of 2 , Apr 25, 2010
    • 0 Attachment
      On 24/04/10 18:22, Tom Link wrote:
      > Hi,
      >
      > Using
      >
      > set columns=1000 lines=1000
      >
      > is a commonly used trick to maximize gvim's window. If I execute this
      > line twice:
      >
      > set columns=1000 lines=1000
      > set columns=1000 lines=1000
      >
      > the command line vanishes and vim behaves as if it actually had that
      > much space available.
      >
      > Version: 7.2-330 vim-gnome, ubuntu 10.04.

      Hm, yes, I see it also in 7.2.411 (owncompiled Huge +gui_gtk2
      +gui_gnome). Clicking twice on the 2nd button from top right (Restore,
      then Maximize) repairs the damage -- maybe something could be done at
      the command-line but it's hard to use it when it's out of sight.

      When maximized above the tasbar with menus, toolbar, text-style tabline,
      and using my usual 'guifont' i.e. "Bitstream Vera Sans Mono 8", my gvim
      has lines=49 columns=143.

      Maybe that behaviour is intentional, for the cases when the system (X11,
      GTK2, whatever terminal Vim is running in in Console mode, ...) does not
      report the number of lines & columns correctly.

      >
      > BTW I have just recently started using the gnome version of gvim --
      > otherwise I mostly use the windows version. It seems to me that the
      > gnome version is rather sluggish in comparison and that the screen
      > gets updated more often. Is this a common observation?
      >
      > Regards,
      > Tom
      >

      Best regards,
      Tony.
      --
      "If I am elected, the concrete barriers around the WHITE HOUSE will be
      replaced by tasteful foam replicas of ANN MARGARET!"

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      Subscription settings: http://groups.google.com/group/vim_dev/subscribe?hl=en
    Your message has been successfully submitted and would be delivered to recipients shortly.