Loading ...
Sorry, an error occurred while loading the content.

Re: Patch 7.2.374

Expand Messages
  • Cesar Romani
    ... In that case it can be reverted for Windows. vim with ruby support v1.8.6, built fine until v7.2.360 on Windows. MOreover vim doesn t build yet with ruby
    Message 1 of 7 , Feb 25 6:51 AM
    • 0 Attachment
      Bram Moolenaar wrote:
      > Steve Hall wrote:
      >
      >> From: Bram Moolenaar, Wed, February 24, 2010 9:48 am
      >>> Patch 7.2.374
      >>> Problem: Ruby eval() doesn't understand Vim types.
      >>> Solution: Add the vim_to_ruby() function. (George Gensure)
      >>> Files: src/eval.c, src/if_ruby.c
      >> I'm still seeing build errors with Windows/Cygwin related to Ruby,
      >> hope this helps:
      >>
      >> gobj/if_ruby.o:if_ruby.c:(.text+0x9b5): undefined reference to
      >> `_rb_string_value_ptr'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xae3): undefined reference to
      >> `_rb_string_value_ptr'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xb0d): undefined reference to
      >> `_rb_string_value_ptr'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xbee): undefined reference to
      >> `_rb_float_new'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xbfd): undefined reference to
      >> `_rb_ary_new'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xc1c): undefined reference to
      >> `_rb_ary_push'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xc3d): undefined reference to
      >> `_rb_string_value_ptr'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0xf38): undefined reference to
      >> `_rb_string_value_ptr'
      >> gobj/if_ruby.o:if_ruby.c:(.text+0x1157): undefined reference to
      >> `_rb_string_value_ptr'
      >> collect2: ld returned 1 exit status
      >> make: *** [gvim.exe] Error 1
      >
      > Sorry, I still have no clue how to fix this without reverting that whole
      > patch. It builds fine on Linux, must be something MS-Windows or Cygwin
      > related. Did you try a MingW build?

      In that case it can be reverted for Windows.
      vim with ruby support v1.8.6, built fine until v7.2.360 on Windows.
      MOreover vim doesn't build yet with ruby support v1.9.1 either with
      DYNAMIC_RUBY=yes or no, on Windows.

      Regards,

      --
      Cesar

      --
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.