Loading ...
Sorry, an error occurred while loading the content.
 

[bug] --remote-silent

Expand Messages
  • nickles
    On Windows XP, with gvim 7.2-356 (and before), when using the following command line to edit the specified file gvim d: music soldiers USSR (Kazach ja).xml
    Message 1 of 8 , Feb 6, 2010
      On Windows XP, with gvim 7.2-356 (and before), when using the
      following command line to edit the specified file

      gvim d:\music\soldiers\USSR\(Kazach'ja).xml

      gvim will open with an empty buffer named

      "USSR(Kazach'ja).xml".

      This behavior is not observed when gvim is called with the same file
      name but w/o the "--remote-silent" option.

      A workaround for the problem is to insert a backslash in the middle of
      "\(", resulting in the following file name:

      d:\music\soldiers\USSR\\(Kazach'ja).xml.

      nickles

      --
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • Valery Kondakoff
      ... If I m trying to open a file like this: gvim.exe --remote-tab-silent c: MP3 XXX LIZA MINNELLI (1989) RESULTS info.txt gVim tries to open MP3 XXX LIZA
      Message 2 of 8 , Feb 8, 2010
        On 07.02.2010 2:35, nickles wrote:
        > On Windows XP, with gvim 7.2-356 (and before), when using the
        > following command line to edit the specified file
        > gvim d:\music\soldiers\USSR\(Kazach'ja).xml
        > gvim will open with an empty buffer named
        > "USSR(Kazach'ja).xml".

        I can confirm this. Here is my message to the list from May 5, 2008:

        -----
        If I'm trying to open a file like this:
        gvim.exe --remote-tab-silent "c:\MP3\XXX\LIZA MINNELLI\(1989)
        RESULTS\info.txt"
        gVim tries to open "\MP3\XXX\LIZA MINNELLI(1989) RESULTS\info.txt"
        resulting in a new file.

        If I'm trying to open the same file without the --remote-tab-silent
        option the info.txt file is opened as expected.
        It seems, when the --remote-tab-silent option is used, the '\('
        combination is counted as an escape-sequence, and this is wrong.
        Can we consider this as a bug?
        gVim 7.2, Win Vista HP SP1.
        -----

        --
        Best regards,
        Valery Kondakoff

        PGP key:
        http://pool.sks-keyservers.net:11371/pks/lookup?op=get&search=0xEEDF8590
        np: Bark Psychosis'1994 (Hex) - A Street Scene

        --
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • Bram Moolenaar
        ... Yeah, this looks like a bug. Did you try doubling the backslash? Or replace the ( with a ?. -- $ echo pizza /dev/oven /// Bram Moolenaar --
        Message 3 of 8 , Feb 8, 2010
          Valery Kondakoff wrote:

          > On 07.02.2010 2:35, nickles wrote:
          > > On Windows XP, with gvim 7.2-356 (and before), when using the
          > > following command line to edit the specified file
          > > gvim d:\music\soldiers\USSR\(Kazach'ja).xml
          > > gvim will open with an empty buffer named
          > > "USSR(Kazach'ja).xml".
          >
          > I can confirm this. Here is my message to the list from May 5, 2008:
          >
          > -----
          > If I'm trying to open a file like this:
          > gvim.exe --remote-tab-silent "c:\MP3\XXX\LIZA MINNELLI\(1989)
          > RESULTS\info.txt"
          > gVim tries to open "\MP3\XXX\LIZA MINNELLI(1989) RESULTS\info.txt"
          > resulting in a new file.
          >
          > If I'm trying to open the same file without the --remote-tab-silent
          > option the info.txt file is opened as expected.
          > It seems, when the --remote-tab-silent option is used, the '\('
          > combination is counted as an escape-sequence, and this is wrong.
          > Can we consider this as a bug?
          > gVim 7.2, Win Vista HP SP1.
          > -----

          Yeah, this looks like a bug. Did you try doubling the backslash?
          Or replace the ( with a ?.

          --
          $ echo pizza > /dev/oven

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ download, build and distribute -- http://www.A-A-P.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • Valery Kondakoff
          ... Yes, the file is loaded successfully when the backslash is doubled. -- Best regards, Valery Kondakoff PGP key:
          Message 4 of 8 , Feb 8, 2010
            On 08.02.2010 23:05, Bram Moolenaar wrote:
            > Yeah, this looks like a bug. Did you try doubling the backslash?

            Yes, the file is loaded successfully when the backslash is doubled.

            --
            Best regards,
            Valery Kondakoff

            PGP key:
            http://pool.sks-keyservers.net:11371/pks/lookup?op=get&search=0xEEDF8590
            np: The High Violets'2006 (To Where You Are) - Invitation

            --
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
          • Axel
            This error still appears in 7.3-353. Any plans for a fix? -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the
            Message 5 of 8 , Nov 4 3:36 AM
              This error still appears in 7.3-353. Any plans for a fix?

              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Yukihiro Nakadaira
              For --remote, files are opened with :drop command on remote vim. And :drop command removes backslash followed by special character. This behavior also occur
              Message 6 of 8 , Nov 4 6:10 AM
                For --remote, files are opened with :drop command on remote vim.
                And :drop command removes backslash followed by special character.
                This behavior also occur for ":edit aaa\(bbb).txt".
                :help filename-backslash
                Vim handles '(' as special character because it is not included in the
                default 'isfname' value.
                Add "set isfname+=(" in vimrc for workaround.

                --
                Yukihiro Nakadaira - yukihiro.nakadaira@...

                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Axel
                Thanks Yukihiro, that solved it! Best regards -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
                Message 7 of 8 , Nov 4 7:13 AM
                  Thanks Yukihiro, that solved it!

                  Best regards

                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Axel
                  *Addendum* Adding ( to isfname obviously breaks helpgrep s functionality, resulting in errors E55: unmatched ) followed by E480: No match: ... -- You
                  Message 8 of 8 , Nov 30 10:14 AM
                    Addendum

                    Adding "(" to 'isfname' obviously breaks helpgrep's functionality, resulting in errors

                    "E55: unmatched \)"

                    followed by

                    "E480: No match: ..."

                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.