Loading ...
Sorry, an error occurred while loading the content.
 

Re: Bug on FreeBSD 5.4

Expand Messages
  • Gary Johnson
    ... If you build it with debugging symbols enabled, you should be able to send it SIGABRT (kill -6) which should make it dump core before terminating. You can
    Message 1 of 27 , Dec 2, 2009
      On 2009-12-02, JD wrote:
      > Vim is hardlocking for me on every single run on my FreeBSD 5.4
      > system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
      >
      > It appears to compile fine, but on run, it fails to respond to any
      > keystrokes and eats nearly 100% of my CPU till I send it a
      > SIGKILL...Please help. :)

      If you build it with debugging symbols enabled, you should be able
      to send it SIGABRT (kill -6) which should make it dump core before
      terminating. You can then use gdb on the core file to examine the
      stack and maybe figure out what it was so busy doing.

      HTH,
      Gary


      --
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Does it always hang, even if you start it as vim -N -u NONE or gvim -N -u NONE ? Best regards, Tony. -- Re graphics: A picture is worth 10K words -- but
      Message 2 of 27 , Dec 2, 2009
        On 03/12/09 05:20, JD wrote:
        > Vim is hardlocking for me on every single run on my FreeBSD 5.4
        > system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
        >
        > It appears to compile fine, but on run, it fails to respond to any
        > keystrokes and eats nearly 100% of my CPU till I send it a
        > SIGKILL...Please help. :)
        >
        > Thanks
        >

        Does it always hang, even if you start it as

        vim -N -u NONE
        or
        gvim -N -u NONE
        ?


        Best regards,
        Tony.
        --
        Re graphics: A picture is worth 10K words -- but only those to describe
        the picture. Hardly any sets of 10K words can be adequately described
        with pictures.

        --
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • JD
        ... Thanks for the response Gary. I believe i built vim with debug symbols correctly, but after it hardlocks, kill -6 doesn t dump a core file anywhere i can
        Message 3 of 27 , Dec 2, 2009
          On Dec 3, 1:21 am, Gary Johnson <garyj...@...> wrote:
          > On 2009-12-02, JD wrote:
          > > Vim is hardlocking for me on every single run on my FreeBSD 5.4
          > > system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
          >
          > > It appears to compile fine, but on run, it fails to respond to any
          > > keystrokes and eats nearly 100% of my CPU till I send it a
          > > SIGKILL...Please help. :)
          >
          > If you build it with debugging symbols enabled, you should be able
          > to send it SIGABRT (kill -6) which should make it dump core before
          > terminating.  You can then use gdb on the core file to examine the
          > stack and maybe figure out what it was so busy doing.
          >
          > HTH,
          > Gary

          Thanks for the response Gary. I believe i built vim with debug symbols
          correctly, but after it hardlocks, kill -6 doesn't dump a core file
          anywhere i can see nor does it terminate the process....

          --
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • JD
          On Dec 3, 1:46 am, Tony Mechelynck ... It appears to work fine launching vim with -N -u NONE, when not launching with -N -u
          Message 4 of 27 , Dec 2, 2009
            On Dec 3, 1:46 am, Tony Mechelynck <antoine.mechely...@...>
            wrote:
            > On 03/12/09 05:20, JD wrote:
            >
            > > Vim is hardlocking for me on every single run on my FreeBSD 5.4
            > > system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
            >
            > > It appears to compile fine, but on run, it fails to respond to any
            > > keystrokes and eats nearly 100% of my CPU till I send it a
            > > SIGKILL...Please help. :)
            >
            > > Thanks
            >
            > Does it always hang, even if you start it as
            >
            >         vim -N -u NONE
            > or
            >         gvim -N -u NONE
            > ?
            >
            > Best regards,
            > Tony.
            > --
            > Re graphics: A picture is worth 10K words -- but only those to describe
            > the picture.  Hardly any sets of 10K words can be adequately described
            > with pictures.

            It appears to work fine launching vim with -N -u NONE, when not
            launching with '-N -u NONE', i've so far narrowed it down to 2
            filetypes. I tried opening a ruby script, a perl script, a python
            script and a C++ source file and the only ones that failed and caused
            vim to lock were the ruby script and the perl script. I moved the
            affected scripts to a different directory (same dir as the C++ source)
            and the issue still occurred and as far as i can tell, the permissions
            on all 4 files are the same.

            --
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
          • Michal Kurgan
            On Wed, 2 Dec 2009 22:55:10 -0800 (PST) ... Probably you need to set core file size limit too. For bash it is: ulimit -c -- Michal Kurgan -- You
            Message 5 of 27 , Dec 3, 2009
              On Wed, 2 Dec 2009 22:55:10 -0800 (PST)
              JD <jdhore1@...> wrote:

              > Thanks for the response Gary. I believe i built vim with debug symbols
              > correctly, but after it hardlocks, kill -6 doesn't dump a core file
              > anywhere i can see nor does it terminate the process....
              >

              Probably you need to set core file size limit too.
              For bash it is: ulimit -c <size>

              --
              Michal Kurgan


              --
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
            • JD
              ... I have my ulimit set to unlimited. :) -- You received this message from the vim_dev maillist. For more information, visit http://www.vim.org/maillist.php
              Message 6 of 27 , Dec 3, 2009
                On Dec 3, 3:04 am, Michal Kurgan <michal.kur...@...> wrote:
                > On Wed, 2 Dec 2009 22:55:10 -0800 (PST)
                >
                > JD <jdho...@...> wrote:
                > > Thanks for the response Gary. I believe i built vim with debug symbols
                > > correctly, but after it hardlocks, kill -6 doesn't dump a core file
                > > anywhere i can see nor does it terminate the process....
                >
                > Probably you need to set core file size limit too.
                > For bash it is: ulimit -c <size>
                >
                > --
                > Michal Kurgan

                I have my ulimit set to unlimited. :)

                --
                You received this message from the "vim_dev" maillist.
                For more information, visit http://www.vim.org/maillist.php
              • Dominique Pellé
                ... You can attach to the running process with gdb and look at the stack trace with backtrace gdb command. You can also use the continue gdb command and
                Message 7 of 27 , Dec 3, 2009
                  jdhore1@... wrote:

                  > Vim is hardlocking for me on every single run on my FreeBSD 5.4
                  > system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
                  >
                  > It appears to compile fine, but on run, it fails to respond to any
                  > keystrokes and eats nearly 100% of my CPU till I send it a
                  > SIGKILL...Please help. :)
                  >
                  > Thanks

                  You can attach to the running process with gdb and look at
                  the stack trace with 'backtrace' gdb command. You can also
                  use the 'continue' gdb command and interrupt again with CTRL-C
                  to run 'backtrace' several times (in case the backtrace is not always
                  the same).

                  Example:

                  $ gdb
                  ...
                  (gdb) attach PID
                  ...
                  (gdb) backtrace
                  ...
                  (gdb) continue
                  (gdb) CTRL-C
                  (gdb) backtrace


                  (replace PID with the process ID of the Vim process which hogs the CPU)

                  The output of backtrace may help to figure out why it hogs the CPU.
                  You will need to compile/link Vim with symbols (-g -O0) to get a proper
                  stack trace with gdb.

                  -- Dominique

                  --
                  You received this message from the "vim_dev" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                • Tony Mechelynck
                  ... Hm. This is a little bit out of my depth, but I suggest the following: - does the hang still happen when editing these filetypes in a Vim started with vim
                  Message 8 of 27 , Dec 3, 2009
                    On 03/12/09 08:03, JD wrote:
                    > On Dec 3, 1:46 am, Tony Mechelynck<antoine.mechely...@...>
                    > wrote:
                    >> On 03/12/09 05:20, JD wrote:
                    >>
                    >>> Vim is hardlocking for me on every single run on my FreeBSD 5.4
                    >>> system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
                    >>
                    >>> It appears to compile fine, but on run, it fails to respond to any
                    >>> keystrokes and eats nearly 100% of my CPU till I send it a
                    >>> SIGKILL...Please help. :)
                    >>
                    >>> Thanks
                    >>
                    >> Does it always hang, even if you start it as
                    >>
                    >> vim -N -u NONE
                    >> or
                    >> gvim -N -u NONE
                    >> ?
                    >>
                    >> Best regards,
                    >> Tony.
                    >> --
                    >> Re graphics: A picture is worth 10K words -- but only those to describe
                    >> the picture. Hardly any sets of 10K words can be adequately described
                    >> with pictures.
                    >
                    > It appears to work fine launching vim with -N -u NONE, when not
                    > launching with '-N -u NONE', i've so far narrowed it down to 2
                    > filetypes. I tried opening a ruby script, a perl script, a python
                    > script and a C++ source file and the only ones that failed and caused
                    > vim to lock were the ruby script and the perl script. I moved the
                    > affected scripts to a different directory (same dir as the C++ source)
                    > and the issue still occurred and as far as i can tell, the permissions
                    > on all 4 files are the same.
                    >

                    Hm. This is a little bit out of my depth, but I suggest the following:

                    - does the hang still happen when editing these filetypes in a Vim
                    started with

                    vim -u /usr/local/share/vim/vim72/vimrc_example.vim

                    ? (assuming that that's your $VIMRUNTIME directory -- it should be,
                    unless you changed the default at compile-time or unless you're using an
                    obsolete version older than 7.2.0)

                    - did you compile with +ruby or -ruby, +perl or -perl ? (see the output
                    of ":version" -- if you enable them at configure-time, but configure
                    doesn't find the right files, it will turn them off)
                    - do you have any "custom" scripts (scripts not distributed with Vim)
                    which apply to Perl and/or Ruby? (and which ones if you do?)
                    - what are the dates mentioned near the top of the _text_ of the
                    following scripts? I'm mentioning what I see in mine

                    $VIMRUNTIME/filetype.vim 2009 Sep 18
                    $VIMRUNTIME/ftplugin/perl.vim 20 Jan 2009
                    $VIMRUNTIME/ftplugin/ruby.vim 2008/06/29 04:18:43
                    $VIMRUNTIME/syntax/perl.vim 2006 November 23
                    $VIMRUNTIME/syntax/ruby.vim 2008/06/29 04:33:41
                    $VIMRUNTIME/indent/perl.vim 2005 Sep 07
                    $VIMRUNTIME/indent/ruby.vim 2008/06/29 04:18:43

                    - does the hang happen if you do
                    (a) syntax off
                    (b) filetype indent off
                    (c) filetype plugin off
                    before editing the files? (try them one at a time, and turn them back on
                    afterwards)


                    Best regards,
                    Tony.
                    --
                    The law will never make men free; it is men who have got to make the
                    law free.
                    -- Henry David Thoreau

                    --
                    You received this message from the "vim_dev" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                  • Tony Mechelynck
                    On 03/12/09 09:58, Dominique Pellé wrote: [...] ... ...and, of course, run the non-stripped executable, i.e., the one in the same directory as the source, NOT
                    Message 9 of 27 , Dec 3, 2009
                      On 03/12/09 09:58, Dominique Pellé wrote:
                      [...]
                      > The output of backtrace may help to figure out why it hogs the CPU.
                      > You will need to compile/link Vim with symbols (-g -O0) to get a proper
                      > stack trace with gdb.
                      >
                      > -- Dominique
                      >

                      ...and, of course, run the non-stripped executable, i.e., the one in the
                      same directory as the source, NOT the one which "make install" copied
                      into the $PATH.


                      Best regards,
                      Tony.
                      --
                      It has been said that man is a rational animal. All my life I have
                      been searching for evidence which could support this.
                      -- Bertrand Russell

                      --
                      You received this message from the "vim_dev" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                    • JD
                      On Dec 3, 4:26 am, Tony Mechelynck ... Here s the output of version: VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Dec 3 2009
                      Message 10 of 27 , Dec 3, 2009
                        On Dec 3, 4:26 am, Tony Mechelynck <antoine.mechely...@...>
                        wrote:
                        > On 03/12/09 08:03, JD wrote:
                        >
                        >
                        >
                        > > On Dec 3, 1:46 am, Tony Mechelynck<antoine.mechely...@...>
                        > > wrote:
                        > >> On 03/12/09 05:20, JD wrote:
                        >
                        > >>> Vim is hardlocking for me on every single run on my FreeBSD 5.4
                        > >>> system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
                        >
                        > >>> It appears to compile fine, but on run, it fails to respond to any
                        > >>> keystrokes and eats nearly 100% of my CPU till I send it a
                        > >>> SIGKILL...Please help. :)
                        >
                        > >>> Thanks
                        >
                        > >> Does it always hang, even if you start it as
                        >
                        > >>          vim -N -u NONE
                        > >> or
                        > >>          gvim -N -u NONE
                        > >> ?
                        >
                        > >> Best regards,
                        > >> Tony.
                        > >> --
                        > >> Re graphics: A picture is worth 10K words -- but only those to describe
                        > >> the picture.  Hardly any sets of 10K words can be adequately described
                        > >> with pictures.
                        >
                        > > It appears to work fine launching vim with -N -u NONE, when not
                        > > launching with '-N -u NONE', i've so far narrowed it down to 2
                        > > filetypes. I tried opening a ruby script, a perl script, a python
                        > > script and a C++ source file and the only ones that failed and caused
                        > > vim to lock were the ruby script and the perl script. I moved the
                        > > affected scripts to a different directory (same dir as the C++ source)
                        > > and the issue still occurred and as far as i can tell, the permissions
                        > > on all 4 files are the same.
                        >
                        > Hm. This is a little bit out of my depth, but I suggest the following:
                        >
                        > - does the hang still happen when editing these filetypes in a Vim
                        > started with
                        >
                        >         vim -u /usr/local/share/vim/vim72/vimrc_example.vim
                        >
                        > ? (assuming that that's your $VIMRUNTIME directory -- it should be,
                        > unless you changed the default at compile-time or unless you're using an
                        > obsolete version older than 7.2.0)
                        >
                        > - did you compile with +ruby or -ruby, +perl or -perl ? (see the output
                        > of ":version" -- if you enable them at configure-time, but configure
                        > doesn't find the right files, it will turn them off)
                        > - do you have any "custom" scripts (scripts not distributed with Vim)
                        > which apply to Perl and/or Ruby? (and which ones if you do?)
                        > - what are the dates mentioned near the top of the _text_ of the
                        > following scripts? I'm mentioning what I see in mine
                        >
                        >         $VIMRUNTIME/filetype.vim        2009 Sep 18
                        >         $VIMRUNTIME/ftplugin/perl.vim   20 Jan 2009
                        >         $VIMRUNTIME/ftplugin/ruby.vim   2008/06/29 04:18:43
                        >         $VIMRUNTIME/syntax/perl.vim     2006 November 23
                        >         $VIMRUNTIME/syntax/ruby.vim     2008/06/29 04:33:41
                        >         $VIMRUNTIME/indent/perl.vim     2005 Sep 07
                        >         $VIMRUNTIME/indent/ruby.vim     2008/06/29 04:18:43
                        >
                        > - does the hang happen if you do
                        >         (a) syntax off
                        >         (b) filetype indent off
                        >         (c) filetype plugin off
                        > before editing the files? (try them one at a time, and turn them back on
                        > afterwards)
                        >
                        > Best regards,
                        > Tony.
                        > --
                        > The law will never make men free; it is men who have got to make the
                        > law free.
                        >                 -- Henry David Thoreau

                        Here's the output of version:

                        VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Dec 3 2009 06:48:09)
                        Included patches: 1-315
                        Compiled by jdhore@...
                        Big version with GTK GUI. Features included (+) or not (-):
                        +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                        +cindent
                        +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                        +comments
                        +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -
                        ebcdic
                        +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
                        +find_in_path
                        +float +folding -footer +fork() +gettext -hangul_input +iconv
                        +insert_expand
                        +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
                        +localmap
                        +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec -
                        mouse_gpm
                        -mouse_jsbterm +mouse_netterm +mouse_sysmouse +mouse_xterm
                        +multi_byte
                        +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl
                        +postscript
                        +printer -profile -python +quickfix +reltime +rightleft -ruby
                        +scrollbind
                        +signs +smartindent -sniff +startuptime +statusline -sun_workshop
                        +syntax
                        +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                        +termresponse
                        +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                        +visual
                        +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                        +writebackup
                        +X11 +xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                        system vimrc file: "$VIM/vimrc"
                        user vimrc file: "$HOME/.vimrc"
                        user exrc file: "$HOME/.exrc"
                        system gvimrc file: "$VIM/gvimrc"
                        user gvimrc file: "$HOME/.gvimrc"
                        system menu file: "$VIMRUNTIME/menu.vim"
                        fall-back for $VIM: "/usr/local/share/vim"
                        Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/
                        local/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -
                        I/usr/X11R6/include -I/usr/local/include -g
                        Linking: gcc -L/usr/local/lib -o vim -L/usr/local/lib -L/usr/X11R6/
                        lib -lgtk-12 -lgdk-12 -Wl,-E -lgmodule-12 -lglib-12 -lintl -lXi -lXext
                        -lXt -lm -lncurses -lintl

                        dates of those files:

                        $VIMRUNTIME/filetype.vim 2009 Dec 3 06:48 (UTC/GMT)
                        $VIMRUNTIME/ftplugin/perl.vim 2009 Dec 3 06:48
                        $VIMRUNTIME/ftplugin/ruby.vim 2009 Dec 3 06:48
                        $VIMRUNTIME/syntax/perl.vim 2009 Dec 3 06:48
                        $VIMRUNTIME/syntax/ruby.vim 2009 Dec 3 06:48
                        $VIMRUNTIME/indent/perl.vim 2009 Dec 3 06:48
                        $VIMRUNTIME/indent/ruby.vim 2009 Dec 3 06:48

                        The only custom scripts i have installed are: SyntaxAttr, BufExplorer,
                        securemodelines and taglist none of which (i believe) are ruby/perl
                        specific.

                        When i ran with 'vim -u /usr/local/share/vim/vim72/vimrc_example.vim',
                        it still hung. Also, gdb hasn't given me a useful backtrace.

                        With syntax, indent and plugin all off, the file(s) open fine.With
                        just syntax on, the file(s) open fine. With syntax and indent on, the
                        file(s) open fine. When i enabled plugin, that's when vim started
                        hanging. I removed all 4 plugins from .vim/plugin (the only place i
                        have any plugins) and with 'filetype plugin on', it still hung.

                        --
                        You received this message from the "vim_dev" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                      • Tony Mechelynck
                        ... No perl and no ruby. If the ftplugins assume that you got the interfaces if you edit the files, you re stuck. The versions I have don t seem to, though
                        Message 11 of 27 , Dec 3, 2009
                          On 03/12/09 21:16, JD wrote:
                          > On Dec 3, 4:26 am, Tony Mechelynck<antoine.mechely...@...>
                          > wrote:
                          >> On 03/12/09 08:03, JD wrote:
                          >>
                          >>
                          >>
                          >>> On Dec 3, 1:46 am, Tony Mechelynck<antoine.mechely...@...>
                          >>> wrote:
                          >>>> On 03/12/09 05:20, JD wrote:
                          >>
                          >>>>> Vim is hardlocking for me on every single run on my FreeBSD 5.4
                          >>>>> system. I've tried 7.2.299, 7.2.309 and 7.2.315 and all are broken.
                          >>
                          >>>>> It appears to compile fine, but on run, it fails to respond to any
                          >>>>> keystrokes and eats nearly 100% of my CPU till I send it a
                          >>>>> SIGKILL...Please help. :)
                          >>
                          >>>>> Thanks
                          >>
                          >>>> Does it always hang, even if you start it as
                          >>
                          >>>> vim -N -u NONE
                          >>>> or
                          >>>> gvim -N -u NONE
                          >>>> ?
                          >>
                          >>>> Best regards,
                          >>>> Tony.
                          >>>> --
                          >>>> Re graphics: A picture is worth 10K words -- but only those to describe
                          >>>> the picture. Hardly any sets of 10K words can be adequately described
                          >>>> with pictures.
                          >>
                          >>> It appears to work fine launching vim with -N -u NONE, when not
                          >>> launching with '-N -u NONE', i've so far narrowed it down to 2
                          >>> filetypes. I tried opening a ruby script, a perl script, a python
                          >>> script and a C++ source file and the only ones that failed and caused
                          >>> vim to lock were the ruby script and the perl script. I moved the
                          >>> affected scripts to a different directory (same dir as the C++ source)
                          >>> and the issue still occurred and as far as i can tell, the permissions
                          >>> on all 4 files are the same.
                          >>
                          >> Hm. This is a little bit out of my depth, but I suggest the following:
                          >>
                          >> - does the hang still happen when editing these filetypes in a Vim
                          >> started with
                          >>
                          >> vim -u /usr/local/share/vim/vim72/vimrc_example.vim
                          >>
                          >> ? (assuming that that's your $VIMRUNTIME directory -- it should be,
                          >> unless you changed the default at compile-time or unless you're using an
                          >> obsolete version older than 7.2.0)
                          >>
                          >> - did you compile with +ruby or -ruby, +perl or -perl ? (see the output
                          >> of ":version" -- if you enable them at configure-time, but configure
                          >> doesn't find the right files, it will turn them off)
                          >> - do you have any "custom" scripts (scripts not distributed with Vim)
                          >> which apply to Perl and/or Ruby? (and which ones if you do?)
                          >> - what are the dates mentioned near the top of the _text_ of the
                          >> following scripts? I'm mentioning what I see in mine
                          >>
                          >> $VIMRUNTIME/filetype.vim 2009 Sep 18
                          >> $VIMRUNTIME/ftplugin/perl.vim 20 Jan 2009
                          >> $VIMRUNTIME/ftplugin/ruby.vim 2008/06/29 04:18:43
                          >> $VIMRUNTIME/syntax/perl.vim 2006 November 23
                          >> $VIMRUNTIME/syntax/ruby.vim 2008/06/29 04:33:41
                          >> $VIMRUNTIME/indent/perl.vim 2005 Sep 07
                          >> $VIMRUNTIME/indent/ruby.vim 2008/06/29 04:18:43
                          >>
                          >> - does the hang happen if you do
                          >> (a) syntax off
                          >> (b) filetype indent off
                          >> (c) filetype plugin off
                          >> before editing the files? (try them one at a time, and turn them back on
                          >> afterwards)
                          >>
                          >> Best regards,
                          >> Tony.
                          >> --
                          >> The law will never make men free; it is men who have got to make the
                          >> law free.
                          >> -- Henry David Thoreau
                          >
                          > Here's the output of version:
                          >
                          > VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Dec 3 2009 06:48:09)
                          > Included patches: 1-315
                          > Compiled by jdhore@...
                          > Big version with GTK GUI. Features included (+) or not (-):
                          > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                          > +cindent
                          > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                          > +comments
                          > +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -
                          > ebcdic
                          > +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
                          > +find_in_path
                          > +float +folding -footer +fork() +gettext -hangul_input +iconv
                          > +insert_expand
                          > +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
                          > +localmap
                          > +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec -
                          > mouse_gpm
                          > -mouse_jsbterm +mouse_netterm +mouse_sysmouse +mouse_xterm
                          > +multi_byte
                          > +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl
                          > +postscript
                          > +printer -profile -python +quickfix +reltime +rightleft -ruby
                          > +scrollbind
                          > +signs +smartindent -sniff +startuptime +statusline -sun_workshop
                          > +syntax
                          > +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                          > +termresponse
                          > +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                          > +visual
                          > +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                          > +writebackup
                          > +X11 +xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                          > system vimrc file: "$VIM/vimrc"
                          > user vimrc file: "$HOME/.vimrc"
                          > user exrc file: "$HOME/.exrc"
                          > system gvimrc file: "$VIM/gvimrc"
                          > user gvimrc file: "$HOME/.gvimrc"
                          > system menu file: "$VIMRUNTIME/menu.vim"
                          > fall-back for $VIM: "/usr/local/share/vim"
                          > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/
                          > local/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -
                          > I/usr/X11R6/include -I/usr/local/include -g
                          > Linking: gcc -L/usr/local/lib -o vim -L/usr/local/lib -L/usr/X11R6/
                          > lib -lgtk-12 -lgdk-12 -Wl,-E -lgmodule-12 -lglib-12 -lintl -lXi -lXext
                          > -lXt -lm -lncurses -lintl

                          No perl and no ruby. If the ftplugins assume that you got the interfaces
                          if you edit the files, you're stuck. The versions I have don't seem to,
                          though (ftplugin/perl.vim doesn't call the Vim/Perl interface and
                          ftplugin/ruby.vim properly tests <if has("ruby")> AFAICT. However, there
                          could be something I didn't notice.

                          >
                          > dates of those files:
                          >
                          > $VIMRUNTIME/filetype.vim 2009 Dec 3 06:48 (UTC/GMT)
                          > $VIMRUNTIME/ftplugin/perl.vim 2009 Dec 3 06:48
                          > $VIMRUNTIME/ftplugin/ruby.vim 2009 Dec 3 06:48
                          > $VIMRUNTIME/syntax/perl.vim 2009 Dec 3 06:48
                          > $VIMRUNTIME/syntax/ruby.vim 2009 Dec 3 06:48
                          > $VIMRUNTIME/indent/perl.vim 2009 Dec 3 06:48
                          > $VIMRUNTIME/indent/ruby.vim 2009 Dec 3 06:48

                          Sorry, you misunderstood me. I didn't want the modification dates as set
                          out in the directory (which are the dates you installed these files) but
                          the dates mentioned in the _text_ of the files, somewhere near the top,
                          which are the "Last change" dates written there by whoever edited them.

                          >
                          > The only custom scripts i have installed are: SyntaxAttr, BufExplorer,
                          > securemodelines and taglist none of which (i believe) are ruby/perl
                          > specific.
                          >
                          > When i ran with 'vim -u /usr/local/share/vim/vim72/vimrc_example.vim',
                          > it still hung. Also, gdb hasn't given me a useful backtrace.
                          >
                          > With syntax, indent and plugin all off, the file(s) open fine.With
                          > just syntax on, the file(s) open fine. With syntax and indent on, the
                          > file(s) open fine. When i enabled plugin, that's when vim started
                          > hanging. I removed all 4 plugins from .vim/plugin (the only place i
                          > have any plugins) and with 'filetype plugin on', it still hung.
                          >

                          You also have the filetype-plugins distributed with Vim, namely
                          $VIMRUNTIME/ftplugin/perl.vim and $VIMRUNTIME/ftplugin/ruby.vim. These
                          are enabled/disabled by "filetype plugin on/off".


                          Best regards,
                          Tony.
                          --
                          "The identical is equal to itself, since it is different."
                          -- Franco Spisani

                          --
                          You received this message from the "vim_dev" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                        • Gregory Margo
                          ... No offense, but are you really using such an old (2005-vintage) FreeBSD release? Or is it really OpenBSD 5.4, a much more recent product? --
                          Message 12 of 27 , Dec 3, 2009
                            On Wed, Dec 02, 2009 at 08:20:40PM -0800, JD wrote:
                            > Vim is hardlocking ... FreeBSD 5.4

                            No offense, but are you really using such an old (2005-vintage) FreeBSD release?

                            Or is it really OpenBSD 5.4, a much more recent product?

                            --
                            +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
                            Gregory H. Margo
                            gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org

                            --
                            You received this message from the "vim_dev" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                          • JD
                            ... Because it s a production-level server (with well over a 2 years of uptime at this point) and it s in a remote location and FreeBSD is not a good OS to
                            Message 13 of 27 , Dec 3, 2009
                              On Dec 3, 10:21 pm, Gregory Margo <gma...@...> wrote:
                              > On Wed, Dec 02, 2009 at 08:20:40PM -0800, JD wrote:
                              > > Vim is hardlocking ... FreeBSD 5.4
                              >
                              > No offense, but are you really using such an old (2005-vintage) FreeBSD release?
                              >
                              > Or is it really OpenBSD 5.4, a much more recent product?
                              >
                              > --
                              > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
                              > Gregory H. Margo
                              > gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org

                              Because it's a production-level server (with well over a 2 years of
                              uptime at this point) and it's in a remote location and FreeBSD is not
                              a good OS to update remotely if you follow the recommended way to
                              update.

                              --
                              You received this message from the "vim_dev" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                            • JD
                              On Dec 3, 7:24 pm, Tony Mechelynck ... Hey Tony, Yeah, it appears I did misunderstand you, sorry. Also, sorry i took so long
                              Message 14 of 27 , Dec 7, 2009
                                On Dec 3, 7:24 pm, Tony Mechelynck <antoine.mechely...@...>
                                wrote:
                                > On 03/12/09 21:16, JD wrote:
                                >
                                >
                                >
                                > > Here's the output of version:
                                >
                                > > VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Dec  3 2009 06:48:09)
                                > > Included patches: 1-315
                                > > Compiled by jdh...@...
                                > > Big version with GTK GUI.  Features included (+) or not (-):
                                > > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                                > > +cindent
                                > > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                                > > +comments
                                > > +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -
                                > > ebcdic
                                > > +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
                                > > +find_in_path
                                > > +float +folding -footer +fork() +gettext -hangul_input +iconv
                                > > +insert_expand
                                > > +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
                                > > +localmap
                                > > +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec -
                                > > mouse_gpm
                                > > -mouse_jsbterm +mouse_netterm +mouse_sysmouse +mouse_xterm
                                > > +multi_byte
                                > > +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl
                                > > +postscript
                                > > +printer -profile -python +quickfix +reltime +rightleft -ruby
                                > > +scrollbind
                                > > +signs +smartindent -sniff +startuptime +statusline -sun_workshop
                                > > +syntax
                                > > +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                                > > +termresponse
                                > > +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                                > > +visual
                                > > +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                                > > +writebackup
                                > > +X11 +xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                                > >     system vimrc file: "$VIM/vimrc"
                                > >       user vimrc file: "$HOME/.vimrc"
                                > >        user exrc file: "$HOME/.exrc"
                                > >    system gvimrc file: "$VIM/gvimrc"
                                > >      user gvimrc file: "$HOME/.gvimrc"
                                > >      system menu file: "$VIMRUNTIME/menu.vim"
                                > >    fall-back for $VIM: "/usr/local/share/vim"
                                > > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/usr/
                                > > local/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -
                                > > I/usr/X11R6/include -I/usr/local/include  -g
                                > > Linking: gcc   -L/usr/local/lib -o vim   -L/usr/local/lib -L/usr/X11R6/
                                > > lib -lgtk-12 -lgdk-12 -Wl,-E -lgmodule-12 -lglib-12 -lintl -lXi -lXext
                                > > -lXt -lm -lncurses  -lintl
                                >
                                > No perl and no ruby. If the ftplugins assume that you got the interfaces
                                > if you edit the files, you're stuck. The versions I have don't seem to,
                                > though (ftplugin/perl.vim doesn't call the Vim/Perl interface and
                                > ftplugin/ruby.vim properly tests <if has("ruby")> AFAICT. However, there
                                > could be something I didn't notice.
                                >
                                >
                                >
                                > > dates of those files:
                                >
                                > > $VIMRUNTIME/filetype.vim        2009 Dec 3 06:48 (UTC/GMT)
                                > > $VIMRUNTIME/ftplugin/perl.vim   2009 Dec 3 06:48
                                > > $VIMRUNTIME/ftplugin/ruby.vim   2009 Dec 3 06:48
                                > > $VIMRUNTIME/syntax/perl.vim     2009 Dec 3 06:48
                                > > $VIMRUNTIME/syntax/ruby.vim     2009 Dec 3 06:48
                                > > $VIMRUNTIME/indent/perl.vim     2009 Dec 3 06:48
                                > > $VIMRUNTIME/indent/ruby.vim     2009 Dec 3 06:48
                                >
                                > Sorry, you misunderstood me. I didn't want the modification dates as set
                                > out in the directory (which are the dates you installed these files) but
                                > the dates mentioned in the _text_ of the files, somewhere near the top,
                                > which are the "Last change" dates written there by whoever edited them.
                                >
                                >
                                >
                                > > The only custom scripts i have installed are: SyntaxAttr, BufExplorer,
                                > > securemodelines and taglist none of which (i believe) are ruby/perl
                                > > specific.
                                >
                                > > When i ran with 'vim -u /usr/local/share/vim/vim72/vimrc_example.vim',
                                > > it still hung. Also, gdb hasn't given me a useful backtrace.
                                >
                                > > With syntax, indent and plugin all off, the file(s) open fine.With
                                > > just syntax on, the file(s) open fine. With syntax and indent on, the
                                > > file(s) open fine. When i enabled plugin, that's when vim started
                                > > hanging. I removed all 4 plugins from .vim/plugin (the only place i
                                > > have any plugins) and with 'filetype plugin on', it still hung.
                                >
                                > You also have the filetype-plugins distributed with Vim, namely
                                > $VIMRUNTIME/ftplugin/perl.vim and $VIMRUNTIME/ftplugin/ruby.vim. These
                                > are enabled/disabled by "filetype plugin on/off".
                                >
                                > Best regards,
                                > Tony.
                                > --
                                > "The identical is equal to itself, since it is different."
                                >                 -- Franco Spisani

                                Hey Tony,

                                Yeah, it appears I did misunderstand you, sorry. Also, sorry i took so
                                long responding. I was out-of-town and didn't have my SSH keys with
                                me. :D Since the issue only seems to be ftplugin related, i'll just
                                paste the last modified dates for those:

                                $VIMRUNTIME/ftplugin/ruby.vim 2008/08/09 17:50:07
                                $VIMRUNTIME/ftplugin/perl.vim 17 Jul 2008

                                Also, I had a friend test this bug on FreeBSD 6.4 and a different
                                friend test on FreeBSD 7.1 and the files i was having issues with with
                                filetype plugin on worked fine for the blokes on the newer FreeBSD's.

                                I also just tried with versions/last modified dates:

                                $VIMRUNTIME/ftplugin/ruby.vim ruby.vim,v 1.40 2008/06/29 04:18:43
                                tpope
                                $VIMRUNTIME/ftplugin/perl.vim 20 Jan 2009

                                and i still had the issue. The only idea i have to possibly narrow
                                this down is that the bug popped up sometime from vim 7.2.239 and
                                7.2.299, I know that's a quite big range, but I originally had Vim
                                installed from ports with version 7.2.239 and AFAIK, everything worked
                                great, upgraded to 7.2.299 and this issue started cropping up or i
                                just started noticing it.

                                --
                                You received this message from the "vim_dev" maillist.
                                For more information, visit http://www.vim.org/maillist.php
                              • Tony Mechelynck
                                ... Well, sorry _I_ took so long responding, it s just my Vim inbox is so full that sometimes I lose track of some threads. (Oldest unread currently
                                Message 15 of 27 , Dec 9, 2009
                                  On 07/12/09 10:43, JD wrote:
                                  > On Dec 3, 7:24 pm, Tony Mechelynck<antoine.mechely...@...>
                                  > wrote:
                                  >> On 03/12/09 21:16, JD wrote:
                                  >>
                                  >>
                                  >>
                                  >>> Here's the output of version:
                                  >>
                                  >>> VIM - Vi IMproved 7.2 (2008 Aug 9, compiled Dec 3 2009 06:48:09)
                                  >>> Included patches: 1-315
                                  >>> Compiled by jdh...@...
                                  >>> Big version with GTK GUI. Features included (+) or not (-):
                                  >>> +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                                  >>> +cindent
                                  >>> +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                                  >>> +comments
                                  >>> +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -
                                  >>> ebcdic
                                  >>> +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
                                  >>> +find_in_path
                                  >>> +float +folding -footer +fork() +gettext -hangul_input +iconv
                                  >>> +insert_expand
                                  >>> +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
                                  >>> +localmap
                                  >>> +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec -
                                  >>> mouse_gpm
                                  >>> -mouse_jsbterm +mouse_netterm +mouse_sysmouse +mouse_xterm
                                  >>> +multi_byte
                                  >>> +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl
                                  >>> +postscript
                                  >>> +printer -profile -python +quickfix +reltime +rightleft -ruby
                                  >>> +scrollbind
                                  >>> +signs +smartindent -sniff +startuptime +statusline -sun_workshop
                                  >>> +syntax
                                  >>> +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                                  >>> +termresponse
                                  >>> +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                                  >>> +visual
                                  >>> +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                                  >>> +writebackup
                                  >>> +X11 +xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                                  >>> system vimrc file: "$VIM/vimrc"
                                  >>> user vimrc file: "$HOME/.vimrc"
                                  >>> user exrc file: "$HOME/.exrc"
                                  >>> system gvimrc file: "$VIM/gvimrc"
                                  >>> user gvimrc file: "$HOME/.gvimrc"
                                  >>> system menu file: "$VIMRUNTIME/menu.vim"
                                  >>> fall-back for $VIM: "/usr/local/share/vim"
                                  >>> Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/
                                  >>> local/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -
                                  >>> I/usr/X11R6/include -I/usr/local/include -g
                                  >>> Linking: gcc -L/usr/local/lib -o vim -L/usr/local/lib -L/usr/X11R6/
                                  >>> lib -lgtk-12 -lgdk-12 -Wl,-E -lgmodule-12 -lglib-12 -lintl -lXi -lXext
                                  >>> -lXt -lm -lncurses -lintl
                                  >>
                                  >> No perl and no ruby. If the ftplugins assume that you got the interfaces
                                  >> if you edit the files, you're stuck. The versions I have don't seem to,
                                  >> though (ftplugin/perl.vim doesn't call the Vim/Perl interface and
                                  >> ftplugin/ruby.vim properly tests<if has("ruby")> AFAICT. However, there
                                  >> could be something I didn't notice.
                                  >>
                                  >>
                                  >>
                                  >>> dates of those files:
                                  >>
                                  >>> $VIMRUNTIME/filetype.vim 2009 Dec 3 06:48 (UTC/GMT)
                                  >>> $VIMRUNTIME/ftplugin/perl.vim 2009 Dec 3 06:48
                                  >>> $VIMRUNTIME/ftplugin/ruby.vim 2009 Dec 3 06:48
                                  >>> $VIMRUNTIME/syntax/perl.vim 2009 Dec 3 06:48
                                  >>> $VIMRUNTIME/syntax/ruby.vim 2009 Dec 3 06:48
                                  >>> $VIMRUNTIME/indent/perl.vim 2009 Dec 3 06:48
                                  >>> $VIMRUNTIME/indent/ruby.vim 2009 Dec 3 06:48
                                  >>
                                  >> Sorry, you misunderstood me. I didn't want the modification dates as set
                                  >> out in the directory (which are the dates you installed these files) but
                                  >> the dates mentioned in the _text_ of the files, somewhere near the top,
                                  >> which are the "Last change" dates written there by whoever edited them.
                                  >>
                                  >>
                                  >>
                                  >>> The only custom scripts i have installed are: SyntaxAttr, BufExplorer,
                                  >>> securemodelines and taglist none of which (i believe) are ruby/perl
                                  >>> specific.
                                  >>
                                  >>> When i ran with 'vim -u /usr/local/share/vim/vim72/vimrc_example.vim',
                                  >>> it still hung. Also, gdb hasn't given me a useful backtrace.
                                  >>
                                  >>> With syntax, indent and plugin all off, the file(s) open fine.With
                                  >>> just syntax on, the file(s) open fine. With syntax and indent on, the
                                  >>> file(s) open fine. When i enabled plugin, that's when vim started
                                  >>> hanging. I removed all 4 plugins from .vim/plugin (the only place i
                                  >>> have any plugins) and with 'filetype plugin on', it still hung.
                                  >>
                                  >> You also have the filetype-plugins distributed with Vim, namely
                                  >> $VIMRUNTIME/ftplugin/perl.vim and $VIMRUNTIME/ftplugin/ruby.vim. These
                                  >> are enabled/disabled by "filetype plugin on/off".
                                  >>
                                  >> Best regards,
                                  >> Tony.
                                  >> --
                                  >> "The identical is equal to itself, since it is different."
                                  >> -- Franco Spisani
                                  >
                                  > Hey Tony,
                                  >
                                  > Yeah, it appears I did misunderstand you, sorry. Also, sorry i took so
                                  > long responding. I was out-of-town and didn't have my SSH keys with
                                  > me. :D Since the issue only seems to be ftplugin related, i'll just
                                  > paste the last modified dates for those:

                                  Well, sorry _I_ took so long responding, it's just my Vim inbox is so
                                  full that sometimes I lose track of some threads. (Oldest unread
                                  currently 2009-11-22)

                                  >
                                  > $VIMRUNTIME/ftplugin/ruby.vim 2008/08/09 17:50:07
                                  > $VIMRUNTIME/ftplugin/perl.vim 17 Jul 2008
                                  >
                                  > Also, I had a friend test this bug on FreeBSD 6.4 and a different
                                  > friend test on FreeBSD 7.1 and the files i was having issues with with
                                  > filetype plugin on worked fine for the blokes on the newer FreeBSD's.
                                  >
                                  > I also just tried with versions/last modified dates:
                                  >
                                  > $VIMRUNTIME/ftplugin/ruby.vim ruby.vim,v 1.40 2008/06/29 04:18:43
                                  > tpope
                                  > $VIMRUNTIME/ftplugin/perl.vim 20 Jan 2009

                                  These are the ones I have, which are the latest ones on the rsync
                                  server. Did you check the syntax scripts? I suppose they wouldn't be
                                  obsolete, though, if you have this.

                                  >
                                  > and i still had the issue. The only idea i have to possibly narrow
                                  > this down is that the bug popped up sometime from vim 7.2.239 and
                                  > 7.2.299, I know that's a quite big range, but I originally had Vim
                                  > installed from ports with version 7.2.239 and AFAIK, everything worked
                                  > great, upgraded to 7.2.299 and this issue started cropping up or i
                                  > just started noticing it.
                                  >

                                  Well, unless you have something Perl- or Ruby-related somewhere (at any
                                  depth) under $VIM/vimfiles/ and/or ~/.vim/ (and/or in your vimrc and/or
                                  gvimrc) then I don't know what can have gone wrong.

                                  You wouldn't have a "system vimrc" or "system gvimrc", would you? Check
                                  their locations near the middle of the ":version" output: on some OSes
                                  the software distributor installs a system vimrc and/or gvimrc,
                                  unbeknownst to the users.


                                  Best regards,
                                  Tony.
                                  --
                                  Life is like a simile.

                                  --
                                  You received this message from the "vim_dev" maillist.
                                  For more information, visit http://www.vim.org/maillist.php
                                • JD
                                  On Dec 9, 8:29 am, Tony Mechelynck ... Hey again tony, :D Here s the dates for the syntax files, but i somewhat doubt they have
                                  Message 16 of 27 , Dec 9, 2009
                                    On Dec 9, 8:29 am, Tony Mechelynck <antoine.mechely...@...>
                                    wrote:
                                    > On 07/12/09 10:43, JD wrote:
                                    >
                                    >
                                    > > Hey Tony,
                                    >
                                    > > Yeah, it appears I did misunderstand you, sorry. Also, sorry i took so
                                    > > long responding. I was out-of-town and didn't have my SSH keys with
                                    > > me. :D Since the issue only seems to be ftplugin related, i'll just
                                    > > paste the last modified dates for those:
                                    >
                                    > Well, sorry _I_ took so long responding, it's just my Vim inbox is so
                                    > full that sometimes I lose track of some threads. (Oldest unread
                                    > currently 2009-11-22)
                                    >
                                    >
                                    >
                                    > > $VIMRUNTIME/ftplugin/ruby.vim   2008/08/09 17:50:07
                                    > > $VIMRUNTIME/ftplugin/perl.vim    17 Jul 2008
                                    >
                                    > > Also, I had a friend test this bug on FreeBSD 6.4 and a different
                                    > > friend test on FreeBSD 7.1 and the files i was having issues with with
                                    > > filetype plugin on worked fine for the blokes on the newer FreeBSD's.
                                    >
                                    > > I also just tried with versions/last modified dates:
                                    >
                                    > > $VIMRUNTIME/ftplugin/ruby.vim   ruby.vim,v 1.40 2008/06/29 04:18:43
                                    > > tpope
                                    > > $VIMRUNTIME/ftplugin/perl.vim    20 Jan 2009
                                    >
                                    > These are the ones I have, which are the latest ones on the rsync
                                    > server. Did you check the syntax scripts? I suppose they wouldn't be
                                    > obsolete, though, if you have this.
                                    >
                                    >
                                    >
                                    >
                                    > Well, unless you have something Perl- or Ruby-related somewhere (at any
                                    > depth) under $VIM/vimfiles/ and/or ~/.vim/ (and/or in your vimrc and/or
                                    > gvimrc) then I don't know what can have gone wrong.
                                    >
                                    > You wouldn't have a "system vimrc" or "system gvimrc", would you? Check
                                    > their locations near the middle of the ":version" output: on some OSes
                                    > the software distributor installs a system vimrc and/or gvimrc,
                                    > unbeknownst to the users.
                                    >
                                    > Best regards,
                                    > Tony.
                                    > --
                                    > Life is like a simile.

                                    Hey again tony, :D

                                    Here's the dates for the syntax files, but i somewhat doubt they have
                                    much to do with here since with "syntax on", everything still worked,
                                    and it didn't fail till "filetype plugin on"

                                    $VIMRUNTIME/syntax/ruby.vim ruby.vim,v 1.16 2008/08/09 17:40:48
                                    $VIMRUNTIME/syntax/perl.vim Last Change: 2006 November 23

                                    I don't have anything in my $VIM/vimfiles directory or my ~/.vim/
                                    directory that would have anything to do with this. There is a system-
                                    wide vimrc, but here is the entirety of it: http://dpaste.com/131384/
                                    <-- Nothing there looks to be ruby/perl specific.

                                    Just wondering, since this would probably be the easiest "fix" to this
                                    problem (and i don't work on ruby or perl stuff all that much), would
                                    it be possible for me to keep syntax, plugin and indent on for all
                                    files, but turn "filetype plugin off" for just perl and ruby files? If
                                    so, how would i do that?

                                    --
                                    You received this message from the "vim_dev" maillist.
                                    For more information, visit http://www.vim.org/maillist.php
                                  • Christian Brabandt
                                    Hi JD! ... I haven t read the whole thread, but I wonder whether profiling or setting verbosity could help debug this issue. See :h verbose and :h profile
                                    Message 17 of 27 , Dec 9, 2009
                                      Hi JD!

                                      On Mi, 09 Dez 2009, JD wrote:

                                      > Here's the dates for the syntax files, but i somewhat doubt they have
                                      > much to do with here since with "syntax on", everything still worked,
                                      > and it didn't fail till "filetype plugin on"

                                      I haven't read the whole thread, but I wonder whether profiling or
                                      setting verbosity could help debug this issue.

                                      See :h 'verbose' and :h profile for more information.

                                      If you have tried that already, please excuse my objection.

                                      regards,
                                      Christian
                                      --
                                      :wq

                                      --
                                      You received this message from the "vim_dev" maillist.
                                      For more information, visit http://www.vim.org/maillist.php
                                    • JD
                                      ... This is what i get with verbose mode (-V8): http://dpaste.com/131416/ After line 266 (the last line), that s when vim hangs eating all my CPU. -- You
                                      Message 18 of 27 , Dec 9, 2009
                                        On Dec 9, 4:15 pm, Christian Brabandt <cbli...@...> wrote:
                                        > Hi JD!
                                        >
                                        > On Mi, 09 Dez 2009, JD wrote:
                                        >
                                        > > Here's the dates for the syntax files, but i somewhat doubt they have
                                        > > much to do with here since with "syntax on", everything still worked,
                                        > > and it didn't fail till "filetype plugin on"
                                        >
                                        > I haven't read the whole thread, but I wonder whether profiling or
                                        > setting verbosity could help debug this issue.
                                        >
                                        > See :h 'verbose' and :h profile for more information.
                                        >
                                        > If you have tried that already, please excuse my objection.
                                        >
                                        > regards,
                                        > Christian
                                        > --
                                        > :wq

                                        This is what i get with verbose mode (-V8): http://dpaste.com/131416/
                                        After line 266 (the last line), that's when vim hangs eating all my
                                        CPU.

                                        --
                                        You received this message from the "vim_dev" maillist.
                                        For more information, visit http://www.vim.org/maillist.php
                                      • JD
                                        I should also mention, here s the -V8 verbose output for Ruby: http://dpaste.com/131417/, Vim also hangs at lines 266/267 (the last lines) of this pastebin. --
                                        Message 19 of 27 , Dec 9, 2009
                                          I should also mention, here's the -V8 verbose output for Ruby:
                                          http://dpaste.com/131417/, Vim also hangs at lines 266/267 (the last
                                          lines) of this pastebin.

                                          --
                                          You received this message from the "vim_dev" maillist.
                                          For more information, visit http://www.vim.org/maillist.php
                                        • Gary Johnson
                                          ... So what happens when you execute that command from a shell prompt? (perl -e print join(q/,/,@INC) ) /tmp/vnfCwnV/0 2 &1 When I tried it, replacing
                                          Message 20 of 27 , Dec 9, 2009
                                            On 2009-12-09, JD wrote:
                                            > On Dec 9, 4:15 pm, Christian Brabandt <cbli...@...> wrote:
                                            > > Hi JD!
                                            > >
                                            > > On Mi, 09 Dez 2009, JD wrote:
                                            > >
                                            > > > Here's the dates for the syntax files, but i somewhat doubt they have
                                            > > > much to do with here since with "syntax on", everything still worked,
                                            > > > and it didn't fail till "filetype plugin on"
                                            > >
                                            > > I haven't read the whole thread, but I wonder whether profiling or
                                            > > setting verbosity could help debug this issue.
                                            > >
                                            > > See :h 'verbose' and :h profile for more information.
                                            > >
                                            > > If you have tried that already, please excuse my objection.
                                            > >
                                            > > regards,
                                            > > Christian
                                            > > --
                                            > > :wq
                                            >
                                            > This is what i get with verbose mode (-V8): http://dpaste.com/131416/
                                            > After line 266 (the last line), that's when vim hangs eating all my
                                            > CPU.

                                            So what happens when you execute that command from a shell prompt?

                                            (perl -e "print join(q/,/,@INC)") >/tmp/vnfCwnV/0 2>&1

                                            When I tried it, replacing "/tmp/vnfCwnV/0" by just "/tmp/vnfCwnV",
                                            I just got the expected file in /tmp containing a comma-separated
                                            list of directories.

                                            Regards,
                                            Gary


                                            --
                                            You received this message from the "vim_dev" maillist.
                                            For more information, visit http://www.vim.org/maillist.php
                                          • James Vega
                                            ... What does :set shell? say? -- You received this message from the vim_dev maillist. For more information, visit http://www.vim.org/maillist.php
                                            Message 21 of 27 , Dec 9, 2009
                                              On Wed, Dec 9, 2009 at 5:11 PM, JD <jdhore1@...> wrote:
                                              > I should also mention, here's the -V8 verbose output for Ruby:
                                              > http://dpaste.com/131417/, Vim also hangs at lines 266/267 (the last
                                              > lines) of this pastebin.

                                              What does ":set shell?" say?

                                              --
                                              You received this message from the "vim_dev" maillist.
                                              For more information, visit http://www.vim.org/maillist.php
                                            • JD
                                              ... shell=/usr/local/bin/bash -- You received this message from the vim_dev maillist. For more information, visit http://www.vim.org/maillist.php
                                              Message 22 of 27 , Dec 9, 2009
                                                On Dec 9, 5:23 pm, James Vega <james...@...> wrote:
                                                > On Wed, Dec 9, 2009 at 5:11 PM, JD <jdho...@...> wrote:
                                                > > I should also mention, here's the -V8 verbose output for Ruby:
                                                > >http://dpaste.com/131417/, Vim also hangs at lines 266/267 (the last
                                                > > lines) of this pastebin.
                                                >
                                                > What does ":set shell?" say?

                                                shell=/usr/local/bin/bash

                                                --
                                                You received this message from the "vim_dev" maillist.
                                                For more information, visit http://www.vim.org/maillist.php
                                              • Christian Brabandt
                                                Hi JD! ... (perl -e print join(q/,/,@INC) ) /tmp/vnfCwnV/0 2 &1 So what happens, if you execute ... what if you do :echo system( echo foobar )? And what are
                                                Message 23 of 27 , Dec 9, 2009
                                                  Hi JD!

                                                  On Mi, 09 Dez 2009, JD wrote:

                                                  > This is what i get with verbose mode (-V8): http://dpaste.com/131416/
                                                  > After line 266 (the last line), that's when vim hangs eating all my
                                                  > CPU.
                                                  "(perl -e "print join(q/,/,@INC)") >/tmp/vnfCwnV/0 2>&1

                                                  So what happens, if you execute
                                                  :echo system("perl -e "print join(q/,/,@INC)")?
                                                  what if you do :echo system("echo foobar")?

                                                  And what are your shellsettings? Try setting shellxquote or shellquote
                                                  and try resetting shellredir to >


                                                  regards,
                                                  Christian

                                                  --
                                                  You received this message from the "vim_dev" maillist.
                                                  For more information, visit http://www.vim.org/maillist.php
                                                • JD
                                                  ... When i run: :echo system( perl -e print join(q/,/,@INC) ), i get: E116: Invalid arguments for function system( perl -e print join (q/,/,@INC) ) E15:
                                                  Message 24 of 27 , Dec 9, 2009
                                                    On Dec 9, 6:08 pm, Christian Brabandt <cbli...@...> wrote:
                                                    > Hi JD!
                                                    >
                                                    > On Mi, 09 Dez 2009, JD wrote:
                                                    >
                                                    > > This is what i get with verbose mode (-V8):http://dpaste.com/131416/
                                                    > > After line 266 (the last line), that's when vim hangs eating all my
                                                    > > CPU.
                                                    >
                                                    > "(perl -e "print join(q/,/,@INC)") >/tmp/vnfCwnV/0 2>&1
                                                    >
                                                    > So what happens, if you execute
                                                    > :echo system("perl -e "print join(q/,/,@INC)")?
                                                    > what if you do :echo system("echo foobar")?
                                                    >
                                                    > And what are your shellsettings? Try setting shellxquote or shellquote
                                                    > and try resetting shellredir to >
                                                    >
                                                    > regards,
                                                    > Christian

                                                    When i run: :echo system("perl -e "print join(q/,/,@INC)"), i get:
                                                    E116: Invalid arguments for function system("perl -e "print join
                                                    (q/,/,@INC)")
                                                    E15: Invalid expression: system("perl -e "print join(q/,/,@INC)")

                                                    When i run: :echo system("echo foobar"), Vim hangs using all my CPU.

                                                    My shellsettings in the beginning (when running the commands above and
                                                    getting the above result) are/were:
                                                    shellquote= (nothing)
                                                    shellxquote= (nothing)
                                                    shellredir=>%s 2>&1

                                                    I changed them to:
                                                    shellquote="\""
                                                    shellxquote="\""
                                                    shellredir=>

                                                    and ran the 2 commands above and got the same results again.
                                                    Just as a note, doing "echo foobar" in the actual shell works just
                                                    fine.

                                                    --
                                                    You received this message from the "vim_dev" maillist.
                                                    For more information, visit http://www.vim.org/maillist.php
                                                  • JD
                                                    So...I removed the $VIMRUNTIME/ftplugin/ruby.vim and perl.vim which seems to work as a temporary stopgap until this issue is really fixed (perl and ruby files
                                                    Message 25 of 27 , Dec 12, 2009
                                                      So...I removed the $VIMRUNTIME/ftplugin/ruby.vim and perl.vim which
                                                      seems to work as a temporary stopgap until this issue is really fixed
                                                      (perl and ruby files open fine now). A question though...What
                                                      functionality do I lose by not having these ftplugins?

                                                      Thanks

                                                      --
                                                      You received this message from the "vim_dev" maillist.
                                                      For more information, visit http://www.vim.org/maillist.php
                                                    • Tony Mechelynck
                                                      ... First, sorry for lagging out again. You lose whatever functionality these scripts provide ;-). I haven t looked at them in detail, but normally ftplugins
                                                      Message 26 of 27 , Jan 9, 2010
                                                        On 12/12/09 19:29, JD wrote:
                                                        > So...I removed the $VIMRUNTIME/ftplugin/ruby.vim and perl.vim which
                                                        > seems to work as a temporary stopgap until this issue is really fixed
                                                        > (perl and ruby files open fine now). A question though...What
                                                        > functionality do I lose by not having these ftplugins?
                                                        >
                                                        > Thanks
                                                        >

                                                        First, sorry for lagging out again.

                                                        You lose whatever functionality these scripts provide ;-). I haven't
                                                        looked at them in detail, but normally ftplugins set filetype-dependent
                                                        options of all kinds, maybe mappings, etc.

                                                        Note that removing stuff from subfolders of $VIMRUNTIME is generally not
                                                        a good idea, because the next time you upgrade your runtime files, and
                                                        in any case no later than when you install the next version of Vim,
                                                        whatever you removed will be put back in.

                                                        To disable filetype-plugins for files of a certain type, the usual
                                                        method is to "pretend" that these ftplugins have already been sourced.
                                                        For ruby and perl, you would add the following near the top of your
                                                        vimrc (even before filetype plugin on I think):

                                                        if has('autocmd')
                                                        au FileType perl,ruby let b:did_ftplugin = 1
                                                        endif

                                                        possibly within a specific "autocommand group" typical for your vimrc.

                                                        Then when the ftplugin starts, it will see the b:did_ftplugin variable
                                                        and ":finish" without doing anything.


                                                        Best regards,
                                                        Tony.
                                                        --
                                                        Since we have to speak well of the dead, let's knock them while they're
                                                        alive.
                                                        -- John Sloan
                                                      Your message has been successfully submitted and would be delivered to recipients shortly.