Loading ...
Sorry, an error occurred while loading the content.

Issues with VIM in vista 64 bit

Expand Messages
  • Steven S
    I install it and everything is fine. But unless I launch it as an admin it takes almost a minute to load. I use the process monitor from sysinternals to see
    Message 1 of 3 , Sep 1, 2009
    • 0 Attachment
      I install it and everything is fine. But unless I launch it as an
      admin it takes almost a minute to load. I use the process monitor from
      sysinternals to see what is going on, there are all sorts of files
      being opened when I don't launch it as admin with a path to a network
      drive that does not exist.

      I have uninstalled, cleaned the registry, reinstalled. Same problem. I
      would run it as admin all the time but I have to click allow every
      time I do and that is a major pain.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Dennis Benzinger
      Hi Steven! ... Did you check your _vimrc and _gvimrc files? Do you have any plugins installed that could cause the access to the network drive? Regards, Dennis
      Message 2 of 3 , Sep 2, 2009
      • 0 Attachment
        Hi Steven!

        -------- Original-Nachricht --------
        > Datum: Tue, 1 Sep 2009 13:24:45 -0700 (PDT)
        > Von: Steven S <ssajous@...>
        > An: vim_dev <vim_dev@...>
        > Betreff: Issues with VIM in vista 64 bit

        >
        > I install it and everything is fine. But unless I launch it as an
        > admin it takes almost a minute to load. I use the process monitor from
        > sysinternals to see what is going on, there are all sorts of files
        > being opened when I don't launch it as admin with a path to a network
        > drive that does not exist.
        >
        > I have uninstalled, cleaned the registry, reinstalled. Same problem. I
        > would run it as admin all the time but I have to click allow every
        > time I do and that is a major pain.
        > [...]

        Did you check your _vimrc and _gvimrc files? Do you have any plugins installed that could cause the access to the network drive?


        Regards,
        Dennis Benzinger

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Henrik Öhman
        ... I ve seen similar problem when Vim tries to expand ~ on Vista. For instance, :e ~/_vimrc is extremely slow, whereas :e C: Users foo home _vimrc doesn t
        Message 3 of 3 , Sep 2, 2009
        • 0 Attachment
          On Sep 1, 10:24 pm, Steven S <ssaj...@...> wrote:
          > I install it and everything is fine. But unless I launch it as an
          > admin it takes almost a minute to load. I use the process monitor from
          > sysinternals to see what is going on, there are all sorts of files
          > being opened when I don't launch it as admin with a path to a  network
          > drive that does not exist.
          >
          > I have uninstalled, cleaned the registry, reinstalled. Same problem. I
          > would run it as admin all the time but I have to click allow every
          > time I do and that is a major pain.

          I've seen similar problem when Vim tries to expand ~ on Vista. For
          instance, :e ~/_vimrc is extremely slow, whereas :e C:\Users\foo\home
          \_vimrc doesn't casue a delay. Maybe you have some command in your
          _vimrc which expands ~? If so, the two problems might be related.

          Henrik.
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.