Loading ...
Sorry, an error occurred while loading the content.

Re: Bug report that didn't get reported?

Expand Messages
  • Paul B. Mahol
    ... 2,3d1 ^[[3;*~ ^[[1;*B 10,12d7 ^[[1;*D ^[[1;*C ^[[1;*A 14a10 ... 16c12
    Message 1 of 24 , May 26, 2009
    • 0 Attachment
      On 2/27/09, Thomas Dickey <dickey@...> wrote:
      > On Fri, 27 Feb 2009, Bram Moolenaar wrote:
      >
      >>>> My installed xterm is #238 [X.Org 6.8.99.903(238)], one from ports
      >>>> with tcap enabled at build time.
      >>>> (I disabled tcap via .Xdefaults)
      >>>> I will upgrade to #241; or newer, build with tcap-query and see if
      >>>> behavior changed.
      >>>
      >>> Tested #241. enabling tcap-query via .Xdefaults still cause left and
      >>> right cursor keys to behave like shift key is pressed all time.
      >>
      >> I thought tcap-query was a configure option, thus compile-time.
      >
      > It's also runtime (after I changed the configure default, I added a
      > resource setting to let it be enabled/disabled).
      >
      >> In my opinion, if a modifier key has no effect it means it doesn't work
      >> and there should not be a termcap entry for that key + modifier.
      >
      > agree (that's what I addressed last fall, in #238).

      I found workaround [xterm-243] for:

      > diff tcap_off tcap_on
      2,3d1
      < <kDel> ^[[3;*~
      < <xDown> ^[[1;*B
      10,12d7
      < <xLeft> ^[[1;*D
      < <xRight> ^[[1;*C
      < <xUp> ^[[1;*A
      14a10
      > t_#4 <S-Left> ^[OD
      16c12
      < t_&8 <Undo> ^[[26;*~
      ---
      > t_%i <S-Right> ^[OC
      29a26
      > t_K1 <kHome> ^[OH
      30a28,29
      > t_K3 <kPageUp> ^[[5~
      > t_K4 <kEnd> ^[OF
      31a31
      > t_K5 <kPageDown> ^[[6~
      35,37d34
      < t_K9 <kMultiply> ^[O*j
      < t_KA <kEnter> ^[O*M
      < t_KB <kPoint> ^[O*n
      58a56
      > t_k2 <F2> ^[OQ
      59a58
      > t_k3 <F3> ^[OR
      60a60
      > t_k4 <F4> ^[OS
      70,73d69
      < t_kI <Insert> ^[[2;*~
      < t_kN <PageDown> ^[[6;*~
      < t_kP <PageUp> ^[[5;*~
      < t_kb <BS> ^H

      simply remove <S-Left> and <S-Right> entries:
      :set t_#4=
      :set t_%i=

      --
      Paul

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.