Loading ...
Sorry, an error occurred while loading the content.

Runtime error on Linux (undefined symbol)

Expand Messages
  • Mun Johl
    Hi, I complied vim v7.2.148 on Red Hat Enterprise Linux v5.3, but when I try to run with the gui (GTK2), I get the following error: ./vim: symbol lookup error:
    Message 1 of 8 , Apr 3, 2009
    • 0 Attachment
      Hi,

      I complied vim v7.2.148 on Red Hat Enterprise Linux v5.3, but when I try
      to run with the gui (GTK2), I get the following error:

      ./vim: symbol lookup error: /usr/local/lib/libgtk-x11-2.0.so.0: undefined symbol: g_signal_new_class_handler


      I updated my libs to glib-2.20.0 and gtk+-2.16.0, yet the problem
      persists. I'm not really sure what I should try next.

      Any assistance would be greatly appreciated.

      Thanks,

      --
      Mun

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... What s your gcc version? (as shown either by gcc --version , or by the appropriate line in the output of rpm -qa |grep gcc ) I m on openSUSE 11.1 with
      Message 2 of 8 , Apr 3, 2009
      • 0 Attachment
        On 04/04/09 00:14, Mun Johl wrote:
        >
        > Hi,
        >
        > I complied vim v7.2.148 on Red Hat Enterprise Linux v5.3, but when I try
        > to run with the gui (GTK2), I get the following error:
        >
        > ./vim: symbol lookup error: /usr/local/lib/libgtk-x11-2.0.so.0: undefined symbol: g_signal_new_class_handler
        >
        >
        > I updated my libs to glib-2.20.0 and gtk+-2.16.0, yet the problem
        > persists. I'm not really sure what I should try next.
        >
        > Any assistance would be greatly appreciated.
        >
        > Thanks,
        >

        What's your gcc version? (as shown either by "gcc --version", or by the
        appropriate line in the output of "rpm -qa |grep gcc")

        I'm on openSUSE 11.1 with gcc 4.3.2 and my gvim 7.2.148 (with
        GTK2/Gnome2) compiles and runs flawlessly. But I don't have anything in
        /usr/local/lib whose filename includes "gtk". OTOH I have lots of GTK
        libraries in /usr/lib (without /local/). The following look most
        interesting:
        lrwxrwxrwx 1 root root 26 2009-03-10 18:32 libgtk-x11-2.0.so ->
        libgtk-x11-2.0.so.0.1400.4*
        lrwxrwxrwx 1 root root 26 2009-03-10 18:07 libgtk-x11-2.0.so.0 ->
        libgtk-x11-2.0.so.0.1400.4*
        -rwxr-xr-x 1 root root 4137476 2009-02-25 18:34 libgtk-x11-2.0.so.0.1400.4*


        Oh, and BTW: you do have the gtk2-devel package installed, and with the
        same version as your gtk2 package, don't you? (I have them both at
        2.14.4-8.6.2, part of which could be a SuSE sub-versioning system.)
        Without them I don't expect that configure would enable the GTK2 GUI
        anyway. Try:

        rpm -qa|grep gtk2-[d2]

        and see if you get them both, with identical version numbers. (That's
        assuming that the package names don't differ too much between RedHat and
        SuSE. If they do, you may have to hunt.)


        Best regards,
        Tony.
        --
        The New Testament offers the basis for modern computer coding theory,
        in the form of an affirmation of the binary number system.

        But let your communication be Yea, yea; nay, nay: for
        whatsoever is more than these cometh of evil.
        -- Matthew 5:37

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Mun Johl
        Hi Tony, Thanks very much for your reply. Please see my comments below. On Fri, Apr 03, 2009 at 05:23 PM PDT, Tony Mechelynck wrote: TM On 04/04/09 00:14, Mun
        Message 3 of 8 , Apr 4, 2009
        • 0 Attachment
          Hi Tony,

          Thanks very much for your reply.
          Please see my comments below.

          On Fri, Apr 03, 2009 at 05:23 PM PDT, Tony Mechelynck wrote:
          TM> On 04/04/09 00:14, Mun Johl wrote:
          TM> >
          TM> > Hi,
          TM> >
          TM> > I complied vim v7.2.148 on Red Hat Enterprise Linux v5.3, but when I try
          TM> > to run with the gui (GTK2), I get the following error:
          TM> >
          TM> > ./vim: symbol lookup error: /usr/local/lib/libgtk-x11-2.0.so.0: undefined symbol: g_signal_new_class_handler
          TM> >
          TM> >
          TM> > I updated my libs to glib-2.20.0 and gtk+-2.16.0, yet the problem
          TM> > persists. I'm not really sure what I should try next.
          TM> >
          TM> > Any assistance would be greatly appreciated.
          TM> >
          TM> > Thanks,
          TM> >
          TM>
          TM> What's your gcc version? (as shown either by "gcc --version", or by the
          TM> appropriate line in the output of "rpm -qa |grep gcc")

          gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-44)

          TM> I'm on openSUSE 11.1 with gcc 4.3.2 and my gvim 7.2.148 (with
          TM> GTK2/Gnome2) compiles and runs flawlessly. But I don't have anything in
          TM> /usr/local/lib whose filename includes "gtk". OTOH I have lots of GTK
          TM> libraries in /usr/lib (without /local/). The following look most
          TM> interesting:
          TM> lrwxrwxrwx 1 root root 26 2009-03-10 18:32 libgtk-x11-2.0.so ->
          TM> libgtk-x11-2.0.so.0.1400.4*
          TM> lrwxrwxrwx 1 root root 26 2009-03-10 18:07 libgtk-x11-2.0.so.0 ->
          TM> libgtk-x11-2.0.so.0.1400.4*
          TM> -rwxr-xr-x 1 root root 4137476 2009-02-25 18:34 libgtk-x11-2.0.so.0.1400.4*
          TM>
          TM>
          TM> Oh, and BTW: you do have the gtk2-devel package installed, and with the
          TM> same version as your gtk2 package, don't you? (I have them both at
          TM> 2.14.4-8.6.2, part of which could be a SuSE sub-versioning system.)
          TM> Without them I don't expect that configure would enable the GTK2 GUI
          TM> anyway. Try:
          TM>
          TM> rpm -qa|grep gtk2-[d2]

          That is a good question. My system originally only came with the
          following gtk2 package: gtk2-2.10.4-20.el5 . Because I did not have the
          gtk2-devel package, vim's configure script was not enabling the gui.
          Therefore, I searched for what I could find regarding gtk2 on the RedHat
          site.

          It turns out that the v2.10.4 release was the most recent package they
          had for both gtk2 and gtk2-devel; and that release was dated Dec 2007 .
          Because that release was old, I downloaded the gtk2 v2.16 sources and
          compiled everything up and installed them. My assumption was that the
          sources (along with the list of dependencies) would of included
          everything that comes with the gtk2 and gtk2-devel packages. But I
          certainly don't know that for a fact.

          I'll try and see what comes in the gtk2 and gtk2-devel packages and
          ensure I have everything I need. I may also try uninstalling the old
          gtk2 package to ensure there isn't some incompatibility on my system.

          Thanks again, Tony.

          --
          Mun

          TM> and see if you get them both, with identical version numbers. (That's
          TM> assuming that the package names don't differ too much between RedHat and
          TM> SuSE. If they do, you may have to hunt.)
          TM>
          TM>
          TM> Best regards,
          TM> Tony.
          TM> --
          TM> The New Testament offers the basis for modern computer coding theory,
          TM> in the form of an affirmation of the binary number system.
          TM>
          TM> But let your communication be Yea, yea; nay, nay: for
          TM> whatsoever is more than these cometh of evil.
          TM> -- Matthew 5:37
          TM>
          TM> TM>


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... [...] ... Vim has been using GTK2 for quite some time, so even a year-and-a half old version ought to work with it. If I were you, I would try to compile
          Message 4 of 8 , Apr 5, 2009
          • 0 Attachment
            On 05/04/09 08:24, Mun Johl wrote:
            > Hi Tony,
            >
            > Thanks very much for your reply.
            > Please see my comments below.
            >
            > On Fri, Apr 03, 2009 at 05:23 PM PDT, Tony Mechelynck wrote:
            [...]
            > TM> Oh, and BTW: you do have the gtk2-devel package installed, and with the
            > TM> same version as your gtk2 package, don't you? (I have them both at
            > TM> 2.14.4-8.6.2, part of which could be a SuSE sub-versioning system.)
            > TM> Without them I don't expect that configure would enable the GTK2 GUI
            > TM> anyway. Try:
            > TM>
            > TM> rpm -qa|grep gtk2-[d2]
            >
            > That is a good question. My system originally only came with the
            > following gtk2 package: gtk2-2.10.4-20.el5 . Because I did not have the
            > gtk2-devel package, vim's configure script was not enabling the gui.
            > Therefore, I searched for what I could find regarding gtk2 on the RedHat
            > site.
            >
            > It turns out that the v2.10.4 release was the most recent package they
            > had for both gtk2 and gtk2-devel; and that release was dated Dec 2007 .
            > Because that release was old, I downloaded the gtk2 v2.16 sources and
            > compiled everything up and installed them. My assumption was that the
            > sources (along with the list of dependencies) would of included
            > everything that comes with the gtk2 and gtk2-devel packages. But I
            > certainly don't know that for a fact.
            >
            > I'll try and see what comes in the gtk2 and gtk2-devel packages and
            > ensure I have everything I need. I may also try uninstalling the old
            > gtk2 package to ensure there isn't some incompatibility on my system.
            >
            > Thanks again, Tony.
            >

            Vim has been using GTK2 for quite some time, so even a year-and-a half
            old version ought to work with it. If I were you, I would try to compile
            Vim with those gtk2 and gtk2-devel packages from the RedHat site, but
            also check my installed version of the RedHat OS against the latest
            RedHat and Fedora versions offered for download, then either upgrade if
            I were out of date, or if I weren't, complain on bugzilla.redhat.com (or
            something; I didn't check the URL) about outdated GTK2 packages.


            Best regards,
            Tony.
            --
            An apple every eight hours will keep three doctors away.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Mun Johl
            Hi Tony, Thanks very much for your reply. Once I uninstalled out of /usr/local and compiled and installed everything into /usr, vim - g worked! I now have
            Message 5 of 8 , Apr 7, 2009
            • 0 Attachment
              Hi Tony,

              Thanks very much for your reply.

              Once I uninstalled out of /usr/local and compiled and installed
              everything into /usr, 'vim - g' worked! I now have to get my fonts
              configured correctly, but I've definitely made progress.

              Thanks again for the assistance!

              Best regards,

              --
              Mun


              On Sun, Apr 05, 2009 at 02:56 AM PDT, Tony Mechelynck wrote:
              TM>
              TM>
              TM>
              TM> On 05/04/09 08:24, Mun Johl wrote:
              TM> > Hi Tony,
              TM> >
              TM> > Thanks very much for your reply.
              TM> > Please see my comments below.
              TM> >
              TM> > On Fri, Apr 03, 2009 at 05:23 PM PDT, Tony Mechelynck wrote:
              TM> [...]
              TM> > TM> Oh, and BTW: you do have the gtk2-devel package installed, and with the
              TM> > TM> same version as your gtk2 package, don't you? (I have them both at
              TM> > TM> 2.14.4-8.6.2, part of which could be a SuSE sub-versioning system.)
              TM> > TM> Without them I don't expect that configure would enable the GTK2 GUI
              TM> > TM> anyway. Try:
              TM> > TM>
              TM> > TM> rpm -qa|grep gtk2-[d2]
              TM> >
              TM> > That is a good question. My system originally only came with the
              TM> > following gtk2 package: gtk2-2.10.4-20.el5 . Because I did not have the
              TM> > gtk2-devel package, vim's configure script was not enabling the gui.
              TM> > Therefore, I searched for what I could find regarding gtk2 on the RedHat
              TM> > site.
              TM> >
              TM> > It turns out that the v2.10.4 release was the most recent package they
              TM> > had for both gtk2 and gtk2-devel; and that release was dated Dec 2007 .
              TM> > Because that release was old, I downloaded the gtk2 v2.16 sources and
              TM> > compiled everything up and installed them. My assumption was that the
              TM> > sources (along with the list of dependencies) would of included
              TM> > everything that comes with the gtk2 and gtk2-devel packages. But I
              TM> > certainly don't know that for a fact.
              TM> >
              TM> > I'll try and see what comes in the gtk2 and gtk2-devel packages and
              TM> > ensure I have everything I need. I may also try uninstalling the old
              TM> > gtk2 package to ensure there isn't some incompatibility on my system.
              TM> >
              TM> > Thanks again, Tony.
              TM> >
              TM>
              TM> Vim has been using GTK2 for quite some time, so even a year-and-a half
              TM> old version ought to work with it. If I were you, I would try to compile
              TM> Vim with those gtk2 and gtk2-devel packages from the RedHat site, but
              TM> also check my installed version of the RedHat OS against the latest
              TM> RedHat and Fedora versions offered for download, then either upgrade if
              TM> I were out of date, or if I weren't, complain on bugzilla.redhat.com (or
              TM> something; I didn't check the URL) about outdated GTK2 packages.
              TM>
              TM>
              TM> Best regards,
              TM> Tony.
              TM> --
              TM> An apple every eight hours will keep three doctors away.
              TM>
              TM> TM>


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tony Mechelynck
              ... In GTK2, it s rather easy. The guifont format for that version is just font-name + space + size (but remember that spaces must be backslash-escaped in
              Message 6 of 8 , Apr 7, 2009
              • 0 Attachment
                On 07/04/09 18:36, Mun Johl wrote:
                >
                > Hi Tony,
                >
                > Thanks very much for your reply.
                >
                > Once I uninstalled out of /usr/local and compiled and installed
                > everything into /usr, 'vim - g' worked! I now have to get my fonts
                > configured correctly, but I've definitely made progress.
                >
                > Thanks again for the assistance!
                >
                > Best regards,
                >

                In GTK2, it's rather easy. The 'guifont' format for that version is just
                font-name + space + size (but remember that spaces must be
                backslash-escaped in the ":set" statement). For instance I use

                :set guifont=Bistream\ Vera\ Sans\ Mono\ 7

                with some additional statements above and below to make my vimrc
                independent of GUI flavour. See details at
                http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI


                Best regards,
                Tony.
                --
                Having discovered the possibility that other creatures could be used
                for sexual intercourse, early man was likely to have made many such
                attempts ... though it is doubtful that he was so sexually carnivorous
                as the Christian and Jewish Adam, who, rabbinical interpreters of the
                Old Testament tell us, had intercourse with every creature before God
                finally hit upon the idea of woman and created Eve.
                -- R. E. Masters

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_dev" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Mun Johl
                Hi Tony, Please see my comments below. On Tue, Apr 07, 2009 at 09:19 PM PDT, Tony Mechelynck wrote: TM On 07/04/09 18:36, Mun Johl wrote: TM TM Hi Tony,
                Message 7 of 8 , Apr 9, 2009
                • 0 Attachment
                  Hi Tony,

                  Please see my comments below.

                  On Tue, Apr 07, 2009 at 09:19 PM PDT, Tony Mechelynck wrote:
                  TM> On 07/04/09 18:36, Mun Johl wrote:
                  TM> >
                  TM> > Hi Tony,
                  TM> >
                  TM> > Thanks very much for your reply.
                  TM> >
                  TM> > Once I uninstalled out of /usr/local and compiled and installed
                  TM> > everything into /usr, 'vim - g' worked! I now have to get my fonts
                  TM> > configured correctly, but I've definitely made progress.
                  TM> >
                  TM> > Thanks again for the assistance!
                  TM> >
                  TM> > Best regards,
                  TM> >
                  TM>
                  TM> In GTK2, it's rather easy. The 'guifont' format for that version is just
                  TM> font-name + space + size (but remember that spaces must be
                  TM> backslash-escaped in the ":set" statement). For instance I use
                  TM>
                  TM> :set guifont=Bistream\ Vera\ Sans\ Mono\ 7
                  TM>
                  TM> with some additional statements above and below to make my vimrc
                  TM> independent of GUI flavour. See details at
                  TM> http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

                  Great write-up, thanks! It answered my main point of confusion which
                  was why on my Solaris box using GTK I can specify the fonts with
                  X-server names (e.g. 9x15) but on my Linux box using GTK2 I can't. If I
                  read your tip correctly, you imply that GTK2 font specification differs
                  from GTK, and I assume GTK uses the older X-server fonts.

                  It's kind of unfortunate GTK2 doesn't support both styles, but such is
                  life I suppose.

                  Thanks very much for all the help, Tony.

                  Best regards,

                  --
                  Mun

                  TM>
                  TM>
                  TM> Best regards,
                  TM> Tony.
                  TM> --
                  TM> Having discovered the possibility that other creatures could be used
                  TM> for sexual intercourse, early man was likely to have made many such
                  TM> attempts ... though it is doubtful that he was so sexually carnivorous
                  TM> as the Christian and Jewish Adam, who, rabbinical interpreters of the
                  TM> Old Testament tell us, had intercourse with every creature before God
                  TM> finally hit upon the idea of woman and created Eve.
                  TM> -- R. E. Masters
                  TM>
                  TM> TM>


                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_dev" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Tony Mechelynck
                  ... [...] ... Yes, GTK1 uses what I called other-X11 guifont (also known as XLFD), which is incompatible with the GTK2 guifont . ... The change happened
                  Message 8 of 8 , Apr 9, 2009
                  • 0 Attachment
                    On 10/04/09 01:41, Mun Johl wrote:
                    >
                    > Hi Tony,
                    >
                    > Please see my comments below.
                    >
                    > On Tue, Apr 07, 2009 at 09:19 PM PDT, Tony Mechelynck wrote:
                    [...]
                    > TM> http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI
                    >
                    > Great write-up, thanks! It answered my main point of confusion which
                    > was why on my Solaris box using GTK I can specify the fonts with
                    > X-server names (e.g. 9x15) but on my Linux box using GTK2 I can't. If I
                    > read your tip correctly, you imply that GTK2 font specification differs
                    > from GTK, and I assume GTK uses the older X-server fonts.

                    Yes, GTK1 uses what I called "other-X11" 'guifont' (also known as XLFD),
                    which is incompatible with the GTK2 'guifont'.

                    >
                    > It's kind of unfortunate GTK2 doesn't support both styles, but such is
                    > life I suppose.

                    The change happened before I came to Vim (and I was still mostly on
                    Windows at first), so yes, I suppose in this case we should roll with
                    the ball.

                    >
                    > Thanks very much for all the help, Tony.

                    My pleasure.

                    >
                    > Best regards,
                    >

                    Best regards,
                    Tony.
                    --
                    Every four seconds a woman has a baby. Our problem is to find this
                    woman and stop her.

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_dev" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  Your message has been successfully submitted and would be delivered to recipients shortly.