Loading ...
Sorry, an error occurred while loading the content.

Re: 2html does not work correctly with vim -E -s

Expand Messages
  • Won-Kyu Park
    ... Yes I tried but without -s option I couldn t get any expected result in my CGI script. someone said that in the CGI mode vim automatically change it s mode
    Message 1 of 2 , Sep 1, 2008
    • 0 Attachment
      2008/9/1 Bram Moolenaar <Bram@...>:
      >
      > Wonkyu Park wrote:
      >
      >> I met a problem with the 2html.vim under the ex-mode with a silent
      >> mode option.
      >> I found that the 2html was work nicely with the vim 6.3 but vim 6.4,
      >> vim7.x and later.
      >>
      >>
      >> when I want a "xterm" color scheme in the exmode (with the silent
      >> mode) It can't change terminal type.
      >> and Iv found that the termcapinit() does not work correctly under the
      >> silent mode.
      >
      > Why not use the solution of omitting the silent mode argument -s?
      > You could redirect the output.
      >

      Yes I tried but without -s option I couldn't get any expected result
      in my CGI script.
      someone said that in the CGI mode vim automatically change it's mode
      to the silent mode and I can't get right results.

      >
      > The patch you give can't be included, skipping the terminal stuff for
      > silent mode is intentional. One could think of a half-silent mode, but
      > that makes it obscure.
      >

      But how can I change its terminal type as xterm-256color or
      xterm-8color to get a right result with the 2html.vim?

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.