Loading ...
Sorry, an error occurred while loading the content.

Re: vim

Expand Messages
  • momodi
    thank you very much! I installed gvim successfully. On Jun 28, 4:53 pm, Dominique Pelle ...
    Message 1 of 6 , Jun 28 4:57 AM
    • 0 Attachment
      thank you very much!
      I installed gvim successfully.

      On Jun 28, 4:53 pm, "Dominique Pelle" <dominique.pe...@...>
      wrote:
      > On Sat, Jun 28, 2008 at 10:30 AM, momodi wrote:
      > > I download the src files of vim7.2a and run "make install"
      > > now my vim's version is 7.2a
      > > but my gvim's version is also 7.1
      >
      > > why?
      >
      > > my OS: ubuntu 8.04
      >
      > You probably did not build the gui version of Vim (typing: 'vim --version'
      > will tell you whether GUI is enabled or not.  So it's using the gvim version
      > of Ubuntu.
      >
      > To build the GUI, you need to install some Ubuntu dev libs.
      >
      > I'm not sure what all all required packages to build the GUI, but
      > I'd suggest something like:
      >
      > $ sudo apt-get install libgnome-dev libgnomeui-dev libgtk-2.0-dev
      >
      > Then, you should be able to build the gui with something like this:
      >
      > $ cd vim7
      > $ make distclean
      > $ ./configure --with-features=huge --enable-gui=gnome2
      > $ make
      > $ sudo make install
      >
      > In case, you need more lib dev packages, here is my full Vim version
      > which shows which lib were used to build it:
      >
      > $ ./vim --version
      > VIM - Vi IMproved 7.2a BETA (2008 Jun 24, compiled Jun 28 2008 10:15:43)
      > Included patches: 1-5
      > Compiled by pel@pel-laptop
      > Huge version with GTK2-GNOME GUI.  Features included (+) or not (-):
      > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
      > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
      > +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic
      > +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path
      > +float +folding -footer +fork() +gettext -hangul_input +iconv +insert_expand
      > +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap
      > +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec -mouse_gpm
      > -mouse_jsbterm +mouse_netterm -mouse_sysmouse +mouse_xterm +multi_byte
      > +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra -perl +postscript
      > +printer +profile -python +quickfix +reltime +rightleft -ruby +scrollbind
      > +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary
      > +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title
      >  +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      > +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
      > +xsmp_interact +xterm_clipboard -xterm_save
      >    system vimrc file: "$VIM/vimrc"
      >      user vimrc file: "$HOME/.vimrc"
      >       user exrc file: "$HOME/.exrc"
      >   system gvimrc file: "$VIM/gvimrc"
      >     user gvimrc file: "$HOME/.gvimrc"
      >     system menu file: "$VIMRUNTIME/menu.vim"
      >   fall-back for $VIM: "/usr/local/share/vim"
      > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
      > -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
      > -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
      > -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
      > -I/usr/include/freetype2 -I/usr/include/libpng12
      > -I/usr/include/pixman-1   -DORBIT2=1 -pthread
      > -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0
      > -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1
      > -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0
      > -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0
      > -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
      > -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0
      > -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0
      > -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2
      > -I/usr/include/pango-1.0 -I/usr/include/gail-1.0
      > -I/usr/include/freetype2 -I/usr/include/atk-1.0
      > -I/usr/lib/gtk-2.0/include -I/usr/include/cairo
      > -I/usr/include/libpng12 -I/usr/include/pixman-1     -g -O0
      > -fno-strength-reduce -Wall -Wmissing-prototypes -DEXITFREE
      > Linking: gcc    -o vim   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
      > -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
      > -lgmodule-2.0 -lglib-2.0     -lgnomeui-2 -lbonoboui-2 -lgnomevfs-2
      > -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation
      > -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
      > -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgconf-2
      > -lgthread-2.0 -lrt -lgmodule-2.0 -lgobject-2.0 -lglib-2.0   -lXt -lm
      > -lncurses -lselinux -lacl
      >
      > Giving the list of required packages to build the GUI version of Vim would
      > be a nice addition to the Wiki tips.
      >
      > -- Dominique
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.