Loading ...
Sorry, an error occurred while loading the content.

CSS syntax highlighting bug in runtime/syntax/css.vim ?

Expand Messages
  • bob
    Hi Vim users/devs :) I found a possible small bug in the CSS syntax file. Problem: When changing the iskeyword option then syntax highlighting will go wrong.
    Message 1 of 2 , Jun 3, 2008
    • 0 Attachment
      Hi Vim users/devs :)

      I found a possible small bug in the CSS syntax file.

      Problem:
      When changing the iskeyword option then syntax highlighting will go wrong.

      Steps to reproduce:
      When I was tweaking my .vimrc I set

      setlocal iskeyword+=-

      for CSS files only. (I did this to be able to select properties
      like "background-color" in one go as a word.)
      This caused it to display the Type in a different colour, but only
      for font-* properties, not for
      background-* or border-* ones strangely enough.

      Fix:
      See attachment (patch).
      Patch is against latest SVN checkout (revision 1024).


      Disclaimer: this is my first post to the vim-dev maillist, sorry if I
      forgot to mention anything, please
      do tell though.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Bram Moolenaar
      ... Why would we want to accept a patch from evilbob127 ? :-) Please tell us your name. -- While it s true that many normal people whould prefer not to _date_
      Message 2 of 2 , Jun 4, 2008
      • 0 Attachment
        > Hi Vim users/devs :)
        >
        > I found a possible small bug in the CSS syntax file.
        >
        > Problem:
        > When changing the iskeyword option then syntax highlighting will go wrong.
        >
        > Steps to reproduce:
        > When I was tweaking my .vimrc I set
        >
        > setlocal iskeyword+=-
        >
        > for CSS files only. (I did this to be able to select properties
        > like "background-color" in one go as a word.)
        > This caused it to display the Type in a different colour, but only
        > for font-* properties, not for
        > background-* or border-* ones strangely enough.
        >
        > Fix:
        > See attachment (patch).
        > Patch is against latest SVN checkout (revision 1024).
        >
        >
        > Disclaimer: this is my first post to the vim-dev maillist, sorry if I
        > forgot to mention anything, please
        > do tell though.

        Why would we want to accept a patch from "evilbob127"? :-)

        Please tell us your name.


        --
        While it's true that many normal people whould prefer not to _date_ an
        engineer, most normal people harbor an intense desire to _mate_ with them,
        thus producing engineerlike children who will have high-paying jobs long
        before losing their virginity.
        (Scott Adams - The Dilbert principle)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ download, build and distribute -- http://www.A-A-P.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.