Loading ...
Sorry, an error occurred while loading the content.

gVim window sizing issue

Expand Messages
  • Geoffrey Antos
    In a GTK2/X11 build, when a gVim window is maximized (with a panel below it, preventing Vim from occupying the lower pixels of the screen) and the user opens a
    Message 1 of 2 , May 5, 2008
    • 0 Attachment
      In a GTK2/X11 build, when a gVim window is maximized (with a panel below
      it, preventing Vim from occupying
      the lower pixels of the screen) and the user opens a second tab, causing
      the GUI tab-bar to appear, gVim incorrectly
      assumes it can further enlarge the window, and pushes the commandline
      portion of the interface below the visible
      portion of the window. In order to make the commandline visible again,
      one must un-maximize and re-maximize the
      window.

      I know about the 'guiheadroom', but it seems like a hack to me. Change
      window-managers, change the wm's theme,
      change X's DPI (perhaps just by adding/removing an external monitor to a
      laptop) and this value may no longer be
      accurate. And then of course, there is also the case where one changes
      the size of the panel.

      I see two ways this can be corrected:
      1. Figure out the correct "available" screen-size based on all the
      NET_WM_STRUT_PARTIAL and NET_WM_STRUT properties.
      This still doesn't account for window-manager border and titlebar sizes
      though, and I see computing the available size as the
      window-manager's job.

      2. Don't attempt to make the window any bigger if it is currently
      maximized. This keeps the commandline visible when the gui
      tabbar is toggled on in a maximized window.

      The attached patch modifies gui_mch_get_screen_dimensions in
      gui_gtk_x11.c to force the window to remain the main size
      if it is maximized, thus avoiding the problem.

      -Geoffrey Antos

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... I haven t looked at the patch, but I m not sure it will work. If you check the right end of your titlebar, you ll see that :set lines=9999 columns=9999
      Message 2 of 2 , May 5, 2008
      • 0 Attachment
        On 06/05/08 02:01, Geoffrey Antos wrote:
        > In a GTK2/X11 build, when a gVim window is maximized (with a panel below
        > it, preventing Vim from occupying
        > the lower pixels of the screen) and the user opens a second tab, causing
        > the GUI tab-bar to appear, gVim incorrectly
        > assumes it can further enlarge the window, and pushes the commandline
        > portion of the interface below the visible
        > portion of the window. In order to make the commandline visible again,
        > one must un-maximize and re-maximize the
        > window.
        >
        > I know about the 'guiheadroom', but it seems like a hack to me. Change
        > window-managers, change the wm's theme,
        > change X's DPI (perhaps just by adding/removing an external monitor to a
        > laptop) and this value may no longer be
        > accurate. And then of course, there is also the case where one changes
        > the size of the panel.
        >
        > I see two ways this can be corrected:
        > 1. Figure out the correct "available" screen-size based on all the
        > NET_WM_STRUT_PARTIAL and NET_WM_STRUT properties.
        > This still doesn't account for window-manager border and titlebar sizes
        > though, and I see computing the available size as the
        > window-manager's job.
        >
        > 2. Don't attempt to make the window any bigger if it is currently
        > maximized. This keeps the commandline visible when the gui
        > tabbar is toggled on in a maximized window.
        >
        > The attached patch modifies gui_mch_get_screen_dimensions in
        > gui_gtk_x11.c to force the window to remain the main size
        > if it is maximized, thus avoiding the problem.
        >
        > -Geoffrey Antos

        I haven't looked at the patch, but I'm not sure it will work. If you
        check the right end of your titlebar, you'll see that ":set lines=9999
        columns=9999" almost maximizes the Vim screen, but not quite. There are
        two possible workarounds:

        - Click the Maximize button or the Maximize menuitem to "really"
        maximize the window; or
        - Use a "text-like" tab bar by means of

        :set go-=e
        :set tabline=<something>

        You may want to set 'tabline' to a user-written function, see ":help
        setting-tabline".


        Best regards,
        Tony.
        --
        Snoring is prohibited unless all bedroom windows are closed and securely
        locked.
        [real standing law in Massachusetts, United States of America]

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.