Loading ...
Sorry, an error occurred while loading the content.

Re: Problems compiling vim with --enable-gui on Debian 4.0

Expand Messages
  • Tony Mechelynck
    ... Try make reconfig (which should be run every time you change your Vim configuration or install new development packages used by Vim). You may need to
    Message 1 of 3 , Apr 20, 2008
    • 0 Attachment
      On 20/04/08 10:03, Fran├žois Ingelrest wrote:
      > On Sun, Apr 20, 2008 at 1:25 AM, Joe Keen<joekeen@...> wrote:
      >> > Are you two having the same problem?
      >> >
      >> > There is a difference in the size_t and int type of the second argument.
      >> > But the idea is that these lines are removed when the function prototype
      >> > is in the header. Question is why that doesn't happen. I appear to
      >> > have the same thing in the header file and it works for me.
      >>
      >> That is the problem I had before I installed the x-window-system-core
      >> package in Debian. Commenting out the definition in osdefs.h did work
      >> for me as well.
      >
      > I think I got it.
      >
      >> From what I understood, osdef.h is generated by osdef.sh. At first,
      > when I launched the compilation, I was missing some X headers (the
      > xserver-xorg-dev package I think), and it seems that osdef.sh was
      > executed at that point. Since it did not find the headers, it kept
      > many definitions (including _Xmblen), and the compilation finally
      > failed because of the missing headers. Then I installed them, and I
      > think that osdef.sh was never executed after that, resulting in the
      > conflict.
      >
      > I've just tried to execute it by hand, and it has generated an almost
      > empty osdef.h this time. Maybe the script should be run each time
      > compilation is started? BTW, I'm using aap for this.

      Try "make reconfig" (which should be run every time you change your Vim
      configuration or install new "development" packages used by Vim). You
      may need to delete src/auto/config.cache and set configure settings via
      environment variables, see
      http://users.skynet.be/antoine.mechelynck/vim/compunix.htm

      If you have hand-edited your sources out of recognition, you may even
      have to start with a fresh set.

      Best regards,
      Tony.
      --
      In Riemann, Hilbert or in Banach space
      Let superscripts and subscripts go their ways.
      Our asymptotes no longer out of phase,
      We shall encounter, counting, face to face.
      -- Stanislaw Lem, "Cyberiad"

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.