Loading ...
Sorry, an error occurred while loading the content.

Re: extends marker shown instead of real character

Expand Messages
  • Tony Mechelynck
    ... Hm... I think all these are opinions, and as such, debatable. I generally use wrap so that I have no extends= in my listchars option, but I have come
    Message 1 of 3 , Feb 27, 2008
      Jürgen Krämer wrote:
      > Hi,
      > the thread "possible cursorline bug" reminded me of some possibly
      > related misbehaviour. Here is how to reproduce it
      > gvim -u NONE -U NONE
      > :set nowrap
      > :set columns=80
      > :set list
      > :set listchars+=extends:+
      > 80ix<esc>0
      > Note that the extends marker is shown although the text line is not
      > wider than the window. It may be debatable if the eol marker which is
      > not visible in this case should lead to the extends marker being
      > displayed. I find it a bit irritating, because it tells me that the
      > content of this line is not completely displayed -- which IMHO is not
      > true. And even if the eol is considered to be part of the line, its
      > presence in the 81st column could be gathered from the *missing* extends
      > marker.
      > But there is a graver problem with the marker: go to the end of line
      > and you will see that the extends marker is displayed even while the
      > cursor is on it. You have to scroll the text to the left to see what's
      > below the cursor. I think the extends marker should not be displayed if
      > it's on the current cursor position.
      > Regards,
      > Jürgen

      Hm... I think all these are opinions, and as such, debatable. I generally use
      'wrap' so that I have no "extends=" in my 'listchars' option, but I have come
      to accept the (a priori strange) fact that when the line is exactly as wide as
      the window, an additional line is used for "only" the EOL symbol (set, for me,
      by "eol:¶"). In your case, i.e., the same but with 'nowrap' and with
      "extends:+" in 'listchars', I suppose the presence of an EOL symbol makes Vim
      regard the line as one character wider "for display" than it is "as text", and
      so the last character (not including the EOL) is the "last but one for
      display" and thus actually shown as the "extends" symbol.

      About displaying the actual character by moving the cursor on it, see also
      ":help 'sidescrolloff'" which might help even if it is not exactly what you
      wish. The Vim cursor is only a highlighting artifact (with optional blink,
      height or width settings in the GUI and some terminals, and color in all), it
      changes nothing to the character displayed in the cursor character cell -- or
      in any character cell for that matter.

      Best regards,
      Food for thought is no substitute for the real thing.
      -- Walt Kelly, "Putluck Pogo"

      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.