Loading ...
Sorry, an error occurred while loading the content.

Weird font issue

Expand Messages
  • Jeff Lanzarotta
    Hello, My version of Vim is the latest and greatest version from version control which includes patches 1-175. This version was compiled using Borland C++ 5.5
    Message 1 of 5 , Dec 21, 2007
    • 0 Attachment
      Hello,

      My version of Vim is the latest and greatest version from version control which includes patches 1-175.  This version was compiled using Borland C++ 5.5 under Windows XP.

      The issue I am having is with the characters 'a' and 'e'...

      When I am in insert mode and I do:
      'a' then backspace, 'a' then backspace, 'a' then backspace, repeatively, the character 'a' is replaced with 'å'.

      When I am in insert mode and I do:
      'e' then backspace then 'a', then 'e' then backspace then 'a', repeatively, the character 'e' is replaced with 'æ'.

      This is weird.  Has anyone else seen this?

      Thanks,

      Jeff


      -Jef
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---

    • James Vega
      ... This is happening because you have the digraph option enabled. When this option is enabled, you can input unicode characters by typing {char1}
      Message 2 of 5 , Dec 21, 2007
      • 0 Attachment
        On Fri, Dec 21, 2007 at 06:12:24AM -0800, Jeff Lanzarotta wrote:
        > When I am in insert mode and I do:
        > 'a' then backspace, 'a' then backspace, 'a' then backspace, repeatively, the character 'a' is replaced with 'å'.

        This is happening because you have the 'digraph' option enabled. When
        this option is enabled, you can input unicode characters by typing
        {char1} <BS> {char2} instead of using <C-k>{char1}{char2}. This is
        described at ":help 'digraphs'".

        James
        --
        GPG Key: 1024D/61326D40 2003-09-02 James Vega <jamessan@...>
      • Jeff Lanzarotta
        Thanks. I was messing around with my vimrc file and inadvertently added set digraph ... I have now turned that feature off... ... This is happening because
        Message 3 of 5 , Dec 21, 2007
        • 0 Attachment
          Thanks.

          I was messing around with my vimrc file and inadvertently added 'set digraph'...

          I have now turned that feature off... 

          James Vega <jamessan@...> wrote:
          On Fri, Dec 21, 2007 at 06:12:24AM -0800, Jeff Lanzarotta wrote:
          > When I am in insert mode and I do:
          > 'a' then backspace, 'a' then backspace, 'a' then backspace, repeatively, the character 'a' is replaced with 'å'.

          This is happening because you have the 'digraph' option enabled. When
          this option is enabled, you can input unicode characters by typing
          {char1} {char2} instead of using {char1}{char2}. This is
          described at ":help 'digraphs'".

          James
          --
          GPG Key: 1024D/61326D40 2003-09-02 James Vega

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---

        • Tony Mechelynck
          ... see ... I suspect that you have a :set digraph line in your vimrc, which makes active (in addition to the always-available
          Message 4 of 5 , Dec 21, 2007
          • 0 Attachment
            Jeff Lanzarotta wrote:
            > Hello,
            >
            > My version of Vim is the latest and greatest version from version
            > control which includes patches 1-175. This version was compiled using
            > Borland C++ 5.5 under Windows XP.
            >
            > The issue I am having is with the characters 'a' and 'e'...
            >
            > When I am in insert mode and I do:
            > 'a' then backspace, 'a' then backspace, 'a' then backspace, repeatively,
            > the character 'a' is replaced with 'å'.
            >
            > When I am in insert mode and I do:
            > 'e' then backspace then 'a', then 'e' then backspace then 'a',
            > repeatively, the character 'e' is replaced with 'æ'.
            >
            > This is weird. Has anyone else seen this?
            >
            > Thanks,
            >
            > Jeff
            >
            >
            > -Jef

            :set nodigraph

            see
            :help digraphs-use

            I suspect that you have a ":set digraph" line in your vimrc, which makes
            <character><BS><character> active (in addition to the always-available
            <Ctrl-K><character><character>) as an additional method of producing foreign
            characters by means of digraphs. If you have that line, remove it to disable
            the strange behaviour you've been seeing. You'll still be able to use the
            other (Ctrl-K prefix) method, which won't interfere with your use of the
            backspace key.

            (Note: aa is the digraph for the letter å, and ae for æ.)


            Best regards,
            Tony.
            --
            "But don't you worry, its for a cause -- feeding global corporations
            paws."

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Adri Verhoef
            ... Jeff Lanzarotta, your quoting mechanism cripples the text portion of the message that you quoted. It said: {char1} {char2} instead of ... and now
            Message 5 of 5 , Jan 17, 2008
            • 0 Attachment
              On Fri, Dec 21, 2007 at 15:36:03 +0000, Jeff Lanzarotta wrote:
              > Thanks.
              >
              > I was messing around with my vimrc file and inadvertently added 'set digraph'...
              >
              > I have now turned that feature off...
              >
              > James Vega <jamessan@...> wrote: On Fri, Dec 21, 2007 at 06:12:24AM -0800, Jeff Lanzarotta wrote:
              > > When I am in insert mode and I do:
              > > 'a' then backspace, 'a' then backspace, 'a' then backspace, repeatively, the character 'a' is replaced with 'å'.
              >
              > This is happening because you have the 'digraph' option enabled. When
              > this option is enabled, you can input unicode characters by typing
              > {char1} {char2} instead of using {char1}{char2}. This is
              > described at ":help 'digraphs'".
              >
              > James
              > --

              Jeff Lanzarotta, your quoting mechanism cripples the text portion of the
              message that you quoted. It said: "{char1} <BS> {char2} instead of ..."
              and now it reads "{char1} {char2} instead of ...".

              Adri

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.