Loading ...
Sorry, an error occurred while loading the content.

Re: Fwd: doc nitpicking

Expand Messages
  • Adri Verhoef
    ... [..] ... [I think Yakow means: screen is always cleared after :silent !CMD ] ... This clearing of the screen is caused by the termcap capability ti .
    Message 1 of 2 , Nov 21, 2007
    • 0 Attachment
      On Sun, Oct 14, 2007 at 12:51:03 +0000, Yakov Lerner wrote:
      > On 10/12/07, Bram Moolenaar <Bram@...> wrote:
      > > Yakov Lerner wrote:
      > > > On 10/11/07, Bram Moolenaar <Bram@...> wrote:
      > > > > Yakov Lerner wrote:
      > > > >
      > > > > > :help :! says:
      > > > > > :silent !{cmd}
      > > > > > The screen is not redrawn then, thus you have to use
      > > > > > CTRL-L or ":redraw!" if the command did display something.
      > > > > >
      > > > > > In console vim, screen is always grabled after ':silent !CMD"

      [I think Yakow means: "screen is always cleared after ':silent !CMD'"]

      > > > Still, screen is cleared after :silent !/bin/true.
      > > > In gdb, I caught the place and the string that clears the screen.
      > > > The string is "\033[?1049h\033[?1h\033=" (length=15).

      This clearing of the screen is caused by the termcap capability 'ti'.

      Bram said:
      > > Apparently your termcap settings are causing this. Try this:
      > > :set t_ti= t_ks=
      > Didn't help.

      I tried this, too, but didn't like the t_ks effects. Since 'ti' (\033[?1049h)
      clears the screen, I only cleared t_ti (with ":set t_ti=") and now the screen
      isn't cleared anymore. This also means that the text for ":silent !{cmd}"
      is correct – the command ':silent !true' doesn't display anything and the
      screen doesn't need to be redrawn, on the other hand the command ':silent !pwd'
      outputs something and the screen isn't cleared, but needs to be redrawn.

      Maybe Bram could add a small note like this: "If your screen is cleared
      after issuing ":silent !{cmd}" and you don't like that, try this:
      :set t_ti=
      In this way your screen will not be cleared."

      My system is Fedora 7 with a GNOME desktop and "gnome-terminal" as a terminal
      emulator. My $TERM is "xterm".

      $TERM is used by Vim to determine the capabilities for the terminal you're
      using and 'ti' is one such capability in termcap; 'ti' is being referred to
      as 't_ti' by Vim.


      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.