Loading ...
Sorry, an error occurred while loading the content.

vim scrolling painfully slow

Expand Messages
  • govindrjujare@gmail.com
    I connect from windows xp to solaris using telnet. I was scrolling using vim editor and saw something strange. If I do a Ctrl-F twice in succession, the first
    Message 1 of 7 , Nov 17, 2007
    • 0 Attachment
      I connect from windows xp to solaris using telnet. I was scrolling
      using vim editor and saw something strange. If I do a Ctrl-F twice
      in succession, the first screen gets updated quickly (almost in
      no time) but the second screen takes very long time (about 8
      seconds).

      To eliminate problems in network, keyboard, memory on windows
      side, I tried the vi editor. It scrolls so fast, I barely see the
      refresh
      happening.

      Any ideas ?

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • govindrjujare@gmail.com
      On Nov 18, 2:26 am, govindrjuj...@gmail.com ... It seems to be problem with files having long wrapped lines. If I set :set nowrap , it works good (though
      Message 2 of 7 , Nov 17, 2007
      • 0 Attachment
        On Nov 18, 2:26 am, "govindrjuj...@..."
        <govindrjuj...@...> wrote:
        > I connect from windows xp to solaris using telnet. I was scrolling
        > using vim editor and saw something strange. If I do a Ctrl-F twice
        > in succession, the first screen gets updated quickly (almost in
        > no time) but the second screen takes very long time (about 8
        > seconds).
        >
        > To eliminate problems in network, keyboard, memory on windows
        > side, I tried the vi editor. It scrolls so fast, I barely see the
        > refresh
        > happening.
        >
        > Any ideas ?

        It seems to be problem with files having long wrapped lines. If I set
        ":set nowrap", it works good (though now I cant see the contents
        of the unwrapped lines).


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Yakov Lerner
        On Nov 18, 2007 9:26 AM, govindrjujare@gmail.com ... I think that in order to really eliminate problems in network & telnet client,
        Message 3 of 7 , Nov 18, 2007
        • 0 Attachment
          On Nov 18, 2007 9:26 AM, govindrjujare@... <govindrjujare@...> wrote:

          I connect from windows xp to solaris using telnet. I was scrolling
          using vim editor and saw something strange. If I do a Ctrl-F twice
          in succession, the first screen gets updated quickly (almost in
          no time) but the second screen takes very long time (about 8
          seconds).

          To eliminate problems in network, keyboard, memory on windows
          side, I tried the vi editor. It scrolls so fast, I barely see the
          refresh
          happening.

          I think that in order to really eliminate problems in network &
          telnet client, you need to run the same editing session locally.

          Yakov



          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---

        • Gary Johnson
          ... Do you have syntax highlighting enabled? If so, try turning it off and see if that helps. It can take vim a long time to highlight files with long lines.
          Message 4 of 7 , Nov 19, 2007
          • 0 Attachment
            On 2007-11-17, "govindrjujare@..." <govindrjujare@...> wrote:
            > On Nov 18, 2:26 am, "govindrjuj...@..."
            > <govindrjuj...@...> wrote:
            > > I connect from windows xp to solaris using telnet. I was scrolling
            > > using vim editor and saw something strange. If I do a Ctrl-F twice
            > > in succession, the first screen gets updated quickly (almost in
            > > no time) but the second screen takes very long time (about 8
            > > seconds).
            > >
            > > To eliminate problems in network, keyboard, memory on windows
            > > side, I tried the vi editor. It scrolls so fast, I barely see the
            > > refresh
            > > happening.
            > >
            > > Any ideas ?
            >
            > It seems to be problem with files having long wrapped lines. If I set
            > ":set nowrap", it works good (though now I cant see the contents
            > of the unwrapped lines).

            Do you have syntax highlighting enabled? If so, try turning it off
            and see if that helps. It can take vim a long time to highlight
            files with long lines.

            Regards,
            Gary

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • govindrjujare@gmail.com
            Did not notice differences with syntax on/off. Both were equally slow. ... --~--~---------~--~----~------------~-------~--~----~ You received this message from
            Message 5 of 7 , Dec 1, 2007
            • 0 Attachment
              Did not notice differences with syntax on/off. Both were equally slow.

              On Nov 19, 1:37 pm, Gary Johnson <garyj...@...> wrote:
              > On 2007-11-17, "govindrjuj...@..." <govindrjuj...@...> wrote:
              > >
              > > On Nov 18, 2:26 am, "govindrjuj...@..."
              > > <govindrjuj...@...> wrote:
              > > > I connect from windows xp to solaris using telnet. I was scrolling
              > > > using vim editor and saw something strange. If I do a Ctrl-F twice
              > > > in succession, the first screen gets updated quickly (almost in
              > > > no time) but the second screen takes very long time (about 8
              > > > seconds).
              >
              > > > To eliminate problems in network, keyboard, memory on windows
              > > > side, I tried the vi editor. It scrolls so fast, I barely see the
              > > > refresh
              > > > happening.
              >
              > > > Any ideas ?
              >
              > > It seems to be problem with files having long wrapped lines. If I set
              > > ":set nowrap", it works good (though now I cant see the contents
              > > of the unwrapped lines).
              >
              > Do you have syntax highlighting enabled? If so, try turning it off
              > and see if that helps. It can take vim a long time to highlight
              > files with long lines.
              >
              > Regards,
              > Gary
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Vladimir Marek
              ... I guess that cat-ing file, or viewing it in less is faster than vim, isn t it ? That would probably mean that we use the terminal somehow in-efficiently ?
              Message 6 of 7 , Dec 2, 2007
              • 0 Attachment
                > > Do you have syntax highlighting enabled? If so, try turning it off
                > > and see if that helps. It can take vim a long time to highlight
                > > files with long lines.

                > Did not notice differences with syntax on/off. Both were equally slow.

                I guess that cat-ing file, or viewing it in less is faster than vim,
                isn't it ? That would probably mean that we use the terminal somehow
                in-efficiently ? I haven't red the source code at all, but I would guess
                that vim is re-drawing whole screen even if you shift down by one line.

                Just out of curiosity, could you try opening file in less, and scroll
                line by line down and up ? Is it also slow ?

                --
                Vlad
              • Dominique Pelle
                On Nov 18, 2007 8:26 AM, govindrjujare@gmail.com ... You may want to try different tips explained in :help slow-terminal . -- Dominique
                Message 7 of 7 , Dec 2, 2007
                • 0 Attachment
                  On Nov 18, 2007 8:26 AM, govindrjujare@...
                  <govindrjujare@...> wrote:
                  >
                  > I connect from windows xp to solaris using telnet. I was scrolling
                  > using vim editor and saw something strange. If I do a Ctrl-F twice
                  > in succession, the first screen gets updated quickly (almost in
                  > no time) but the second screen takes very long time (about 8
                  > seconds).
                  >
                  > To eliminate problems in network, keyboard, memory on windows
                  > side, I tried the vi editor. It scrolls so fast, I barely see the
                  > refresh
                  > happening.
                  >
                  > Any ideas ?

                  You may want to try different tips explained in ":help slow-terminal".

                  -- Dominique

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_dev" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                Your message has been successfully submitted and would be delivered to recipients shortly.