Loading ...
Sorry, an error occurred while loading the content.

":setlocal autoread?" -- bug?

Expand Messages
  • Christian J. Robinson
    Somehow all session files set the buffer local option autoread for every restored buffer regardless of what the global/local setting is. I ve also noticed
    Message 1 of 4 , Sep 29, 2007
    • 0 Attachment
      Somehow all session files set the buffer local option 'autoread' for
      every restored buffer regardless of what the global/local setting is.
      I've also noticed that doing "vim -u NONE -c ':setlocal autoread?'"
      shows the odd value of "--autoread".

      - Christian

      --
      Some people like my advice so much that they frame it upon the wall
      instead of using it. -- Gordon R. Dickson
      Christian J. Robinson <infynity@...> http://infynity.spodzone.com/
      PGP keys: 0x893B0EAF / 0xFB698360 http://infynity.spodzone.com/pgp

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • ap
      On Sep 29, 5:44 pm, Christian J. Robinson ... What does ... tell you, after your session has loaded ? ... I suppose this is just a
      Message 2 of 4 , Sep 29, 2007
      • 0 Attachment
        On Sep 29, 5:44 pm, "Christian J. Robinson" <infyn...@...>
        wrote:
        > Somehow all session files set the buffer local option 'autoread' for
        > every restored buffer regardless of what the global/local setting is.

        What does
        :verbose set autoread
        tell you, after your session has loaded ?

        > I've also noticed that doing "vim -u NONE -c ':setlocal autoread?'"
        > shows the odd value of "--autoread".
        >
        I suppose this is just a visual problem.

        -ap


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... [...] ... autoread Last set from ~/Session.vim ... noautoread ... noautoread ... gvim -S ... autoread Last set from ~/Session.vim ... VIM - Vi IMproved 7.1
        Message 3 of 4 , Sep 30, 2007
        • 0 Attachment
          ap wrote:
          >
          >
          > On Sep 29, 5:44 pm, "Christian J. Robinson" <infyn...@...>
          > wrote:
          >> Somehow all session files set the buffer local option 'autoread' for
          >> every restored buffer regardless of what the global/local setting is.
          >
          > What does
          > :verbose set autoread
          > tell you, after your session has loaded ?
          [...]

          I have the same symptom:

          :verbose set autoread?
          autoread
          Last set from ~/Session.vim
          :verbose setglobal autoread?
          noautoread
          :windo setlocal autoread<
          :verbose set autoread?
          noautoread
          :mks!
          :qa
          gvim -S
          :verbose set autoread?
          autoread
          Last set from ~/Session.vim
          :version
          VIM - Vi IMproved 7.1 (2007 May 12, compiled Sep 29 2007 14:42:20)
          Included patches: 1-125
          Compiled by antoine.mechelynck@...
          Huge version with GTK2-GNOME GUI. Features included (+) or not (-):
          [...] +mksession [...]


          Best regards,
          Tony.
          --
          hundred-and-one symptoms of being an internet addict:
          30. Even though you died last week, you've managed to retain OPS on your
          favorite IRC channel.

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Bram Moolenaar
          ... I see the problem, I ll fix it. ... This means the global value is used. It looks like this isn t documented anywhere. I ll add something. -- The most
          Message 4 of 4 , Sep 30, 2007
          • 0 Attachment
            > Somehow all session files set the buffer local option 'autoread' for
            > every restored buffer regardless of what the global/local setting is.

            I see the problem, I'll fix it.

            > I've also noticed that doing "vim -u NONE -c ':setlocal autoread?'"
            > shows the odd value of "--autoread".

            This means the global value is used. It looks like this isn't
            documented anywhere. I'll add something.

            --
            The most powerful force in the universe is gossip.

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ download, build and distribute -- http://www.A-A-P.org ///
            \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.