Loading ...
Sorry, an error occurred while loading the content.

more trouble with netrw

Expand Messages
  • sc
    charles-- again i find myself struggling with netrw i used to love it for directory navigation and finding things, but have come to hate the way it mangles my
    Message 1 of 9 , Sep 1 11:39 AM
    • 0 Attachment
      charles--

      again i find myself struggling with netrw

      i used to love it for directory navigation and finding
      things, but have come to hate the way it mangles my session
      settings, specifically formatoptions

      i went the extra mile to get v112b off your web site,
      de-install the v110 that was giving me fits, and install
      v112b in my ~/.vim so it wouldn't get whacked

      that was several weeks ago

      what's happening now is that every time i build and install a
      new patch level, v110 gets put back in place on my
      /usr/local/share/vim/vim71, and vim searches that first when
      coming up, effectively making my v112b invisible to vim

      do i need to write a script to whack the netrws on
      /usr/local/share and run it at the tail end of my install
      script, or do you have a better suggestion?

      --
      sc

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Charles E. Campbell, Jr.
      ... v112b shouldn t be changing your format options. ... Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its first entry, as it should. So I
      Message 2 of 9 , Sep 1 3:29 PM
      • 0 Attachment
        sc wrote:

        >charles--
        >
        >again i find myself struggling with netrw
        >
        >i used to love it for directory navigation and finding
        >things, but have come to hate the way it mangles my session
        >settings, specifically formatoptions
        >
        >

        v112b shouldn't be changing your format options.

        >i went the extra mile to get v112b off your web site,
        >de-install the v110 that was giving me fits, and install
        >v112b in my ~/.vim so it wouldn't get whacked
        >
        >that was several weeks ago
        >
        >what's happening now is that every time i build and install a
        >new patch level, v110 gets put back in place on my
        >/usr/local/share/vim/vim71, and vim searches that first when
        >coming up, effectively making my v112b invisible to vim
        >
        >

        Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
        first entry, as it should. So I think you should figure out why your
        runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?
        Normally the netrw in your ~/.vim should be loaded first and thereby
        prevent the loading of the system netrw (ie. prevent the loading of
        v110), so if you get your runtimepath issue worked out netrw v112b
        should come up even though the /usr/local/share/vim/vim71 still has v110.

        >do i need to write a script to whack the netrws on
        >/usr/local/share and run it at the tail end of my install
        >script, or do you have a better suggestion?
        >
        >

        Fix your runtimepath! Its probably the easiest.

        Regards,
        Chip Campbell



        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... On Linux, the default value is ~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after or its equivalent after expanding ~ $VIM and $VIMRUNTIME.
        Message 3 of 9 , Sep 1 3:58 PM
        • 0 Attachment
          Charles E. Campbell, Jr. wrote:
          > sc wrote:
          >
          >> charles--
          >>
          >> again i find myself struggling with netrw
          >>
          >> i used to love it for directory navigation and finding
          >> things, but have come to hate the way it mangles my session
          >> settings, specifically formatoptions
          >>
          >>
          >
          > v112b shouldn't be changing your format options.
          >
          >> i went the extra mile to get v112b off your web site,
          >> de-install the v110 that was giving me fits, and install
          >> v112b in my ~/.vim so it wouldn't get whacked
          >>
          >> that was several weeks ago
          >>
          >> what's happening now is that every time i build and install a
          >> new patch level, v110 gets put back in place on my
          >> /usr/local/share/vim/vim71, and vim searches that first when
          >> coming up, effectively making my v112b invisible to vim
          >>
          >>
          >
          > Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
          > first entry, as it should. So I think you should figure out why your
          > runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?
          > Normally the netrw in your ~/.vim should be loaded first and thereby
          > prevent the loading of the system netrw (ie. prevent the loading of
          > v110), so if you get your runtimepath issue worked out netrw v112b
          > should come up even though the /usr/local/share/vim/vim71 still has v110.
          >
          >> do i need to write a script to whack the netrws on
          >> /usr/local/share and run it at the tail end of my install
          >> script, or do you have a better suggestion?
          >>
          >>
          >
          > Fix your runtimepath! Its probably the easiest.
          >
          > Regards,
          > Chip Campbell

          On Linux, the default value is

          ~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after

          or its equivalent after expanding ~ $VIM and $VIMRUNTIME. Any 'runtimepath'
          directory other than $VIMRUNTIME need only be created when you have something
          to put into it; but in order to install a vimball you need file- and
          directory-creation privileges to directories early in 'runtimepath' and their
          immediate parent. Normally you ought to have all permissions over your $HOME
          directory and anything below it, so that's no problem.

          You (sc) need a _very_ good reason to change 'runtimepath'; and $VIMRUNTIME
          should be in the middle, not at one end.

          Full-fledged scripts other than those distributed together with Vim should go
          early in 'runtimepath', either under $VIM/vimfiles/ (for system-wide use) or
          under ~/.vim/ (for single-user use).


          Best regards,
          Tony.
          --
          Vote for ME -- I'm well-tapered, half-cocked, ill-conceived and
          TAX-DEFERRED!

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • sc
          ... indeed, when i can get it to load, it works great, and i am using it all the more now, but keeping an eye on it ... no, i do nothing to rtp or runtimepath
          Message 4 of 9 , Sep 1 4:07 PM
          • 0 Attachment
            On Sat, Sep 01, 2007 at 06:29:59PM -0400, Charles E. Campbell, Jr. wrote:
            >
            > sc wrote:
            >
            > >charles--
            > >
            > >again i find myself struggling with netrw
            > >
            > >i used to love it for directory navigation and finding
            > >things, but have come to hate the way it mangles my session
            > >settings, specifically formatoptions

            > v112b shouldn't be changing your format options.

            indeed, when i can get it to load, it works great, and i am
            using it all the more now, but keeping an eye on it

            > >i went the extra mile to get v112b off your web site,
            > >de-install the v110 that was giving me fits, and install
            > >v112b in my ~/.vim so it wouldn't get whacked
            > >
            > >that was several weeks ago
            > >
            > >what's happening now is that every time i build and install a
            > >new patch level, v110 gets put back in place on my
            > >/usr/local/share/vim/vim71, and vim searches that first when
            > >coming up, effectively making my v112b invisible to vim

            > Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
            > first entry, as it should. So I think you should figure out why your
            > runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?

            no, i do nothing to rtp or runtimepath in either .vimrc or
            .gvimrc

            > Normally the netrw in your ~/.vim should be loaded first and thereby
            > prevent the loading of the system netrw (ie. prevent the loading of
            > v110), so if you get your runtimepath issue worked out netrw v112b
            > should come up even though the /usr/local/share/vim/vim71 still has v110.

            > >do i need to write a script to whack the netrws on
            > >/usr/local/share and run it at the tail end of my install
            > >script, or do you have a better suggestion?

            > Fix your runtimepath! Its probably the easiest.

            i am officially flummoxed

            when i look at :set rtp? i see:

            runtimepath=~/.vim,/usr/local/share/vim/vimfiles,/usr/local/share/vim/vim71,/usr/local/share/vim/vimfiles/after,~/.vim/after

            yet before i wrote and ran my netrw whacker it was loading
            v110 -- obviously, ~/.vim is the first thing in 'rtp', so i
            too think it should have been grabbing v112b from there

            it's as if something were steering it to /usr/local/share

            --
            sc

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • sc
            ... waaaa! i m NOT! i swear!! there s something truly weird that was causing vim to find netrw on /usr/local/share, in spite of my
            Message 5 of 9 , Sep 1 4:17 PM
            • 0 Attachment
              On Sun, Sep 02, 2007 at 12:58:46AM +0200, Tony Mechelynck wrote:
              >
              > Charles E. Campbell, Jr. wrote:
              > > sc wrote:
              > >
              > >> charles--
              > >>
              > >> again i find myself struggling with netrw
              > >>
              > >> i used to love it for directory navigation and finding
              > >> things, but have come to hate the way it mangles my session
              > >> settings, specifically formatoptions
              > >
              > > v112b shouldn't be changing your format options.
              > >
              > >> i went the extra mile to get v112b off your web site,
              > >> de-install the v110 that was giving me fits, and install
              > >> v112b in my ~/.vim so it wouldn't get whacked
              > >>
              > >> that was several weeks ago
              > >>
              > >> what's happening now is that every time i build and install a
              > >> new patch level, v110 gets put back in place on my
              > >> /usr/local/share/vim/vim71, and vim searches that first when
              > >> coming up, effectively making my v112b invisible to vim

              > > Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
              > > first entry, as it should. So I think you should figure out why your
              > > runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?
              > > Normally the netrw in your ~/.vim should be loaded first and thereby
              > > prevent the loading of the system netrw (ie. prevent the loading of
              > > v110), so if you get your runtimepath issue worked out netrw v112b
              > > should come up even though the /usr/local/share/vim/vim71 still has v110.
              > >
              > >> do i need to write a script to whack the netrws on
              > >> /usr/local/share and run it at the tail end of my install
              > >> script, or do you have a better suggestion?

              > > Fix your runtimepath! Its probably the easiest.
              > >
              > > Regards,
              > > Chip Campbell
              >
              > On Linux, the default value is
              >
              > ~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after
              >
              > or its equivalent after expanding ~ $VIM and $VIMRUNTIME. Any 'runtimepath'
              > directory other than $VIMRUNTIME need only be created when you have something
              > to put into it; but in order to install a vimball you need file- and
              > directory-creation privileges to directories early in 'runtimepath' and their
              > immediate parent. Normally you ought to have all permissions over your $HOME
              > directory and anything below it, so that's no problem.
              >
              > You (sc) need a _very_ good reason to change 'runtimepath'; and $VIMRUNTIME
              > should be in the middle, not at one end.

              waaaa! i'm NOT! i swear!! there's something truly weird
              that was causing vim to find netrw on /usr/local/share, in
              spite of my

              runtimepath=~/.vim,/usr/local/share/vim/vimfiles,/usr/local/share/vim/vim71,/usr/local/share/vim/vimfiles/after,~/.vim/after

              --
              sc

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tony Mechelynck
              ... Yes, that s the default value. Is the more recent version installed in the plugin/ and autoload/ subdirs of one of the above? Not under ~/.vim for a
              Message 6 of 9 , Sep 1 4:32 PM
              • 0 Attachment
                sc wrote:
                > On Sun, Sep 02, 2007 at 12:58:46AM +0200, Tony Mechelynck wrote:
                >> Charles E. Campbell, Jr. wrote:
                >>> sc wrote:
                >>>
                >>>> charles--
                >>>>
                >>>> again i find myself struggling with netrw
                >>>>
                >>>> i used to love it for directory navigation and finding
                >>>> things, but have come to hate the way it mangles my session
                >>>> settings, specifically formatoptions
                >>> v112b shouldn't be changing your format options.
                >>>
                >>>> i went the extra mile to get v112b off your web site,
                >>>> de-install the v110 that was giving me fits, and install
                >>>> v112b in my ~/.vim so it wouldn't get whacked
                >>>>
                >>>> that was several weeks ago
                >>>>
                >>>> what's happening now is that every time i build and install a
                >>>> new patch level, v110 gets put back in place on my
                >>>> /usr/local/share/vim/vim71, and vim searches that first when
                >>>> coming up, effectively making my v112b invisible to vim
                >
                >>> Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
                >>> first entry, as it should. So I think you should figure out why your
                >>> runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?
                >>> Normally the netrw in your ~/.vim should be loaded first and thereby
                >>> prevent the loading of the system netrw (ie. prevent the loading of
                >>> v110), so if you get your runtimepath issue worked out netrw v112b
                >>> should come up even though the /usr/local/share/vim/vim71 still has v110.
                >>>
                >>>> do i need to write a script to whack the netrws on
                >>>> /usr/local/share and run it at the tail end of my install
                >>>> script, or do you have a better suggestion?
                >
                >>> Fix your runtimepath! Its probably the easiest.
                >>>
                >>> Regards,
                >>> Chip Campbell
                >> On Linux, the default value is
                >>
                >> ~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after
                >>
                >> or its equivalent after expanding ~ $VIM and $VIMRUNTIME. Any 'runtimepath'
                >> directory other than $VIMRUNTIME need only be created when you have something
                >> to put into it; but in order to install a vimball you need file- and
                >> directory-creation privileges to directories early in 'runtimepath' and their
                >> immediate parent. Normally you ought to have all permissions over your $HOME
                >> directory and anything below it, so that's no problem.
                >>
                >> You (sc) need a _very_ good reason to change 'runtimepath'; and $VIMRUNTIME
                >> should be in the middle, not at one end.
                >
                > waaaa! i'm NOT! i swear!! there's something truly weird
                > that was causing vim to find netrw on /usr/local/share, in
                > spite of my
                >
                > runtimepath=~/.vim,/usr/local/share/vim/vimfiles,/usr/local/share/vim/vim71,/usr/local/share/vim/vimfiles/after,~/.vim/after
                >

                Yes, that's the default value.

                Is the more recent version installed in the plugin/ and autoload/ subdirs of
                one of the above? Not under ~/.vim for a different user (which would have a
                different home dir)? Nor in an after-directory? And you _do_ have read/write
                permission on the files and their directories, don't you?

                Oh, and, you aren't overriding $VIM and/or $VIMRUNTIME are you? (I suppose
                not, but trying to cover all bases). You ought to see

                :echo $VIM
                /usr/local/share/vim
                :echo $VIMRUNTIME
                /usr/local/share/vim/vim71


                Best regards,
                Tony.
                --
                The economy depends about as much on economists as the weather does on
                weather forecasters.
                -- Jean-Paul Kauffmann

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_dev" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • sc
                ... /home/scott/.vim find . -name *netrw* -print ./doc/pi_netrw.txt ./netrw.vba ./syntax/netrw.vim ./autoload/netrw.vim ./autoload/netrwSettings.vim
                Message 7 of 9 , Sep 1 5:13 PM
                • 0 Attachment
                  On Sun, Sep 02, 2007 at 01:32:52AM +0200, Tony Mechelynck wrote:
                  >
                  > sc wrote:
                  > > On Sun, Sep 02, 2007 at 12:58:46AM +0200, Tony Mechelynck wrote:
                  > >> Charles E. Campbell, Jr. wrote:
                  > >>> sc wrote:
                  > >>>
                  > >>>> charles--
                  > >>>>
                  > >>>> again i find myself struggling with netrw
                  > >>>>
                  > >>>> i used to love it for directory navigation and finding
                  > >>>> things, but have come to hate the way it mangles my session
                  > >>>> settings, specifically formatoptions
                  > >>> v112b shouldn't be changing your format options.
                  > >>>
                  > >>>> i went the extra mile to get v112b off your web site,
                  > >>>> de-install the v110 that was giving me fits, and install
                  > >>>> v112b in my ~/.vim so it wouldn't get whacked
                  > >>>>
                  > >>>> that was several weeks ago
                  > >>>>
                  > >>>> what's happening now is that every time i build and install a
                  > >>>> new patch level, v110 gets put back in place on my
                  > >>>> /usr/local/share/vim/vim71, and vim searches that first when
                  > >>>> coming up, effectively making my v112b invisible to vim
                  > >
                  > >>> Your runtimepath is odd -- my runtimepath has /home/cec/.vim as its
                  > >>> first entry, as it should. So I think you should figure out why your
                  > >>> runtimepath is wrong; perhaps you have VIMRUNTIME set in your .profile?
                  > >>> Normally the netrw in your ~/.vim should be loaded first and thereby
                  > >>> prevent the loading of the system netrw (ie. prevent the loading of
                  > >>> v110), so if you get your runtimepath issue worked out netrw v112b
                  > >>> should come up even though the /usr/local/share/vim/vim71 still has v110.
                  > >>>
                  > >>>> do i need to write a script to whack the netrws on
                  > >>>> /usr/local/share and run it at the tail end of my install
                  > >>>> script, or do you have a better suggestion?
                  > >
                  > >>> Fix your runtimepath! Its probably the easiest.
                  > >>>
                  > >>> Regards,
                  > >>> Chip Campbell
                  > >> On Linux, the default value is
                  > >>
                  > >> ~/.vim,$VIM/vimfiles,$VIMRUNTIME,$VIM/vimfiles/after,~/.vim/after
                  > >>
                  > >> or its equivalent after expanding ~ $VIM and $VIMRUNTIME. Any 'runtimepath'
                  > >> directory other than $VIMRUNTIME need only be created when you have something
                  > >> to put into it; but in order to install a vimball you need file- and
                  > >> directory-creation privileges to directories early in 'runtimepath' and their
                  > >> immediate parent. Normally you ought to have all permissions over your $HOME
                  > >> directory and anything below it, so that's no problem.
                  > >>
                  > >> You (sc) need a _very_ good reason to change 'runtimepath'; and $VIMRUNTIME
                  > >> should be in the middle, not at one end.
                  > >
                  > > waaaa! i'm NOT! i swear!! there's something truly weird
                  > > that was causing vim to find netrw on /usr/local/share, in
                  > > spite of my
                  > >
                  > > runtimepath=~/.vim,/usr/local/share/vim/vimfiles,/usr/local/share/vim/vim71,/usr/local/share/vim/vimfiles/after,~/.vim/after
                  > >
                  >
                  > Yes, that's the default value.
                  >
                  > Is the more recent version installed in the plugin/ and autoload/ subdirs of
                  > one of the above? Not under ~/.vim for a different user (which would have a
                  > different home dir)? Nor in an after-directory? And you _do_ have read/write
                  > permission on the files and their directories, don't you?

                  /home/scott/.vim> find . -name "*netrw*" -print
                  ./doc/pi_netrw.txt
                  ./netrw.vba
                  ./syntax/netrw.vim
                  ./autoload/netrw.vim
                  ./autoload/netrwSettings.vim
                  ./autoload/netrwFileHandlers.vim
                  ./plugin/netrwPlugin.vim

                  which is indeed v112b, as witness the fact that after running
                  my:

                  /home/scott/.build/vim> cat wobn
                  #!/bin/bash
                  ##
                  ## whack old buggy netrw -- must run as root
                  ##
                  for f in $(find /usr/local/share/vim/vim71 -name "*netrw*" -print)
                  do
                  rm -i $f
                  done

                  then v112b is what comes up when i try to :Explore

                  i am the only user on this box:

                  /home> ls -Al
                  total 24
                  drwx------ 2 root root 16384 Apr 11 14:29 lost+found
                  drwxr-xr-x 89 scott users 4096 Sep 1 18:46 scott
                  /home>

                  now what else did you ask? read/write permissions on the
                  files and their directories?

                  files first:

                  /home/scott/.vim> for f in $(find . -name "*netrw*" -print)
                  > do
                  > ls -l $f
                  > done
                  -rw-r--r-- 1 scott users 103511 Aug 22 15:58 ./doc/pi_netrw.txt
                  -rw-r--r-- 1 scott users 365991 Aug 22 15:28 ./netrw.vba
                  -rw-r--r-- 1 scott users 3152 Aug 22 15:58 ./syntax/netrw.vim
                  -rw-r--r-- 1 scott users 231897 Aug 22 15:58 ./autoload/netrw.vim
                  -rw-r--r-- 1 scott users 8069 Aug 22 15:58 ./autoload/netrwSettings.vim
                  -rw-r--r-- 1 scott users 10226 Aug 22 15:58 ./autoload/netrwFileHandlers.vim
                  -rw-r--r-- 1 scott users 8875 Aug 22 15:58 ./plugin/netrwPlugin.vim

                  owned by me and writable by me

                  now for the directories:

                  /home/scott/.vim> ls -ld * | grep '^d'
                  drwxr-xr-x 2 scott users 4096 Sep 1 13:07 autoload
                  drwxr-xr-x 2 scott users 4096 Aug 22 15:58 doc
                  drwxr-xr-x 2 scott users 4096 Sep 1 13:04 plugin
                  drwxr-xr-x 2 scott users 4096 Sep 1 13:05 syntax

                  > Oh, and, you aren't overriding $VIM and/or $VIMRUNTIME are you? (I suppose
                  > not, but trying to cover all bases). You ought to see
                  >
                  > :echo $VIM
                  > /usr/local/share/vim
                  > :echo $VIMRUNTIME
                  > /usr/local/share/vim/vim71

                  indeed -- :echo $VIM yeilds:

                  /usr/local/share/vim

                  and :echo $VIMRUNTIME yeilds:

                  /usr/local/share/vim/vim71

                  this is a true mystery, but one i hope no-one loses any sleep
                  over -- i've put 'wobn' in my install script, which i run as
                  root, so i've got a painless work-around -- i may even get to
                  trust it enough to take the '-i' off the 'rm' -- not soon,
                  but eventually -- maybe

                  --
                  sc

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_dev" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Bill McCarthy
                  ... This may be unrelated to sc s problem, but happened to me in my Windows installation. I removed all *netrw* files from my $vimruntime and installed the
                  Message 8 of 9 , Sep 2 8:26 PM
                  • 0 Attachment
                    On Sat 1-Sep-07 1:39pm -0600, sc wrote:

                    > again i find myself struggling with netrw

                    This may be unrelated to sc's problem, but happened to me in
                    my Windows installation.

                    I removed all *netrw* files from my $vimruntime and
                    installed the latest (112b) there. It worked fine.
                    However, I later updated my runtime files from the ftp site
                    (the update only copies new files and only overwrites
                    existing files if the ftp file has a newer date).

                    After the update, I noticed that I was back to 110.

                    Looking around at the ftp site, I noticed that there are two
                    very similar versions of the autoload file netrw.vim on the
                    ftp site. One is in the autoload/ directory and starts
                    with:

                    " netrw.vim: Handles file transfer and remote directory listing across
                    " AUTOLOAD SECTION
                    " Date: Jun 20, 2007
                    " Version: 110k NOT RELEASED

                    The other is in the plugin/ directory and starts with:

                    " netrw.vim: Handles file transfer and remote directory listing across
                    " AUTOLOAD SECTION
                    " Date: Jun 21, 2007
                    " Version: 110

                    These two files are identical, except for the differences in
                    those lines and the line starting with: let g:loaded_netrw =

                    So this second version is getting written to the plugin\
                    directory of my runtime files and gives me the version 110
                    announcement.

                    The netrw.vim file should be removed from the plugin/
                    directory of the ftp site.

                    A working solution, until this is done, is to create a
                    current dated empty file called netrw.vim in the plugin
                    directory of your runtime. That way the rouge netrw.vim
                    will not be written there when you update your runtime.

                    --
                    Best regards,
                    Bill


                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_dev" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • Tony Mechelynck
                    ... s/rouge/rogue this is not about cosmetics, jewellery or Canadian football ... On Unix-like systems, rsync (with --delete) will make the destination tree
                    Message 9 of 9 , Sep 3 1:40 AM
                    • 0 Attachment
                      Bill McCarthy wrote:
                      > On Sat 1-Sep-07 1:39pm -0600, sc wrote:
                      >
                      >> again i find myself struggling with netrw
                      >
                      > This may be unrelated to sc's problem, but happened to me in
                      > my Windows installation.
                      >
                      > I removed all *netrw* files from my $vimruntime and
                      > installed the latest (112b) there. It worked fine.
                      > However, I later updated my runtime files from the ftp site
                      > (the update only copies new files and only overwrites
                      > existing files if the ftp file has a newer date).
                      >
                      > After the update, I noticed that I was back to 110.
                      >
                      > Looking around at the ftp site, I noticed that there are two
                      > very similar versions of the autoload file netrw.vim on the
                      > ftp site. One is in the autoload/ directory and starts
                      > with:
                      >
                      > " netrw.vim: Handles file transfer and remote directory listing across
                      > " AUTOLOAD SECTION
                      > " Date: Jun 20, 2007
                      > " Version: 110k NOT RELEASED
                      >
                      > The other is in the plugin/ directory and starts with:
                      >
                      > " netrw.vim: Handles file transfer and remote directory listing across
                      > " AUTOLOAD SECTION
                      > " Date: Jun 21, 2007
                      > " Version: 110
                      >
                      > These two files are identical, except for the differences in
                      > those lines and the line starting with: let g:loaded_netrw =
                      >
                      > So this second version is getting written to the plugin\
                      > directory of my runtime files and gives me the version 110
                      > announcement.
                      >
                      > The netrw.vim file should be removed from the plugin/
                      > directory of the ftp site.
                      >
                      > A working solution, until this is done, is to create a
                      > current dated empty file called netrw.vim in the plugin
                      > directory of your runtime. That way the rouge netrw.vim

                      s/rouge/rogue
                      " this is not about cosmetics, jewellery or Canadian football

                      > will not be written there when you update your runtime.
                      >

                      On Unix-like systems, rsync (with --delete) will make the destination tree
                      identical to the source tree regardless of anteriority, so the above won't
                      work there. The following will (after $VIMRUNTIME/plugin/netrw.vim is deleted
                      once by hand):

                      #!/bin/bash
                      rsync -avzcP --delete --exclude="/dos/" ftp.nluug.nl::Vim/runtime/ ./runtime/
                      2>&1 | tee rsync.log
                      rm -vf runtime/plugin/netrw.vim 2>&1 | tee -a rsync.log
                      vim -es -u NONE -c '%s/^.*\r//' -cx rsync.log
                      make -C src installruntime 2>&1 | tee instrt.log

                      Notes:
                      1. In case your mailer or mine added spurious line breaks: the long line
                      starting "rsync" includes everything up to but not including the line starting
                      "rm".
                      2. the "vim" step cleans up the log by removing "nonspacing" lines --
                      temporary "progress reports" which were overwritten on the screen
                      3. the "make installruntime" step only needs to be done when:
                      a) there are changed files other than doc/tags and plugin/netrw.vim, and
                      b) you aren't about to compile a new patchlevel of Vim (in which case the
                      "make install" which follows it will take care of runtime files anyway).


                      Best regards,
                      Tony.
                      --
                      Did you know ...

                      That no-one ever reads these things?

                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_dev" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    Your message has been successfully submitted and would be delivered to recipients shortly.