Loading ...
Sorry, an error occurred while loading the content.

Re: VIM 7.1 compilation error

Expand Messages
  • Edward L. Fox
    Hi Kiwon and Keedi, ... Try this patch: Index: src/gui_gtk_x11.c ... +++ src/gui_gtk_x11.c (working copy) @@ -5347,7 +5347,7 @@ void
    Message 1 of 6 , Aug 3, 2007
    • 0 Attachment
      Hi Kiwon and Keedi,

      > [...]
      > gui_gtk_x11.c: In function 'gui_mch_set_fontset':
      > gui_gtk_x11.c:5348: error: 'gui_T' has no member named 'current_font'
      > gui_gtk_x11.c: In function 'gui_mch_free_fontset':
      > gui_gtk_x11.c:5374: warning: passing argument 1 of 'gdk_font_unref' from
      > incompatible pointer type
      > make: *** [objects/gui_gtk_x11.o] Error 1
      >
      > Turning off the '--enable-hangulinput' option might temporally resolve that.
      > Now I'm also finding a way to settle the matter completely even turning on
      > it.
      > But no one has seemed to know it, poor...:-(

      Try this patch:

      Index: src/gui_gtk_x11.c
      ===================================================================
      --- src/gui_gtk_x11.c (revision 396)
      +++ src/gui_gtk_x11.c (working copy)
      @@ -5347,7 +5347,7 @@
      void
      gui_mch_set_fontset(GuiFontset fontset)
      {
      - gui.current_font = fontset;
      + gui.fontset = fontset;
      }
      #endif

      > [...]

      By the way, please always use bottom-posting or interlaced-posting in
      this mailing list. Bram hates top-posting.


      Regards,


      Edward L. Fox

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Edward L. Fox
      Hi Kiwon, ... Sorry but I know nothing about Hangul input. Could you give me a brief introduction of the basic usage of Hangul input? That is, how do I set up
      Message 2 of 6 , Aug 3, 2007
      • 0 Attachment
        Hi Kiwon,

        On 8/3/07, um.kiwon@... <um.kiwon@...> wrote:
        > Thanks Edward.
        >
        > It works just in compiling manner, not actual.
        > Hangul inputting is incorrect, all is shown as broken characters.

        Sorry but I know nothing about Hangul input. Could you give me a brief
        introduction of the basic usage of Hangul input? That is, how do I set
        up the Hangul input and what result is expected? Then I could do some
        basic debugging about this problem.

        Any way, as the Vim build-in Hangul input conflicts with XIM
        interface, I think you'd better enable XIM interface rather than
        Hangul interface, then you could use some more powerful input method
        engine such as SCIM instead.

        > By the way, what does the "bottom-posting or interlaced-posting" mean?
        > Is it "Reply to Author"?

        FYI

        http://en.wikipedia.org/wiki/Posting_style

        > Sorry for bothering you. I'm just first time here.

        Just feel free to post any thing here. All people here are very
        friendly. But you should obey the basic rules and the principles here.
        For example, bottom-posting. :-)

        >
        > Best regards,
        > Kiwon Um
        > [...]

        Cheers,

        Edward L. Fox

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Edward L. Fox
        Hi Shawn Y. Kim, (Cross-posting to vim-multibytes) Thanks for your reply! ... In fact as Um. Kiwon reported, my patch doesn t work at all. :-( I don t actually
        Message 3 of 6 , Aug 3, 2007
        • 0 Attachment
          Hi Shawn Y. Kim,

          (Cross-posting to vim-multibytes)

          Thanks for your reply!

          On 8/3/07, Shawn Y. Kim <orchistro@...> wrote:
          > [...]
          > I've also been through the same what you're going through.
          >
          > There could be a couple of solutions :
          >
          > 1. You could just use your xim. Try to configure vim with these
          > options :
          > --enable-xim --enable-gui=gtk2 --enable-multibyte --enable-multilang
          > 2. If you really hate XIMs like SCIM and nabi,
          > 2-1. you coluld choose to use gtk instead of gtk2
          > --enable-hangulinput --enable-gui=gtk --enable-multibyte --enable-
          > multilang --enable-xim=no --enable-fontset
          > 2-2. If you want to use the built-in hangulinput module with GTK2,
          > there's a way. I'm gonna describe how to do that later.
          >
          > Above, I can see Mr.Fox has posted a solution about this. Frankly, I
          > didn't really tried that one out.

          In fact as Um. Kiwon reported, my patch doesn't work at all. :-(

          I don't actually know how many Vimmers in Korean are still using the
          Hangul automata. In my impression, I think every Asian user is using
          at least one Input Method Engine (IME). If so, the Hangul automata may
          not be necessary at all. Or if possible, we could use keymap to
          simulate the Hangul automata.

          > I, however, got another one, though it has a "critical" limitation.
          > Here it is:
          >
          > shawn.ygdrasil:~/work/vim7/src$ svn diff feature.h
          > Index: feature.h
          > ===================================================================
          > --- feature.h (revision 392)
          > +++ feature.h (working copy)
          > @@ -674,7 +674,10 @@
          > * turn to english mode
          > */
          > # if !defined(FEAT_XFONTSET) && defined(HAVE_X11)
          > -# define FEAT_XFONTSET /* Hangul input
          > requires xfontset */
          > +# if !defined(HAVE_GTK2)
          > +# define FEAT_XFONTSET /* Hangul input
          > requires xfontset
          > + only if not featured with
          > gtk2 */
          > +#endif
          > # endif
          > # if defined(FEAT_XIM) && !defined(LINT)
          > Error: You should select only ONE of XIM and HANGUL INPUT
          > shawn.ygdrasil:~/work/vim7/src$
          >
          > The one thing that may be bothering you when you use this patch is
          > that you HAVE TO always use euc-kr as your encoding.
          > If the locale settings of your machine is UTF-8, you've gotta add
          > these lines to your .vimrc file :
          >
          > set encoding=euc-kr
          > set fileencoding=utf-8

          Um, it seems that with these settings, I will not be able to edit
          files in other CJK languages...

          > As to the details of encoding and fileencoding, refer to the vim help
          > page.
          >
          > Except for that, it works great with GTK+2 with alti-aliased fonts,
          > easy to set font, huh?
          > But, personally, I prefer to use GTK+1.2 with rasterized, highly-
          > optimized fonts like sun-gothic + fixed combination.

          By the way, I guess that Gothic was a Japanese font... Three widely
          used Korean fonts are named "BatangChe", "DotumChe", "Gulim" and
          "GulimChe". Maybe I am wrong...

          >
          > Any way, good look.
          >
          > BRGD.
          > Shawn from Seoul ;-)

          Shalom,

          Edward L. Fox

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Shawn Y. Kim
          Mr. Fox, ... My pleasure ;-) ... OK, there s no statistical report, yet ;-) Sure, it s true that every Asian user s using at least one IME. As far as I m
          Message 4 of 6 , Aug 3, 2007
          • 0 Attachment
            Mr. Fox,

            On 8월4일, 오전12시04분, "Edward L. Fox" <edy...@...> wrote:
            > Hi Shawn Y. Kim,
            >
            > (Cross-posting to vim-multibytes)
            >
            > Thanks for your reply!

            My pleasure ;-)

            >
            > On 8/3/07, Shawn Y. Kim <orchis...@...> wrote:
            >
            >
            >
            > > [...]
            > > I've also been through the same what you're going through.
            >
            > > There could be a couple of solutions :
            >
            > > 1. You could just use your xim. Try to configure vim with these
            > > options :
            > > --enable-xim --enable-gui=gtk2 --enable-multibyte --enable-multilang
            > > 2. If you really hate XIMs like SCIM and nabi,
            > > 2-1. you coluld choose to use gtk instead of gtk2
            > > --enable-hangulinput --enable-gui=gtk --enable-multibyte --enable-
            > > multilang --enable-xim=no --enable-fontset
            > > 2-2. If you want to use the built-in hangulinput module with GTK2,
            > > there's a way. I'm gonna describe how to do that later.
            >
            > > Above, I can see Mr.Fox has posted a solution about this. Frankly, I
            > > didn't really tried that one out.
            >
            > In fact as Um. Kiwon reported, my patch doesn't work at all. :-(
            >
            > I don't actually know how many Vimmers in Korean are still using the
            > Hangul automata. In my impression, I think every Asian user is using
            > at least one Input Method Engine (IME). If so, the Hangul automata may
            > not be necessary at all. Or if possible, we could use keymap to
            > simulate the Hangul automata.

            OK, there's no statistical report, yet ;-)
            Sure, it's true that every Asian user's using at least one IME.
            As far as I'm concerned, there also are many users who just can't use
            one.
            It could be because they don't have root privilege and their system
            administrators just
            do not even want to bother paying much attention to stuffs like IME or
            incompetent :-(

            Bottom line.
            As far as I'm concerned, the hangulinput feature needs to be at least
            kept as it is now.

            >
            >
            >
            > > I, however, got another one, though it has a "critical" limitation.
            > > Here it is:
            >
            > > shawn.ygdrasil:~/work/vim7/src$ svn diff feature.h
            > > Index: feature.h
            > > ===================================================================
            > > --- feature.h (revision 392)
            > > +++ feature.h (working copy)
            > > @@ -674,7 +674,10 @@
            > > * turn to english mode
            > > */
            > > # if !defined(FEAT_XFONTSET) && defined(HAVE_X11)
            > > -# define FEAT_XFONTSET /* Hangul input
            > > requires xfontset */
            > > +# if !defined(HAVE_GTK2)
            > > +# define FEAT_XFONTSET /* Hangul input
            > > requires xfontset
            > > + only if not featured with
            > > gtk2 */
            > > +#endif
            > > # endif
            > > # if defined(FEAT_XIM) && !defined(LINT)
            > > Error: You should select only ONE of XIM and HANGUL INPUT
            > > shawn.ygdrasil:~/work/vim7/src$
            >
            > > The one thing that may be bothering you when you use this patch is
            > > that you HAVE TO always use euc-kr as your encoding.
            > > If the locale settings of your machine is UTF-8, you've gotta add
            > > these lines to your .vimrc file :
            >
            > > set encoding=euc-kr
            > > set fileencoding=utf-8
            >
            > Um, it seems that with these settings, I will not be able to edit
            > files in other CJK languages...
            >
            > > As to the details of encoding and fileencoding, refer to the vim help
            > > page.
            >
            > > Except for that, it works great with GTK+2 with alti-aliased fonts,
            > > easy to set font, huh?
            > > But, personally, I prefer to use GTK+1.2 with rasterized, highly-
            > > optimized fonts like sun-gothic + fixed combination.
            >
            > By the way, I guess that Gothic was a Japanese font... Three widely
            > used Korean fonts are named "BatangChe", "DotumChe", "Gulim" and
            > "GulimChe". Maybe I am wrong...

            Yes, that is true, Gulim or GulimChe are widely appreciated as they
            are system fonts in the Windows OSs.
            But the landscape has been changed as "Un-Gothic" font has become
            available.
            Almost every recent linux distribution use "Un-Gothic" (I am not sure
            the name is correctly spelled out :-( ).
            Moreover, GulimChe, Gulim and BatangChe are commercial fonts :-(
            As to sun-gothic font, yes it is also a commercial font that comes
            with Sun microsystem's openwin.
            IMHO, sun-gothic font is the most readable hangul "bitmap" font.

            >
            >
            >
            > > Any way, good look.
            >
            > > BRGD.
            > > Shawn from Seoul ;-)
            >
            > Shalom,
            >
            > Edward L. Fox

            Regards,
            Shawn Y. Kim.


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_dev" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Kiwon Um
            Thanks for your passionate concerns. ... These solutions worked well. Now I m just using VIM with SCIM. But still one more question... I ve tested something
            Message 5 of 6 , Aug 5, 2007
            • 0 Attachment
              Thanks for your passionate concerns.

              On Aug 3, 11:32 pm, "Shawn Y. Kim" <orchis...@...> wrote:
              > On 8월3일, 오후6시16분, "Edward L. Fox" <edy...@...> wrote:
              >
              >
              >
              > > Hi Kiwon,
              >
              > > On 8/3/07, um.ki...@... <um.ki...@...> wrote:
              >
              > > > Thanks Edward.
              >
              > > > It works just in compiling manner, not actual.
              > > > Hangul inputting is incorrect, all is shown as broken characters.
              >
              > > Sorry but I know nothing about Hangul input. Could you give me a brief
              > > introduction of the basic usage of Hangul input? That is, how do I set
              > > up the Hangul input and what result is expected? Then I could do some
              > > basic debugging about this problem.
              >
              > > Any way, as the Vim build-in Hangul input conflicts with XIM
              > > interface, I think you'd better enable XIM interface rather than
              > > Hangul interface, then you could use some more powerful input method
              > > engine such as SCIM instead.
              >
              > > > By the way, what does the "bottom-posting or interlaced-posting" mean?
              > > > Is it "Reply to Author"?
              >
              > > FYI
              >
              > >http://en.wikipedia.org/wiki/Posting_style
              >
              > > > Sorry for bothering you. I'm just first time here.
              >
              > > Just feel free to post any thing here. All people here are very
              > > friendly. But you should obey the basic rules and the principles here.
              > > For example, bottom-posting. :-)
              >
              > > > Best regards,
              > > > Kiwon Um
              > > > [...]
              >
              > > Cheers,
              >
              > > Edward L. Fox
              >
              > Hi, Kiwon.
              >
              > It seems that you were trying to compile vim using following options
              > combined together:
              >
              > --enable-hangulinput
              > --enable-xim=no
              > --enable-gui=gtk2
              > --enable-fontset
              > --enable-multibyte
              > --enable-multilang
              >
              > The problem that caused the compile error is that the hangulinput
              > module depends on xfontset.
              > And the fontset feature causes sort of "conflict" with gtk2.
              > Gtk2 has whole different font system than that of gtk1.2.
              >
              > I've also been through the same what you're going through.
              >
              > There could be a couple of solutions :
              >
              > 1. You could just use your xim. Try to configure vim with these
              > options :
              > --enable-xim --enable-gui=gtk2 --enable-multibyte --enable-multilang
              > 2. If you really hate XIMs like SCIM and nabi,
              > 2-1. you coluld choose to use gtk instead of gtk2
              > --enable-hangulinput --enable-gui=gtk --enable-multibyte --enable-
              > multilang --enable-xim=no --enable-fontset
              > 2-2. If you want to use the built-in hangulinput module with GTK2,
              > there's a way. I'm gonna describe how to do that later.
              >
              These solutions worked well.
              Now I'm just using VIM with SCIM.

              But still one more question...
              I've tested something more with Hangul i.e. Korean text.
              I have some 'euckr' encoded text files but my VIMs (such gvim or vim)
              cannot read/show these files correctly.
              Although I set 'encoding=euckr' and 'fileencoding=euckr or utf8', it
              show me some broken characters.

              I think it might be a quite different problem with --enable-
              hangulinput.
              Anyhow I just want to resolve Hangul-cencerned problems.

              > Above, I can see Mr.Fox has posted a solution about this. Frankly, I
              > didn't really tried that one out.
              > I, however, got another one, though it has a "critical" limitation.
              > Here it is:
              >
              > shawn.ygdrasil:~/work/vim7/src$ svn diff feature.h
              > Index: feature.h
              > ===================================================================
              > --- feature.h (revision 392)
              > +++ feature.h (working copy)
              > @@ -674,7 +674,10 @@
              > * turn to english mode
              > */
              > # if !defined(FEAT_XFONTSET) && defined(HAVE_X11)
              > -# define FEAT_XFONTSET /* Hangul input
              > requires xfontset */
              > +# if !defined(HAVE_GTK2)
              > +# define FEAT_XFONTSET /* Hangul input
              > requires xfontset
              > + only if not featured with
              > gtk2 */
              > +#endif
              > # endif
              > # if defined(FEAT_XIM) && !defined(LINT)
              > Error: You should select only ONE of XIM and HANGUL INPUT
              > shawn.ygdrasil:~/work/vim7/src$
              >
              > The one thing that may be bothering you when you use this patch is
              > that you HAVE TO always useeuc-kras your encoding.
              > If the locale settings of your machine is UTF-8, you've gotta add
              > these lines to your .vimrc file :
              >
              > set encoding=euc-kr
              > set fileencoding=utf-8
              >
              > As to the details of encoding and fileencoding, refer to the vim help
              > page.
              >
              > Except for that, it works great with GTK+2 with alti-aliased fonts,
              > easy to set font, huh?
              > But, personally, I prefer to use GTK+1.2 with rasterized, highly-
              > optimized fonts like sun-gothic + fixed combination.
              >
              I didn't try these yet.

              > Any way, good look.
              >
              > BRGD.
              > Shawn from Seoul ;-)

              It was my extremely short thought to get rid of the --enable-
              hangulnput fixture.
              I didn't care about persons who should use that.
              Thanks again for your cares.

              Best regards,
              Kiwon Um


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_dev" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Tony Mechelynck
              Kiwon Um wrote: [...] ... [...] How to solve that will depend on which kinds of files you usually edit; the following assumes that you have encoding set to
              Message 6 of 6 , Aug 5, 2007
              • 0 Attachment
                Kiwon Um wrote:
                [...]
                > But still one more question...
                > I've tested something more with Hangul i.e. Korean text.
                > I have some 'euckr' encoded text files but my VIMs (such gvim or vim)
                > cannot read/show these files correctly.
                > Although I set 'encoding=euckr' and 'fileencoding=euckr or utf8', it
                > show me some broken characters.
                [...]

                How to solve that will depend on which kinds of files you usually edit; the
                following assumes that you have 'encoding' set to utf-8:

                a) Most files are either Unicode with BOM, UTF-8 (even without BOM), or euc-kr:

                :set fileencodings=ucs-bom,utf-8,euc-kr,latin1

                If some euc-kr file is wrongly detected as UTF-8:

                :e ++enc=euc-kr filename

                If you need to edit some Unicode file without BOM in another encoding than
                UTF-8, use (for instance):

                :e ++enc=utf-16le filename

                b) You have only a few euc-kr files, and you know what they are:

                :set fileencodings=ucs-bom,utf-8,latin1

                Always open euc-kr files with

                :e ++enc=euc-kr filename

                c) All (or almost all) your Unicode files have a BOM:

                :set fileencodings=ucs-bom,euc-kr,latin1

                If you need to edit a Unicode file without a BOM, use for instance

                :e ++enc=utf8 filename

                etc.

                To set the BOM on all _new_ Unicode files by default, use

                :setglobal bomb

                This setting does not affect non-Unicode files. For existing files, the
                presence or absence of a BOM is detected automatically if 'fileencodings'
                starts with "ucs-bom".

                See
                :help 'fileencodings'
                :help ++opt
                :help 'bomb'

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_dev" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              Your message has been successfully submitted and would be delivered to recipients shortly.