Loading ...
Sorry, an error occurred while loading the content.
 

Re: Strange coloring for GTK build

Expand Messages
  • Tony Mechelynck
    ... Many text consoles, including the Windows console, have only 8 background colors as opposed to 16 foreground colors. In that case, trying to set a bright
    Message 1 of 5 , Jul 20, 2007
      Larson, David wrote:
      > Here is a better picture showing the problem for gtk2. This is what the
      > color test shows.
      >
      > Notice that setting the color as the foreground does not always match
      > the color when it is set as the background. Especially for the red and
      > blues. Any ideas on how to fix this?

      Many text consoles, including the Windows console, have only 8 background
      colors as opposed to 16 foreground colors. In that case, trying to set a
      "bright" color as the background will fail. For instance, trying to set a red
      background will give "dark red" which is usually a kind of dark reddish brown,
      more /lie-de-vin/ than true dark red.

      To see all the terminal names in your system's terminfo library in
      alphabetical order, use

      toe|sort|less

      at the shell prompt. You may try setting 'term' and/or $TERM to one of them
      (with caution) to see if the result is better.


      Best regards,
      Tony.
      --
      As I was going up Punch Card Hill,
      Feeling worse and worser,
      There I met a C.R.T.
      And it drop't me a cursor.

      C.R.T., C.R.T.,
      Phosphors light on you!
      If I had fifty hours a day
      I'd spend them all at you.

      -- Uncle Colonel's Cursory Rhymes

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Larson, David
      ... the ... match ... and ... background ... a ... set a ... reddish ... Actually, that isn t what is happening here. The colors aren t a little off, they are
      Message 2 of 5 , Jul 20, 2007
        > Larson, David wrote:
        > > Here is a better picture showing the problem for gtk2. This is what
        the
        > > color test shows.
        > >
        > > Notice that setting the color as the foreground does not always
        match
        > > the color when it is set as the background. Especially for the red
        and
        > > blues. Any ideas on how to fix this?
        >
        > Many text consoles, including the Windows console, have only 8
        background
        > colors as opposed to 16 foreground colors. In that case, trying to set
        a
        > "bright" color as the background will fail. For instance, trying to
        set a
        > red
        > background will give "dark red" which is usually a kind of dark
        reddish
        > brown,
        > more /lie-de-vin/ than true dark red.

        Actually, that isn't what is happening here. The colors aren't a little
        off, they are completely wrong. The "red" foreground is blue and the
        "blue" foreground is red. Strangely, the background colors are
        correct...

        David

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_dev" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... Then your system may be confusing MS-DOS colours with X colours, see :help highlight-cterm and in particular :help cterm-colors . You may still try
        Message 3 of 5 , Jul 20, 2007
          Larson, David wrote:
          >> Larson, David wrote:
          >>> Here is a better picture showing the problem for gtk2. This is what
          > the
          >>> color test shows.
          >>>
          >>> Notice that setting the color as the foreground does not always
          > match
          >>> the color when it is set as the background. Especially for the red
          > and
          >>> blues. Any ideas on how to fix this?
          >> Many text consoles, including the Windows console, have only 8
          > background
          >> colors as opposed to 16 foreground colors. In that case, trying to set
          > a
          >> "bright" color as the background will fail. For instance, trying to
          > set a
          >> red
          >> background will give "dark red" which is usually a kind of dark
          > reddish
          >> brown,
          >> more /lie-de-vin/ than true dark red.
          >
          > Actually, that isn't what is happening here. The colors aren't a little
          > off, they are completely wrong. The "red" foreground is blue and the
          > "blue" foreground is red. Strangely, the background colors are
          > correct...
          >
          > David

          Then your system may be confusing "MS-DOS" colours with "X" colours, see
          ":help highlight-cterm" and in particular ":help cterm-colors". You may still
          try playing with the $TERM environment variable (before starting Vim) and see
          if it behaves better. Use something that's not too different from the actual
          terminal you're using.


          Best regards,
          Tony.
          --
          What garlic is to food, insanity is to art.

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_dev" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.