Loading ...
Sorry, an error occurred while loading the content.
 

Re: lost menu

Expand Messages
  • scott
    ... menu.vim is owned by root -- i su before performing the make install -- but both group and other have read permission -- i verified by, as me, starting
    Message 1 of 6 , Dec 29, 2006
      On Friday 29 December 2006 22:00, A.J.Mechelynck wrote:
      > scott wrote:
      > > On Friday 29 December 2006 10:55, A.J.Mechelynck wrote:
      > >> Charles E Campbell Jr wrote:
      > >>> scott wrote:
      > >>>> has anyone else lost the ability to get a menu by entering
      > >>>>
      > >>>> :set guioptions+=m
      > >>>>
      > >>>> nothing happens
      > >>>>
      > >>>> i see
      > >>>>
      > >>>> 4: /usr/local/share/vim/vim70/menu.vim
      > >>>>
      > >>>> in :scriptnames...
      > >>>>
      > >>>> no glaring errors on build (7.0.178)
      > >>>>
      > >>>> i build with
      > >>>> export CONF_OPT_GUI='--enable-gnome-check'
      > >>>> in SUSE linux 10.0
      > >>>
      > >>> I don't have any problems seeing a menu (I'm using Fedora Core 5, vim
      > >>> 7.0.1-178).
      > >>> For build options, I use
      > >>>
      > >>> ./configure --with-features=huge --enable-perlinterp
      > >>>
      > >>> I commented out my usual guioptions setting (set guioptions=abegmr) and
      > >>> put your (set guioptions+=m) in instead. So, it appears likely that
      > >>> there's a permission
      > >>> error associated with your being able to use gnome, since it works for
      > >>> you as root.
      > >>> Hmm, are you sure you're using the same vim as root that you are as a
      > >>> user? What does
      > >>> which vim
      > >>> say as user and as root?
      > >>>
      > >>> Why do you need the "enable-gnome-check"? In Makefile, there's a note:
      > >>>
      > >>> GNOME means GTK with Gnome support. If using GTK, then GNOME will
      > >>> # automatically be used if it is found. If you have GNOME, but do not
      > >>> want to
      > >>> # use it (e.g., want a GTK-only version), then use --enable-gui=gtk.
      > >>>
      > >>> so normally if you use GTK then GNOME will automatically be used, too.
      > >>
      > >> That paragraph is outdated. Gnome is now disabled by default. Use
      > >> --enable-gnome-check if you want configure to include it in GTK builds
      > >> if it finds it on your system.
      > >>
      > >>> Also in the Makefile:
      > >>>
      > >>> # Uncomment one of these lines if you have that GUI but don't want to
      > >>> use it.
      > >>> # The automatic check will use another one that can be found
      > >>> # Gnome is disabled by default, it may cause trouble.
      > >>> ...
      > >>> #CONF_OPT_GUI = --enable-gnome-check
      > >>>
      > >>> which seems to indicate that the --enable-gnome-check is causing GNOME
      > >>> to be disabled, oddly enough. No Gnome, no menu.
      > >>>
      > >>> Regards,
      > >>> Chip Campbell
      > >>
      > >> --enable-gnome-check causes Gnome _not_ to be disabled -- provided that
      > >> you have Gnome and GTK, or Gnome2 and GTK2, installed. Without
      > >> --enable-gnome-check, configure doesn't check for Gnome and doesn't
      > >> include it even if you have it installed.
      > >>
      > >>
      > >> Best regards,
      > >> Tony.
      > >
      > > 'which vim' shows as /usr/local/bin for both myself and root -- the :ver
      > > text indicates the same -- i have no reason to think they are different,
      > > and i know they both use the same .vimrc and .gvimrc -- the ones on /root
      > > are symbolic links to the ones on my home path -- further, :scriptnames
      > > shows the same set of scripts loaded for both myself and root (with
      > > menu.vim prominently mentioned)
      > >
      > > not sure if it's related, but :ver shows a huge version with GTK2-GNOME
      > > (not GNOME2) -- i still find it weird that i don't get a menu and root
      > > does
      >
      > Does your non-root login name have read permission on
      > /usr/local/share/vim/vim70/menu.vim ? Or is your vimrc not created with
      > root as owner? (check either file with ls -l )
      >
      >
      > Best regards,
      > Tony.

      menu.vim is owned by root -- i 'su' before performing the 'make install' --
      but both group and other have read permission -- i verified by, as me,
      starting a gvim session on that very module, no problem

      the real .vimrc, on my home path, is owned by me -- the sybolic link to it
      on /root is owned by root -- i have no evidence that either root or myself is
      having problems reading .vimrc -- the app is coming up fine

      i did notice the font of the menu that root does see is quite small -- i would
      change it to a larger font if the menus were working for both accounts and if
      i had any intention of really using the menu system

      i occasionally turn the menu on when i want to see a list of available color
      schemes for choosing from, which is what i was doing when i found out i'm
      not getting the menu -- can't say how many versions/patches i've gone through
      before finding this out -- i use it *very* seldom -- it just bothers me that i
      can't get a menu when i ask for one now

      --
      scott
    Your message has been successfully submitted and would be delivered to recipients shortly.