Loading ...
Sorry, an error occurred while loading the content.

Re: About Unicode CJK Unified Extension B

Expand Messages
  • A.J.Mechelynck
    ... GTK2 gvim does all its I/O in UTF-8. Therefore, IIUC, you cannot have both +gui_gtk2 and -multibyte. You might try setting encoding to latin1 in the GTK2
    Message 1 of 18 , Sep 29, 2006
    • 0 Attachment
      Christian MICHON wrote:
      > On 3/6/06, Bram Moolenaar <Bram@...> wrote:
      >>
      >> GTK2 does everything with UTF-8, thus it should work as it is.
      >>
      >
      > I know this is a bit late, but I tried today to make a custom gtk2
      > gvim build without multibyte, and I apparently cannot unless I
      > change heavily the code around the utf8 stuff...
      >
      > The problem I face is that all my previous builds were gtk-1.2.10
      > without multibyte, and when I do cut and paste from gvim 7
      > to one of those gtk1 build, I get nasty \@utf8\@ chains
      > embedded in whatever I copy.
      >
      > Is there a fix or this is the expected gtk2 behaviour ?
      >

      GTK2 gvim does all its I/O in UTF-8. Therefore, IIUC, you cannot have both
      +gui_gtk2 and -multibyte.

      You might try setting 'encoding' to latin1 in the GTK2 build to see if it
      makes a difference. Of course, there's no way you can paste codepoints >
      U+00FF into an 8-bit build of Vim, except as multi-byte gibberish.

      The long-term fix, of course, is to stop using those earlier -multibyte
      builds. 8-bit _files_ should be compatible between + and - multibyte builds
      anyway.


      Best regards,
      Tony.
    Your message has been successfully submitted and would be delivered to recipients shortly.