Loading ...
Sorry, an error occurred while loading the content.
 

Re: Bug: Can't select bottom window by mouse-clicking

Expand Messages
  • A.J.Mechelynck
    ... I didn t include -U NONE (with uppercase U) for two reasons, each of which is sufficient by itself: 1) -u NONE (with lowercase u) suppresses sourcing of
    Message 1 of 7 , Aug 1, 2006
      Charles E Campbell Jr wrote:
      > A.J.Mechelynck wrote:
      >
      >> No it doesn't (and I'm using almost the same as yours, i.e., Huge
      >> version 7.0.42 with GTK2-GNOME GUI) on SuSE Linux 9.3 Professional.
      >>
      >> With my own vimrc I get it even with no editfile.
      >>
      >> A little experimenting shows that the e flag must be absent from
      >> 'guioptions' for the bug to manifest. Here's a new testcase:
      >>
      >> gvim -N -u NONE
      >> :set go-=e stal=2 wmh=0 wh=999
      >> :new
      >>
      >> Now click on both status lines in alternation and see what happens.
      >> (Clicking inside the bottom window does select it, but with ":set
      >> wmh=0 wh=999" this is usually not possible.)
      >
      > OK, with this (I also included a "-u NONE") I was unable to select the
      > bottom window by clicking on it.

      I didn't include -U NONE (with uppercase U) for two reasons, each of
      which is sufficient by itself:

      1) -u NONE (with lowercase u) suppresses sourcing of vimrc, plugins
      _and_ gvimrc.
      2) I don't have a gvimrc anyway.

      > Interestingly, after a ctrl-w j to select the bottom window by moving
      > the cursor to it, I was able to click
      > on the upper window status line with the mouse to select it.

      Me too. In fact, with any number of windows (more than one) I can select
      any of them _except_ the bottom one by clicking its statusline.

      >
      > Consider it duplicated!
      >
      > For those who are silently browsing: the 'e' option in guioptions is
      > supposed to
      >
      > "Add tab pages when indicated with 'showtabline'"

      ... and 'stal' or 'showtabline' set to 2 means "always". Without the e
      flag, gvim uses a "text" tabline similar to that of the console version.

      >
      > so it doesn't appear like it should have this behavior.
      >
      > Regards,
      > Chip Campbell
      >
      >
      >

      Best regards,
      Tony.
    • Bram Moolenaar
      ... I can reproduce it. I ll put it in the todo list (which is toooooo long now). -- ... /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net
      Message 2 of 7 , Aug 8, 2006
        A.J.Mechelynck wrote:

        > No it doesn't (and I'm using almost the same as yours, i.e., Huge
        > version 7.0.42 with GTK2-GNOME GUI) on SuSE Linux 9.3 Professional.
        >
        > With my own vimrc I get it even with no editfile.
        >
        > A little experimenting shows that the e flag must be absent from
        > 'guioptions' for the bug to manifest. Here's a new testcase:
        >
        > gvim -N -u NONE
        > :set go-=e stal=2 wmh=0 wh=999
        > :new
        >
        > Now click on both status lines in alternation and see what happens.
        > (Clicking inside the bottom window does select it, but with ":set wmh=0
        > wh=999" this is usually not possible.)

        I can reproduce it. I'll put it in the todo list (which is toooooo long
        now).

        --
        From "know your smileys":
        :-F Bucktoothed vampire with one tooth missing

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ download, build and distribute -- http://www.A-A-P.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
      Your message has been successfully submitted and would be delivered to recipients shortly.