Loading ...
Sorry, an error occurred while loading the content.

vim70f, test49 fails if binary is not named 'vim'

Expand Messages
  • Gregory Margo
    test49.vim assumes the binary is named vim . If the --with-vim-name option is used (such as --with-vim-name=vim7 ) then test49 fails. Here is a minor patch
    Message 1 of 4 , Apr 27, 2006
    • 0 Attachment
      test49.vim assumes the binary is named 'vim'.

      If the --with-vim-name option is used (such as "--with-vim-name=vim7")
      then test49 fails.

      Here is a minor patch that makes test49 respect the VIMPROG environment
      variable from the Makefile, falling back to the current value
      if not found:

      --- vim70f/src/testdir/test49.vim.00 2006-02-28 05:36:54.000000000 -0800
      +++ vim70f/src/testdir/test49.vim 2006-04-27 16:26:31.677399006 -0700
      @@ -454,9 +454,10 @@
      " pipe are consumed at the debug prompt. Use "-N" to enable command-line
      " continuation ("C" in 'cpo'). Add "nviminfo" to 'viminfo' to avoid
      " messing up the user's viminfo file.
      + let vimprog = exists($VIMPROG) ? $VIMPROG : "../vim"
      let redirect = a:0 ?
      \ " -c 'au VimLeave * redir END' -c 'redir\\! >" . a:1 . "'" : ""
      - exec "!echo '" . debug_quits . "q' | ../vim -u NONE -N -Xes" . redirect .
      + exec "!echo '" . debug_quits . "q' | " . vimprog . " -u NONE -N -Xes" . redirect .
      \ " -c 'debuggreedy|set viminfo+=nviminfo'" .
      \ " -c 'let ExtraVimBegin = " . extra_begin . "'" .
      \ " -c 'let ExtraVimResult = \"" . resultfile . "\"'" . breakpoints .



      --
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Gregory H. Margo
      gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org
    • Gregory Margo
      ... Argh!@, I should not have hit the return key so fast, that patch doesn t fix all the problems. Sorry. --
      Message 2 of 4 , Apr 27, 2006
      • 0 Attachment
        On Thu, Apr 27, 2006 at 04:34:30PM -0700, Gregory Margo wrote:
        > test49.vim assumes the binary is named 'vim'.
        >
        > If the --with-vim-name option is used (such as "--with-vim-name=vim7")
        > then test49 fails.
        >
        > Here is a minor patch.....

        Argh!@, I should not have hit the return key so fast, that patch doesn't
        fix all the problems. Sorry.

        --
        +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
        Gregory H. Margo
        gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org
      • Bram Moolenaar
        ... I see the problem you want to fix. But Vim doesn t always get the $VIMPROG environment variable from make. Another solution is to create a symlink from
        Message 3 of 4 , Apr 28, 2006
        • 0 Attachment
          Gregory Margo wrote:

          > test49.vim assumes the binary is named 'vim'.
          >
          > If the --with-vim-name option is used (such as "--with-vim-name=vim7")
          > then test49 fails.
          >
          > Here is a minor patch that makes test49 respect the VIMPROG environment
          > variable from the Makefile, falling back to the current value
          > if not found:
          >
          > --- vim70f/src/testdir/test49.vim.00 2006-02-28 05:36:54.000000000 -0800
          > +++ vim70f/src/testdir/test49.vim 2006-04-27 16:26:31.677399006 -0700
          > @@ -454,9 +454,10 @@
          > " pipe are consumed at the debug prompt. Use "-N" to enable command-line
          > " continuation ("C" in 'cpo'). Add "nviminfo" to 'viminfo' to avoid
          > " messing up the user's viminfo file.
          > + let vimprog = exists($VIMPROG) ? $VIMPROG : "../vim"
          > let redirect = a:0 ?
          > \ " -c 'au VimLeave * redir END' -c 'redir\\! >" . a:1 . "'" : ""
          > - exec "!echo '" . debug_quits . "q' | ../vim -u NONE -N -Xes" . redirect .
          > + exec "!echo '" . debug_quits . "q' | " . vimprog . " -u NONE -N -Xes" . redirect .
          > \ " -c 'debuggreedy|set viminfo+=nviminfo'" .
          > \ " -c 'let ExtraVimBegin = " . extra_begin . "'" .
          > \ " -c 'let ExtraVimResult = \"" . resultfile . "\"'" . breakpoints .

          I see the problem you want to fix. But Vim doesn't always get the
          $VIMPROG environment variable from make.

          Another solution is to create a symlink from vim to the target used.
          Try this patch:

          --- Makefile 24 Apr 2006 19:27:13 -0000 1.63
          +++ Makefile 28 Apr 2006 09:28:31 -0000
          @@ -1719,6 +1720,9 @@
          -if test -n "$(MAKEMO)" -a -f $(PODIR)/Makefile; then \
          cd $(PODIR); $(MAKE) -f Makefile check VIM=../$(VIMTARGET); \
          fi
          + -if test $(VIMTARGET) != vim -a ! -e vim; then \
          + ln -s $(VIMTARGET) vim; \
          + fi
          cd testdir; $(MAKE) -f Makefile $(GUI_TESTTARGET) VIMPROG=../$(VIMTARGET) $(GUI_TESTARG)

          testclean:


          Would this have any problems?

          --
          LAUNCELOT: Isn't there a St. Aaaaarrrrrrggghhh's in Cornwall?
          ARTHUR: No, that's Saint Ives.
          "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ download, build and distribute -- http://www.A-A-P.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
        • Gregory Margo
          ... Seems to work fine. I just compiled and tested the vim70g code, which has your patch. thanks, gm --
          Message 4 of 4 , May 1, 2006
          • 0 Attachment
            On Fri, Apr 28, 2006 at 11:44:06AM +0200, Bram Moolenaar wrote:
            >
            > I see the problem you want to fix. But Vim doesn't always get the
            > $VIMPROG environment variable from make.
            >
            > Another solution is to create a symlink from vim to the target used.
            > Try this patch:
            >
            > Would this have any problems?

            Seems to work fine. I just compiled and tested the vim70g code,
            which has your patch.

            thanks,
            gm

            --
            +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
            Gregory H. Margo
            gmargo at yahoo/com, gmail/com, pacbell/net; greg at margofamily/org
          Your message has been successfully submitted and would be delivered to recipients shortly.