Loading ...
Sorry, an error occurred while loading the content.
 

Problems OS X intel 6.x series

Expand Messages
  • Brad Beveridge
    I ve spent most of today trying to build various Vims (6.2, 6.4, 6 series CVS) under OS X Intel. I configured with ./configure --prefix=/opt/local
    Message 1 of 4 , Apr 1, 2006
      I've spent most of today trying to build various Vims (6.2, 6.4, 6
      series CVS) under OS X Intel.
      I configured with "./configure --prefix=/opt/local --disable-darwin" I
      only want the console version.
      I was getting malloc/free problems in expand_files, it looked like
      repl was being freed without being assigned to a valid pointer.
      After much insanity, it appears that Apple's GCC causes some breakage
      with -O2. Reducing the optimisation level to -O, it works again.

      gcc --version
      i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5250)

      Can some other OS X Intel owners try this to confirm there is a
      problem? Any idea how to raise this with Apple?

      Cheers
      Brad
    • Chris Allen
      ... Yes, this is a known bug in GCC 4 shipping with OS X (for both architectures, I m pretty sure). ... Nope, sorry. HTH, Chris Allen
      Message 2 of 4 , Apr 1, 2006
        On 4/2/06, Brad Beveridge <brad.beveridge@...> wrote:
        > Can some other OS X Intel owners try this to confirm there is a
        > problem?

        Yes, this is a known bug in GCC 4 shipping with OS X (for both
        architectures, I'm pretty sure).

        > Any idea how to raise this with Apple?

        Nope, sorry.

        HTH,
        Chris Allen
      • David Chin
        ... You may try submitting a bug report: http://developer.apple.com/bugreporter/ You ll have to sign up for a Developer Connection account, first. -- Dave
        Message 3 of 4 , Apr 2, 2006
          > Any idea how to raise this with Apple?

          You may try submitting a bug report:

          http://developer.apple.com/bugreporter/

          You'll have to sign up for a Developer Connection account, first.

          -- Dave
          Email: david.w.h.chin@...
        • Bram Moolenaar
          ... This is a gcc 4.0.1 problem. The optimizer reorders the code, so that a block of memory is freed before it is used. I stepped through it with the
          Message 4 of 4 , Apr 2, 2006
            Brad Beveridge wrote:

            > I've spent most of today trying to build various Vims (6.2, 6.4, 6
            > series CVS) under OS X Intel.
            > I configured with "./configure --prefix=3D/opt/local --disable-darwin" I
            > only want the console version.
            > I was getting malloc/free problems in expand_files, it looked like
            > repl was being freed without being assigned to a valid pointer.
            > After much insanity, it appears that Apple's GCC causes some breakage
            > with -O2. Reducing the optimisation level to -O, it works again.
            >
            > gcc --version
            > i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5250)
            >
            > Can some other OS X Intel owners try this to confirm there is a
            > problem? Any idea how to raise this with Apple?

            This is a gcc 4.0.1 problem. The optimizer reorders the code, so that a
            block of memory is freed before it is used. I stepped through it with
            the debugger to verify this actually happens.

            I haven't reported it, the docs on how to report bugs is very confusing.

            --
            This message contains 78% recycled characters.

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ download, build and distribute -- http://www.A-A-P.org ///
            \\\ help me help AIDS victims -- http://www.ICCF.nl ///
          Your message has been successfully submitted and would be delivered to recipients shortly.