Loading ...
Sorry, an error occurred while loading the content.

Re: virtualedit bug

Expand Messages
  • Bram Moolenaar
    ... It is caused by the new matchparen plugin. You can disable it with :NoMatchParen . Or include this patch: diff -u -r1.1 matchparen.vim ... +++
    Message 1 of 5 , Mar 1, 2006
    • 0 Attachment
      Ralf Wildenhues wrote:

      > I noted a regression introduced recently:
      >
      > With a ~/.vimrc containing only
      >
      > set nocompatible
      > if has("virtualedit")
      > set virtualedit=block
      > endif
      >
      > no other own configuration files, and then typing
      > vim
      > i[
      >
      > the cursor does not move past the inserted bracket. It is not possible with
      > movements to get behind the bracket. Same with parentheses.

      It is caused by the new matchparen plugin. You can disable it with
      ":NoMatchParen". Or include this patch:

      diff -u -r1.1 matchparen.vim
      --- ../runtime/plugin/matchparen.vim 27 Feb 2006 23:47:59 -0000 1.1
      +++ ../runtime/plugin/matchparen.vim 1 Mar 2006 14:10:34 -0000
      @@ -81,6 +81,8 @@
      if before > 0
      if &ve != ''
      let vcol = virtcol('.')
      + let old_ve = &ve
      + set ve=all
      endif
      call cursor(c_lnum, c_col - before)
      endif
      @@ -88,6 +90,7 @@
      if before > 0
      if &ve != ''
      exe 'normal ' . vcol . '|'
      + let &ve = old_ve
      else
      call cursor(0, c_col)
      endif


      --
      Anyone who is capable of getting themselves made President should on no
      account be allowed to do the job.
      -- Douglas Adams, "The Hitchhiker's Guide to the Galaxy"

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ download, build and distribute -- http://www.A-A-P.org ///
      \\\ help me help AIDS victims -- http://www.ICCF.nl ///
    • Ralf Wildenhues
      Hi Bram, ... Yes. Both the patch and the command fix the issue I observed. Thanks! Ralf
      Message 2 of 5 , Mar 1, 2006
      • 0 Attachment
        Hi Bram,

        Bram Moolenaar <Bram <at> moolenaar.net> writes:
        >
        > It is caused by the new matchparen plugin. You can disable it with
        > ":NoMatchParen". Or include this patch:

        Yes. Both the patch and the command fix the issue I observed.

        Thanks!
        Ralf
      Your message has been successfully submitted and would be delivered to recipients shortly.