Loading ...
Sorry, an error occurred while loading the content.

Re: gvim7: 3 startup issues

Expand Messages
  • A. J. Mechelynck
    Zdenek SEKERA wrote: [...] ... That setting is for gvim with X11 _other_ than GTK+2 and kvim. In gvim for GTK+2 it is not valid. Try ... xlsfonts does show it,
    Message 1 of 8 , Feb 28, 2006
    • 0 Attachment
      Zdenek SEKERA wrote:
      > It surely looks like it thinks my tried fonts are not monospaced.
      > To answer better your questions (I tested gvim-gtk2):
      > - set guifont= no double space but I have no idea what font
      > is being used
      > - set guifont=screen15 (I don't have that font -> get double space)
      > - set guifont=-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1
      > -> get double space, I have that font and use it in xterm)

      That setting is for gvim with X11 _other_ than GTK+2 and kvim. In gvim
      for GTK+2 it is not valid. Try

      :set guifont=Fixed\ 13

      > I just tried your choice 'set guifont=courier\ 10' and it works.
      > Hmmmm, I don't understand it.
      > 'xlsfonts' doesn't show this font so I don't have so in all logic it
      > should behave like the case above with 'screen15', but in this
      > case I don't get double space. What's going on here ??

      xlsfonts does show it, in xlsfonts format, probably as something
      beginning "-misc-courier-medium-r-normal-". Instead of "misc", the first
      part could be something else.

      > Would you or anyone know the way to findout what font is actually
      > used in (g)vim???
      > Thanks,
      > ---Zdenek

      See ":help setting-guifont" (if you have that helptag) to see the 4
      different formats of 'guifont'. Each version of gvim accepts only one of
      these formats. The format for 'guifont' in gvim for GTK+2 is <base
      name><space><height>. The base name can include spaces, as in e.g.

      :set guifont=Andale\ Mono\ 11

      which means "11-point Andale Mono". This format is incompatible with
      xlsfont. Remember that spaces in the value of an option (after the equal
      sign in the ":set" statement) must be backslash-escaped.

      On some systems, including GTK (I'm not sure about GTK+2), doing

      :set guifont=*

      will bring a pop-up menu similar to what you get for setting fonts in
      other X11 or Windows applications. Another possibility, assuming you
      have 'nocompatible' set, is to type

      :set guifont=<Tab>

      which will (on all flavours of gvim including those which don't
      recognise ":set guifont=*") bring the current value on the command-line,
      with backslash-escapes if and where needed. Edit it to your heart's
      delight, then accept the new value with <Enter> or abandon the changes
      with <Esc>.

      Best regards,
    Your message has been successfully submitted and would be delivered to recipients shortly.