Loading ...
Sorry, an error occurred while loading the content.
 

Fwd: Re: Context menu and cindent

Expand Messages
  • Allen Castaban
    It definitely looks like a bug... I turned on the verbose and script names. It has exact the same output when I start gvim from the context menu or from the
    Message 1 of 2 , Nov 30, 2005
      It definitely looks like a bug...
      I turned on the verbose and script names.
      It has exact the same output when I start gvim from
      the context menu or from the command line. I actually
      discovered that when I double click on a file which by
      default edited by VIM, cindent is turned off again. So
      that takes gvimext out of the picture, as in this case
      "C:\Program Files\Vim\vim63\gvim.exe" %1 is executed.

      When I start vim, it reports to me that cindent is
      last set from _vimrc and
      scripts executed are _vimrc,syntax.vim, synload.vim,
      syncolor.vim, filetype.vim,menu.vim
      A Simple grep search from vim/vim63 directory by
      executing grep nocin */*.vim did not turn up anything.

      Can somebody try this out, in 6.3 and 6.4
      That will be very helpfull
      --- Benji Fisher <benji@...> wrote:

      > Date: Wed, 30 Nov 2005 08:25:35 -0500
      > From: Benji Fisher <benji@...>
      > Subject: Re: Context menu and cindent
      > To: vim-dev@...
      >
      > On Tue, Nov 29, 2005 at 03:40:43PM -0500, Allen
      > Castaban wrote:
      > > When I start VIM from the Windows Context menu, my
      > cindent is turned
      > > off, although I have it turned on in my vimrc
      > file. When I start it
      > > regular way, it is OK
      > > Is this a bug a feature gvimext.dll? How can I fix
      > it?
      > > (I am using 6.3 in Windows 2000)
      > > Thanks
      >
      > I can think of three explanations:
      >
      > 1. Some other file is being :source'd after your
      > vimrc file, changing
      > the value of cindent.
      >
      > 2. Your vimrc file is not being :source'd.
      >
      > 3. There is a bug in vim.
      >
      > You should be able to figure out which it is using
      >
      > :verbose set cindent?
      > :scriptnames
      >
      > and perhaps by adding some diagnostics to your vimrc
      > file, for example
      >
      > call confirm('Start of vimrc file')
      > ...
      > call confirm('End of vimrc file')
      >
      > or
      >
      > let foo = 'Start of vimrc file 30 November 2005'
      > ...
      > let bar = 'End of vimrc file 30 November 2005'
      >
      > HTH --Benji Fisher
      >
    • A. J. Mechelynck
      ... [...] What does it say when you ask ... when you notice that cindent has got turned off ? Is there a difference with the answers to the same questions
      Message 2 of 2 , Nov 30, 2005
        Allen Castaban wrote:
        > It definitely looks like a bug...
        > I turned on the verbose and script names.
        > It has exact the same output when I start gvim from
        > the context menu or from the command line. I actually
        > discovered that when I double click on a file which by
        > default edited by VIM, cindent is turned off again. So
        > that takes gvimext out of the picture, as in this case
        > "C:\Program Files\Vim\vim63\gvim.exe" %1 is executed.
        >
        > When I start vim, it reports to me that cindent is
        > last set from _vimrc and
        > scripts executed are _vimrc,syntax.vim, synload.vim,
        > syncolor.vim, filetype.vim,menu.vim
        > A Simple grep search from vim/vim63 directory by
        > executing grep nocin */*.vim did not turn up anything.
        [...]

        What does it say when you ask
        :verbose set cindent? cinoptions? indentexpr?
        :scriptnames
        when you notice that cindent has got "turned off"? Is there a difference
        with the answers to the same questions when cindent is working?

        Best regards,
        Tony.
      Your message has been successfully submitted and would be delivered to recipients shortly.