Loading ...
Sorry, an error occurred while loading the content.

RE: Suggestion: set hlsearch={pattern}

Expand Messages
  • Halim, Salman
    Might I suggest a simple workaround? Instead of doing c/; , try ct; instead... (I m assuming that the semicolon you are attempting to change is on the
    Message 1 of 4 , Oct 17, 2005
    • 0 Attachment
      Might I suggest a simple workaround? Instead of doing 'c/;', try 'ct;'
      instead... (I'm assuming that the semicolon you are attempting to
      change is on the same line as the cursor.)

      Salman.

      > -----Original Message-----
      > From: Alexander.Farber@... [mailto:Alexander.Farber@...]
      > Sent: Monday, October 17, 2005 8:49 AM
      > To: vim-dev@...
      > Subject: RE: Suggestion: set hlsearch={pattern}
      >
      > Thank you, but this would require hitting an extra key.
      >
      > And also the DWIM-principle:
      >
      > When you have hlsearch switched on, do you really want to see
      > all the semicolons after you replaced some C-statement with a
      > "c/;"? I think not!
      >
      > Regards
      > Alex
      >
      > > -----Original Message-----
      > > From: ext John Love-Jensen [mailto:eljay@...]
      > >
      > > " Toggle search highlight on/off.
      > > :nmap <F3> :set hls!<CR>:set hls?<CR>
      > >
      > > You can also type this to turn off hls until next search:
      > > :noh
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.