Loading ...
Sorry, an error occurred while loading the content.

Old piece of code in Vim 7.x

Expand Messages
  • Lubomir Host
    Hi vimmers! ... if (STRNCMP(b0p- b0_version, VIM 3.0 , 7) == 0) { msg_start(); msg_outtrans_attr(mfp- mf_fname, MSG_HIST); MSG_PUTS_ATTR(_( cannot be used
    Message 1 of 1 , Sep 30 3:35 AM
    • 0 Attachment
      Hi vimmers!

      A piece of code from vim7/src/memline.c line 953 - 962:

      --------------------------------------%<--------------------------------------
      if (STRNCMP(b0p->b0_version, "VIM 3.0", 7) == 0)
      {
      msg_start();
      msg_outtrans_attr(mfp->mf_fname, MSG_HIST);
      MSG_PUTS_ATTR(_(" cannot be used with this version of Vim.\n"),
      MSG_HIST);
      MSG_PUTS_ATTR(_("Use Vim version 3.0.\n"), MSG_HIST);
      msg_end();
      goto theend;
      }
      --------------------------------------%<--------------------------------------

      Do we need this piece of code? I think Vim 3.0 is quite old. How many
      years ago was Vim 3.0 released?

      rajo

      --
      Lubomir Host 'rajo' <rajo AT platon.sk> ICQ #: 257322664 ,''`.
      Platon Software Development Group http://platon.sk/ : :' :
      Homepage: http://rajo.platon.sk/en/references `. `'
      http://www.gnu.org/philosophy/no-word-attachments.html `-
    Your message has been successfully submitted and would be delivered to recipients shortly.