Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 7: Editing a directory

Expand Messages
  • Johnny Blaze
    Charles, running it with -u NONE -U NONE does help a little... Decho DBG window says: ssh is not executable, can t do remote directory exploring running ...
    Message 1 of 6 , Jan 17, 2005
    • 0 Attachment
      Charles,

      running it with -u NONE -U NONE does help a little...

      Decho DBG window says:
      ssh is not executable, can't do remote directory exploring

      running
      :set verbose=1000
      :e c:\
      gives:

      "C:\" illegal file name
      Executing BufEnter Auto commands for "*"
      autocommand if expand("%:p:h") !~ "^$" | lcd %:p:h | end if
      line 0: if expand ....
      line 0: lcd %p:h | endif
      line 0: endif
      Executing BufEnter Auto commands for "*"
      autocommand call <SID>LocalBrowse(expand("<afile>")
      line 0: call <SID>LocalBrowse(expand("<afile>")
      calling function <SNR>33_LocalBrowse("")
      line 1:
      line 2: " let dirname = (a:dirname="") ? expand("%:p") : a:dirname
      line 3: if !isdirectory(a:dirname)
      line 4: "ignore it
      line 5: return
      function <SNR>33_LocalBrowse returning #0
      continuing ...

      :echo g:loaded_netrw
      v54a


      On Sun, 16 Jan 2005 21:45:59 -0800, drchip@...
      <drchip@...> wrote:
      > Quoting Johnny Blaze <pyromancer@...>:
      >
      > > I tried the same tests as I did previously, and I get the same
      > > results. It looks like VIM isn't doing any autocmds it just keeps
      > > complaining that any directory name is an invalid file.
      >
      > To find out more, you'll need to use the internal debugger. You'll
      > need the Decho plugin, available at:
      >
      > http://vim.sourceforge.net/scripts/script.php?script_id=120
      >
      > Install it, then
      >
      > vim netrw.vim
      > :DechoOn
      > :wq
      >
      > Next time you use netrw, a debugging window will appear. Please save the
      > window and send it to me. You may wish to remove the password if you
      > use one which will appear in the debugging output.
      >
      > FYI - I tried netrw v54a with both cygwin and cmd windows under WinXP.
      > I then also tried it with vim -u NONE -N under both windows in order
      > to avoid any personal-setting effects. You may wish to do so, too. If
      > netrw suddenly starts working, then some setting in your <.vimrc> is likely
      > to be interfering. In such a case I'd very much like to find out what
      > it is so I can program around it.
      >
      > Good luck!
      > Chip Campbell
      >
      >


      --

      . o O pyromancer O o .
    Your message has been successfully submitted and would be delivered to recipients shortly.