Loading ...
Sorry, an error occurred while loading the content.

Bug report repeating text with insertmode option set

Expand Messages
  • Jens Paulus
    Hi developers, here comes a serious bug report. If the insertmode option is unset it works as it should and an entered text can be repeated with a count number
    Message 1 of 2 , Jan 4, 2005
    • 0 Attachment
      Hi developers,

      here comes a serious bug report. If the insertmode option is unset it
      works as it should and an entered text can be repeated with a count
      number given, for example 4isometext<Esc> repeats the entered text. But
      if the insertmode option is set and when trying to repeat an entered
      text with <C-L>4isometext<C-L><Esc> then after the second <C-L> nothing
      works anymore and everything is hanging and this process needs to be
      externally killed with the kill -1 processnumber command. What I have
      not tried is if this also happens when trying to enter
      <C-L>4<Esc>sometext<C-L><Esc> but I assume this because <C-L>i and
      <C-L><Esc> are supposed to be equivalent. Also I have not tried
      repeating text using <C-O> instead of <C-L> to enter Normal mode and if
      that fails, too. There is no repeat command in Insert mode and therefore
      this is the only way to repeat text.

      Best regards

      Jens
    • Bram Moolenaar
      ... I can see a hang, although not always. I ll fix it. -- hundred-and-one symptoms of being an internet addict: 235. You start naming your kids Pascal,
      Message 2 of 2 , Jan 4, 2005
      • 0 Attachment
        Jens Paulus wrote:

        > here comes a serious bug report. If the insertmode option is unset it
        > works as it should and an entered text can be repeated with a count
        > number given, for example 4isometext<Esc> repeats the entered text. But
        > if the insertmode option is set and when trying to repeat an entered
        > text with <C-L>4isometext<C-L><Esc> then after the second <C-L> nothing
        > works anymore and everything is hanging and this process needs to be
        > externally killed with the kill -1 processnumber command. What I have
        > not tried is if this also happens when trying to enter
        > <C-L>4<Esc>sometext<C-L><Esc> but I assume this because <C-L>i and
        > <C-L><Esc> are supposed to be equivalent. Also I have not tried
        > repeating text using <C-O> instead of <C-L> to enter Normal mode and if
        > that fails, too. There is no repeat command in Insert mode and therefore
        > this is the only way to repeat text.

        I can see a hang, although not always. I'll fix it.

        --
        hundred-and-one symptoms of being an internet addict:
        235. You start naming your kids Pascal, COBOL, Algol and Fortran.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html ///
      Your message has been successfully submitted and would be delivered to recipients shortly.