Loading ...
Sorry, an error occurred while loading the content.

FAQ: Windows and the time change

Expand Messages
  • Dan Sharp
    ... I started to send a reminder email mentioning this problem this morning but couldn t reproduce it on my machine, so I wasn t sure if it only occurred on
    Message 1 of 2 , Oct 31, 2004
    • 0 Attachment
      Robin Becker wrote:
      > My time zone switched over today BST-->GMT and I now find that VIM
      > thinks the filetimes are wrong. So I get a W11 message opening a file
      > and doing :w immediately.
      >
      > I have used VI/VIM/GVIM for a long time and never saw this before. Is
      > it GVIM or perhaps some evil monitor/spy program. Procexp doesn't see
      > anyone else working on the file.
      >
      > I am using XP SP2 and GVIM has version below.

      I started to send a reminder email mentioning this problem this morning
      but couldn't reproduce it on my machine, so I wasn't sure if it only
      occurred on the Spring time change or both. This is a problem on
      Windows systems. The FAQ entry from
      http://vimdoc.sourceforge.net/vimfaq.html#33.12 is quoted below.

      =====
      33.12. Everytime I save a file, Vim warns about the file being changed
      outside of Vim. Why?

      If you get the following warning message, everytime you save a file:

      WARNING: The file has been changed since reading it!!!
      Do you really want to write to it (y/n)?

      then this problem could be related to a bug in MS-Windows on the day
      daylight saving time starts. Vim remembers the timestamp of the file
      after it was written. Just before the next write the timestamp is
      obtained again to check if the file was changed outside of Vim. This
      works correctly, except on the day daylight saving time starts.

      This problem will go away the next day after the day the daylight saving
      time starts.

      For more information, read

      :help W11
      =====

      Dan Sharp
    • Bob Davis
      ... I just got the bug by leaving gvim editing a file all nite long. When I tried to use it today it gave this error msg. As per the W11 help setting TZ=-5
      Message 2 of 2 , Nov 1, 2004
      • 0 Attachment
        Dan Sharp wrote:
        > Robin Becker wrote:
        > > My time zone switched over today BST-->GMT and I now find that VIM
        > > thinks the filetimes are wrong. So I get a W11 message opening a file
        > > and doing :w immediately.
        > >
        > > I have used VI/VIM/GVIM for a long time and never saw this before. Is
        > > it GVIM or perhaps some evil monitor/spy program. Procexp doesn't see
        > > anyone else working on the file.
        > >
        > > I am using XP SP2 and GVIM has version below.
        >
        > I started to send a reminder email mentioning this problem this morning
        > but couldn't reproduce it on my machine, so I wasn't sure if it only
        > occurred on the Spring time change or both. This is a problem on
        > Windows systems. The FAQ entry from
        > http://vimdoc.sourceforge.net/vimfaq.html#33.12 is quoted below.
        >
        > =====
        > 33.12. Everytime I save a file, Vim warns about the file being changed
        > outside of Vim. Why?
        >
        > If you get the following warning message, everytime you save a file:
        >
        > WARNING: The file has been changed since reading it!!!
        > Do you really want to write to it (y/n)?
        >
        > then this problem could be related to a bug in MS-Windows on the day
        > daylight saving time starts. Vim remembers the timestamp of the file
        > after it was written. Just before the next write the timestamp is
        > obtained again to check if the file was changed outside of Vim. This
        > works correctly, except on the day daylight saving time starts.
        >
        > This problem will go away the next day after the day the daylight saving
        > time starts.
        >
        > For more information, read
        >
        > :help W11
        > =====
        >
        > Dan Sharp
        >

        I just got the bug by leaving gvim editing a file all nite long. When I tried to use it today it gave this error msg. As
        per the W11 help setting TZ=-5 worked for me.
      Your message has been successfully submitted and would be delivered to recipients shortly.