Loading ...
Sorry, an error occurred while loading the content.

vim & utf8 / xterm highlighting problem

Expand Messages
  • Johannes Zellner
    Hello, I ve a strange problem here. If I run vim in an utf8 enabled xterm, the colors are not set correctly sometimes. For example the cursor, which should be
    Message 1 of 2 , Oct 4, 2004
    • 0 Attachment
      Hello,

      I've a strange problem here. If I run vim in an utf8 enabled xterm,
      the colors are not set correctly sometimes.

      For example the cursor, which should be black according to my X
      resources get's sometimes the color of the StatusLine foreground.
      (E.g. yellow here).

      After the xterm gets expose events (e.g. when cycling windows or
      switching workspaces) or after I do manually a redraw with <ctrl-l>
      everything is highlighted correctly.

      I tried that with both vim 6.3 and vim 7.

      The strangest thing about it is that it depends on the xterm font.
      I tried different iso10646 fonts, the font which reproduces
      the problem is

      -gnu-unifont-*-*-*-*-17-*-*-*-*-*-iso10646-*

      I don't really know if this is a vim problem, but maybe someone
      observed a similar problem.

      Any ideas?

      --
      Johannes
    • Bram Moolenaar
      ... If the problem goes away when exposing the xterm window, then it very probably is an xterm problem. Vim doesn t do any redrawing then. You might want to
      Message 2 of 2 , Oct 5, 2004
      • 0 Attachment
        Johannes Zellner wrote:

        > I've a strange problem here. If I run vim in an utf8 enabled xterm,
        > the colors are not set correctly sometimes.
        >
        > For example the cursor, which should be black according to my X
        > resources get's sometimes the color of the StatusLine foreground.
        > (E.g. yellow here).
        >
        > After the xterm gets expose events (e.g. when cycling windows or
        > switching workspaces) or after I do manually a redraw with <ctrl-l>
        > everything is highlighted correctly.
        >
        > I tried that with both vim 6.3 and vim 7.
        >
        > The strangest thing about it is that it depends on the xterm font.
        > I tried different iso10646 fonts, the font which reproduces
        > the problem is
        >
        > -gnu-unifont-*-*-*-*-17-*-*-*-*-*-iso10646-*
        >
        > I don't really know if this is a vim problem, but maybe someone
        > observed a similar problem.
        >
        > Any ideas?

        If the problem goes away when exposing the xterm window, then it very
        probably is an xterm problem. Vim doesn't do any redrawing then.
        You might want to report the problem to Thomas Dickey. First try
        installing the latest version from http://invisible-island.net/xterm.

        --
        hundred-and-one symptoms of being an internet addict:
        84. Books in your bookcase bear the names Bongo, WinSock and Inside OLE

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
      Your message has been successfully submitted and would be delivered to recipients shortly.