Loading ...
Sorry, an error occurred while loading the content.

Re: Compiled "working" gvim on Solaris 2.8, but bug in configure

Expand Messages
  • Bram Moolenaar
    ... That s probably a GTK problem. Loading its libraries and doing the GUI startup stuff can be slow. ... [...] ... This is non-standard, thus the existing
    Message 1 of 3 , Oct 2, 2004
    • 0 Attachment
      Steve Hobbs wrote:

      > QUESTION:
      > It now works but the GTK2-GUI version takes about 10-15 seconds to
      > appear. Any ideas??? (The non-GUI version is almost instant)

      That's probably a GTK problem. Loading its libraries and doing the
      GUI startup stuff can be slow.

      > DETAILS ON THE BUG:
      > We have an existing /usr/local structure which has a particular version
      > of tools from SunFreeware.com. I didn't want to break this structure so
      > I went about creating an entirely new structure in "/usr/local2".
      [...]
      > I couldn't get the tool to recognise my nice new installation in
      > "/usr/local2". It kept saying it couldn't find it.

      This is non-standard, thus the existing configure won't find anything
      there. You will have to fall back to manually specifying paths.

      You might want to compile with Motif instead, it's a "lighter" GUI than
      GTK and it's supported by Sun. But it doesn't look that nice and it's
      not free (although lesstif is a good Motif replacement).

      --
      "Oh, no! NOT the Spanish Inquisition!"
      "NOBODY expects the Spanish Inquisition!!!"
      -- Monty Python sketch --
      "Oh, no! NOT another option!"
      "EVERYBODY expects another option!!!"
      -- Discussion in vim-dev mailing list --

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
    • David Necas (Yeti)
      ... I also remember some troubles with font scanning. Maybe strace/truss gvim could give a clue... Yeti -- Do not use tab characters. Their effect is not
      Message 2 of 3 , Oct 2, 2004
      • 0 Attachment
        On Sat, Oct 02, 2004 at 05:29:48PM +0200, Bram Moolenaar wrote:
        >
        > Steve Hobbs wrote:
        >
        > > QUESTION:
        > > It now works but the GTK2-GUI version takes about 10-15 seconds to
        > > appear. Any ideas??? (The non-GUI version is almost instant)
        >
        > That's probably a GTK problem. Loading its libraries and doing the
        > GUI startup stuff can be slow.

        I also remember some troubles with font scanning. Maybe
        strace/truss gvim could give a clue...

        Yeti


        --
        Do not use tab characters. Their effect is not predictable.
      Your message has been successfully submitted and would be delivered to recipients shortly.