Loading ...
Sorry, an error occurred while loading the content.

Compiled "working" gvim on Solaris 2.8, but bug in configure

Expand Messages
  • Steve Hobbs
    Firstly I ll say this is my first post to this group and I ve not been monitoring traffic, so apologies if I break protocol here. I ve been trying for the last
    Message 1 of 3 , Oct 1, 2004
    • 0 Attachment
      Firstly I'll say this is my first post to this group and I've not been
      monitoring traffic, so apologies if I break protocol here.

      I've been trying for the last two days to compile gvim on Solaris 2.8
      from source, and I've finally achieved it (almost), in the process I've
      found what I consider a bug in the vim63/src/auto/configure.

      QUESTION:
      It now works but the GTK2-GUI version takes about 10-15 seconds to
      appear. Any ideas??? (The non-GUI version is almost instant)

      DETAILS ON THE BUG:
      We have an existing /usr/local structure which has a particular version
      of tools from SunFreeware.com. I didn't want to break this structure so
      I went about creating an entirely new structure in "/usr/local2".

      This meant I had to compile *everything* from source, which is a
      process that's taken ages.

      When I reached vim I noticed it required a toolkit to run the GUI, so I
      choose GTK2. This was painful to say the least, but the mail at:
      http://mail.gnome.org/archives/gtk-list/2004-August/msg00004.html
      helped considerably.

      Finally after testing GTK2 with gtk-demo I tried to compile VIM.

      I couldn't get the tool to recognise my nice new installation in
      "/usr/local2". It kept saying it couldn't find it.

      I finally discovered the problem today.
      "/usr/local" is HARDCODED into all of the tests that configure runs in
      vim63/src/auto/configure.

      I therefore run the following line to make all of the "/usr/local"
      references to my new "/usr/local2":
      perl -pi -e 's#/usr/local([^2])#/usr/local2$1#g' \
      vim63/src/auto/configure

      I also made sure my path and LD_LIBRARY_PATH were setup to ignore
      "/usr/local".

      Here are the commands I finally used to compile:
      (running in a bash shell)
      TOOL=vim63
      cd /usr/local2/src/vim
      bunzip2 -c vim-6.3.tar.bz2 | tar xvf -
      chown -R root:other *
      # ALL OF THE VIM tests hard code the /usr/local directory for all tests
      # This line overrides it!
      perl -pi -e 's#/usr/local([^2])#/usr/local2$1#g'
      vim63/src/auto/configure
      (PATH=/usr/local2/bin:/usr/dt/bin:/bin:/usr/sbin:/usr/openwin/bin:/tools/Pharos/bin:/usr/lsf.local/bin;
      \

      LD_LIBRARY_PATH=/usr/local2/lib:/usr/dt/lib:/usr/lib:/usr/openwin/lib:/usr/X/lib;
      \
      cd ${TOOL} && \
      ./configure --prefix=/usr/local2 \
      ) > ${TOOL}_configure.log 2>&1
      (cd ${TOOL} && make) > ${TOOL}_make.log 2>&1
      (cd ${TOOL} && make install) > ${TOOL}_make_install.log 2>&1

      Regards,

      Steve


      ______________________________________________________________________
      Post your free ad now! http://personals.yahoo.ca
    • Bram Moolenaar
      ... That s probably a GTK problem. Loading its libraries and doing the GUI startup stuff can be slow. ... [...] ... This is non-standard, thus the existing
      Message 2 of 3 , Oct 2, 2004
      • 0 Attachment
        Steve Hobbs wrote:

        > QUESTION:
        > It now works but the GTK2-GUI version takes about 10-15 seconds to
        > appear. Any ideas??? (The non-GUI version is almost instant)

        That's probably a GTK problem. Loading its libraries and doing the
        GUI startup stuff can be slow.

        > DETAILS ON THE BUG:
        > We have an existing /usr/local structure which has a particular version
        > of tools from SunFreeware.com. I didn't want to break this structure so
        > I went about creating an entirely new structure in "/usr/local2".
        [...]
        > I couldn't get the tool to recognise my nice new installation in
        > "/usr/local2". It kept saying it couldn't find it.

        This is non-standard, thus the existing configure won't find anything
        there. You will have to fall back to manually specifying paths.

        You might want to compile with Motif instead, it's a "lighter" GUI than
        GTK and it's supported by Sun. But it doesn't look that nice and it's
        not free (although lesstif is a good Motif replacement).

        --
        "Oh, no! NOT the Spanish Inquisition!"
        "NOBODY expects the Spanish Inquisition!!!"
        -- Monty Python sketch --
        "Oh, no! NOT another option!"
        "EVERYBODY expects another option!!!"
        -- Discussion in vim-dev mailing list --

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
      • David Necas (Yeti)
        ... I also remember some troubles with font scanning. Maybe strace/truss gvim could give a clue... Yeti -- Do not use tab characters. Their effect is not
        Message 3 of 3 , Oct 2, 2004
        • 0 Attachment
          On Sat, Oct 02, 2004 at 05:29:48PM +0200, Bram Moolenaar wrote:
          >
          > Steve Hobbs wrote:
          >
          > > QUESTION:
          > > It now works but the GTK2-GUI version takes about 10-15 seconds to
          > > appear. Any ideas??? (The non-GUI version is almost instant)
          >
          > That's probably a GTK problem. Loading its libraries and doing the
          > GUI startup stuff can be slow.

          I also remember some troubles with font scanning. Maybe
          strace/truss gvim could give a clue...

          Yeti


          --
          Do not use tab characters. Their effect is not predictable.
        Your message has been successfully submitted and would be delivered to recipients shortly.