Loading ...
Sorry, an error occurred while loading the content.

changing directory with perl enabled windows version of vim (fwd)

Expand Messages
  • mkaminsky@softhome.net
    Hi, I ve got no answer to the following problem on the users list. Thought I d try the dev list before reporting it as a bug. Moshe ... Date: Sat, 28 Aug 2004
    Message 1 of 1 , Aug 31, 2004
    • 0 Attachment
      Hi,

      I've got no answer to the following problem on the users list. Thought I'd
      try the dev list before reporting it as a bug.

      Moshe

      ----------Forwarded message ---------
      Date: Sat, 28 Aug 2004 23:02:40 +0300
      From: Moshe Kaminsky <kaminsky@...>
      To: Vim Mailing List <vim@...>
      Subject: changing directory with perl enabled windows version of vim
      Message-ID: <20040828200240.GA27087@kaminsky>
      Mail-Followup-To: Vim Mailing List <vim@...>
      Mime-Version: 1.0
      Content-Type: multipart/signed; micalg=pgp-sha1;
      protocol="application/pgp-signature"; boundary="tThc/1wpZn/ma/RB"
      Content-Disposition: inline
      X-Accept-Language: en
      X-Location: Israel, Rehovot
      X-Editor: Vim 6.3 http://vim.sf.net/
      User-Agent: Mutt/1.5.6i

      Hi,

      It appears that if, on windows, one starts (a perl enabled) vim, and
      then changes directory (:cd C:\foo), this change is not reflected in the
      perl interpreter. This can be witnessed, eg, by running

      :perl use Cwd;VIM::Msg(cwd)

      (after changing the directory). This does not happen on Linux. Is this a
      bug or a feature? Can I tell the perl interpreter to be synchronized
      with vim?

      Thanks,
      Moshe
    Your message has been successfully submitted and would be delivered to recipients shortly.