Loading ...
Sorry, an error occurred while loading the content.
 

Re: problem with polish diacritics: win32-vim63

Expand Messages
  • Antoine J. Mechelynck
    ... Oops! Typo. I meant a-ogonek of course.
    Message 1 of 7 , Jul 2, 2004
      Antoine J. Mechelynck <antoine.mechelynck@...> wrote:
      > Mikolaj Machowski <mikmach@...> wrote:
      > > I've got multiple reports and tested it myself.
      > >
      > > It is impossible to insert Polish diacritics in Vim 6.3 win32.
      > > Eg. press <AltGr-a> and got 1. This is not problem of font.
      > > Encoding is detected properly (cp1250), 1 is entered literally
      > > ga returns the same code as simple press of 1.
      > >
      > > Downloading of iconv.dll doesn't help.
      > >
      > > CTRL-^ or various values of 'iminsert' doesn't help also.
      > >
      > > m.
      >
      > Can you enter them by means of digraphs? For instance, does ^Ka;
      > (i.e., Control-K, letter-a, semicolon) in inssert mode produce the
      > letter e-ogonek? If it does, then the data is represented correctly

      Oops! Typo. I meant "a-ogonek" of course.

      > in gvim's working storage. If it doesn't, then the problem lies
      > deeper.
      >
      > Also, what does gvim answer to
      >
      > set encoding?
      > set termencoding?
      > set fileencodings?
      > set keymap?
      > set langmap?
      >
      > Regards,
      > Tony.
    • Mikolaj Machowski
      ... a-ogonek :) Yes, its possible. :dig shows very long table, like for utf-8 encoding and most of these digraphs doesn t work, but those from cp1250 range are
      Message 2 of 7 , Jul 3, 2004
        Dnia sobota, 3 lipca 2004 01:11, Antoine J. Mechelynck napisaƂ:
        > Mikolaj Machowski <mikmach@...> wrote:
        > > I've got multiple reports and tested it myself.
        > >
        > > It is impossible to insert Polish diacritics in Vim 6.3 win32.
        > > Eg. press <AltGr-a> and got 1. This is not problem of font.
        > > Encoding is detected properly (cp1250), 1 is entered literally
        > > ga returns the same code as simple press of 1.
        > >
        > > Downloading of iconv.dll doesn't help.
        > >
        > > CTRL-^ or various values of 'iminsert' doesn't help also.
        > >
        > > m.
        >
        > Can you enter them by means of digraphs? For instance, does ^Ka; (i.e.,
        > Control-K, letter-a, semicolon) in inssert mode produce the letter
        > e-ogonek?

        a-ogonek :)
        Yes, its possible. :dig shows very long table, like for utf-8 encoding
        and most of these digraphs doesn't work, but those from cp1250 range are
        working.

        > If it does, then the data is represented correctly in gvim's
        > working storage. If it doesn't, then the problem lies deeper.
        >
        > Also, what does gvim answer to
        >
        > set encoding?
        cp1250
        > set termencoding?
        empty
        > set fileencodings?
        ucs-bom
        > set keymap?
        empty
        > set langmap?
        empty
        >
        > Tony.

        m.


        --
        LaTeX + Vim = http://vim-latex.sourceforge.net/
        Vim-list(s) Users Map: (last change 10 Mar)
        http://skawina.eu.org/mikolaj/vimlist
        VimGDB - http://skawina.eu.org/mikolaj/vimgdb
      • Antoine J. Mechelynck
        ... If you invoke Vim as gvim -u NONE -U NONE -N , does encoding get set to the same value? If it does, try setting the keymap and/or langmap options.
        Message 3 of 7 , Jul 3, 2004
          Mikolaj Machowski <mikmach@...> wrote:
          > Dnia sobota, 3 lipca 2004 01:11, Antoine J. Mechelynck napisal:
          > > Mikolaj Machowski <mikmach@...> wrote:
          > > > I've got multiple reports and tested it myself.
          > > >
          > > > It is impossible to insert Polish diacritics in Vim 6.3 win32.
          > > > Eg. press <AltGr-a> and got 1. This is not problem of font.
          > > > Encoding is detected properly (cp1250), 1 is entered literally
          > > > ga returns the same code as simple press of 1.
          > > >
          > > > Downloading of iconv.dll doesn't help.
          > > >
          > > > CTRL-^ or various values of 'iminsert' doesn't help also.
          > > >
          > > > m.
          > >
          > > Can you enter them by means of digraphs? For instance, does ^Ka;
          > > (i.e., Control-K, letter-a, semicolon) in inssert mode produce the
          > > letter e-ogonek?
          >
          > a-ogonek :)
          > Yes, its possible. :dig shows very long table, like for utf-8 encoding
          > and most of these digraphs doesn't work, but those from cp1250 range
          > are working.
          >
          > > If it does, then the data is represented correctly in gvim's
          > > working storage. If it doesn't, then the problem lies deeper.
          > >
          > > Also, what does gvim answer to
          > >
          > > set encoding?
          > cp1250
          > > set termencoding?
          > empty
          > > set fileencodings?
          > ucs-bom
          > > set keymap?
          > empty
          > > set langmap?
          > empty
          > >
          > > Tony.
          >
          > m.

          If you invoke Vim as "gvim -u NONE -U NONE -N", does 'encoding' get set to
          the same value? If it does, try setting the 'keymap' and/or 'langmap'
          options. If it doesn't, I'd suggest also setting 'termencoding' to the
          'encoding' that gets set when gvim is loaded with -u NONE -U NONE -N. To do
          that, find in your vimrc the line that sets 'encoding', and add just before
          it

          if &termencoding == ""
          let &termencoding = &encoding
          endif

          I'd also suggest ":set fileencodings+=cp1250" in any case.

          See
          :help 'encoding'
          :help 'termencoding'
          :help 'fileencodings'
          :help 'keymap'
          :help 'langmap'

          HTH,
          Tony.
        • Mikolaj Machowski
          ... All options has the same values. ... For what? There is no keymap file for Polish keyboard, it was never necessary. Also I have no idea how to create one.
          Message 4 of 7 , Jul 3, 2004
            Mikolaj Machowski <mikmach@...> wrote:
            >If you invoke Vim as "gvim -u NONE -U NONE -N", does 'encoding' get set
            >to the same value?

            All options has the same values.

            >If it does, try setting the 'keymap' and/or 'langmap'
            >options.

            For what?
            There is no keymap file for Polish keyboard, it was never necessary.
            Also I have no idea how to create one. Keymap files are for simple
            mappings, eventually for dead keys which for most of Polish users is
            unacceptable.

            >If it doesn't, I'd suggest also setting 'termencoding' to the
            >'encoding' that gets set when gvim is loaded with -u NONE -U NONE -N.
            >To do that, find in your vimrc the line that sets 'encoding', and add
            >just before it

            Doesn't help.

            m.


            --
            LaTeX + Vim = http://vim-latex.sourceforge.net/
            Vim-list(s) Users Map: (last change 10 Mar)
            http://skawina.eu.org/mikolaj/vimlist
            VimGDB - http://skawina.eu.org/mikolaj/vimgdb
          • Alejandro Lopez-Valencia
            ... It works for me in W2ksp4 with the Polish (Programmers) keyboard driver after I set gvim s buffer encoding to cp1250 (not my system s default obviously):
            Message 5 of 7 , Jul 3, 2004
              At 05:37 p.m. 02/07/2004, Mikolaj Machowski wrote:
              >I've got multiple reports and tested it myself.
              >
              >It is impossible to insert Polish diacritics in Vim 6.3 win32.
              >Eg. press <AltGr-a> and got 1. This is not problem of font.
              >Encoding is detected properly (cp1250), 1 is entered literally
              >ga returns the same code as simple press of 1.

              It works for me in W2ksp4 with the 'Polish (Programmers)' keyboard driver
              after I set gvim's buffer encoding to cp1250 (not my system's default
              obviously): <altgr>-a produces an aogonek (u0105, cp1250 codepoint 0xB9).

              I wonder if the keyboard driver installed matches your expectations (the
              keyboard 'Polish (214)' is very different) and if the font you use for
              display contains the actual glyph.
            Your message has been successfully submitted and would be delivered to recipients shortly.