Loading ...
Sorry, an error occurred while loading the content.

Slow start on X /Linux

Expand Messages
  • Ron Aaron
    Starting gvim is slow when I run on a vnc session; it starts fast when I run from a normal session. In other words, starting gvim from my normal KDE desktop (X
    Message 1 of 6 , Apr 1, 2004
    • 0 Attachment
      Starting gvim is slow when I run on a vnc session; it starts fast when I run
      from a normal session.

      In other words, starting gvim from my normal KDE desktop (X display :0) takes
      a fraction of a second. Doing the same thing (same exact startup files etc)
      takes 6.5 seconds on the vnc desktop (X display :1).

      If I do "gvim -X" then it starts up quickly on the vnc desktop. But changing
      'clipboard' doesn't make any difference at all.

      Any suggestions?


      --
      My GPG public key is at http://ronware.org/
      fingerprint: 4E91 06E9 2020 114C 8BCD 55B2 0816 60AF 2B3D 4C51
    • Dan Sharp
      ... How are you connecting to the VNC session? Would you happen to be forwarding your VNC session through an ssh connection, especially one with X forwarding
      Message 2 of 6 , Apr 2, 2004
      • 0 Attachment
        Ron Aaron wrote:
        > Starting gvim is slow when I run on a vnc session; it starts fast when I run
        > from a normal session.
        >
        > In other words, starting gvim from my normal KDE desktop (X display :0) takes
        > a fraction of a second. Doing the same thing (same exact startup files etc)
        > takes 6.5 seconds on the vnc desktop (X display :1).
        >
        > If I do "gvim -X" then it starts up quickly on the vnc desktop. But changing
        > 'clipboard' doesn't make any difference at all.

        How are you connecting to the VNC session? Would you happen to be
        forwarding your VNC session through an ssh connection, especially one
        with X forwarding enabled? If so, then gvim is probably trying to
        connect to your local X session from the remote machine, which is
        causing the delay, and which using the -X option disables. I think it
        may be to update the local xterm title, since you said changing
        'clipboard' doesn't make a difference.

        Dan Sharp
      • Ron Aaron
        ... Excellent analysis! Yes, that is exactly what I am doing. Do you have any suggestions? I do need the X clipboard to work. I am connecting from a Windows
        Message 3 of 6 , Apr 2, 2004
        • 0 Attachment
          On Friday 02 April 2004 08:38 am, Dan Sharp wrote:

          > How are you connecting to the VNC session? Would you happen to be
          > forwarding your VNC session through an ssh connection, especially one
          > with X forwarding enabled?

          Excellent analysis! Yes, that is exactly what I am doing.

          Do you have any suggestions? I do need the X clipboard to work.
          I am connecting from a Windows machine using Putty -- perhaps I don't need the
          "X forwarding" checked...


          --
          My GPG public key is at http://ronware.org/
          fingerprint: 4E91 06E9 2020 114C 8BCD 55B2 0816 60AF 2B3D 4C51
        • Dan Sharp
          ... I think that would fix it. I guess you are using the port forwarding so you can connect to localhost:5901 to access the VNC session? In that case, you
          Message 4 of 6 , Apr 2, 2004
          • 0 Attachment
            Ron Aaron wrote:
            > On Friday 02 April 2004 08:38 am, Dan Sharp wrote:
            >
            >
            >>How are you connecting to the VNC session? Would you happen to be
            >>forwarding your VNC session through an ssh connection, especially one
            >>with X forwarding enabled?
            >
            > Excellent analysis! Yes, that is exactly what I am doing.
            >
            > Do you have any suggestions? I do need the X clipboard to work.
            > I am connecting from a Windows machine using Putty -- perhaps I don't need the
            > "X forwarding" checked...

            I think that would fix it. I guess you are using the port forwarding so
            you can connect to localhost:5901 to access the VNC session? In that
            case, you don't need X forwarding to be enabled, especially if you
            aren't running an X server on Windows. Gvim is probably trying to
            connect to it and timing out before continuing. With the forwarding
            turned off, it should only look on the remote system for the X server.

            Dan Sharp
          • Ron Aaron
            ... I turned off all X forwarding but it still is slow on this connection. :-
            Message 5 of 6 , Apr 2, 2004
            • 0 Attachment
              On Friday 02 April 2004 09:29 am, Dan Sharp wrote:
              > I think that would fix it. I guess you are using the port forwarding so
              > you can connect to localhost:5901 to access the VNC session? In that
              > case, you don't need X forwarding to be enabled, especially if you
              > aren't running an X server on Windows. Gvim is probably trying to
              > connect to it and timing out before continuing. With the forwarding
              > turned off, it should only look on the remote system for the X server.

              I turned off all X forwarding but it still is slow on this connection. :-<
            • Alejandro López-Valencia
              ... Try using a different VNC flavor. I can vouch for TighVNC as being fast even on a 56K line. -- Alejandro López-Valencia http://dradul.tripod.com/ The
              Message 6 of 6 , Apr 2, 2004
              • 0 Attachment
                At 12:39 p.m. 02/04/2004, Ron Aaron wrote:
                >On Friday 02 April 2004 09:29 am, Dan Sharp wrote:
                > > I think that would fix it. I guess you are using the port forwarding so
                > > you can connect to localhost:5901 to access the VNC session? In that
                > > case, you don't need X forwarding to be enabled, especially if you
                > > aren't running an X server on Windows. Gvim is probably trying to
                > > connect to it and timing out before continuing. With the forwarding
                > > turned off, it should only look on the remote system for the X server.
                >
                >I turned off all X forwarding but it still is slow on this connection. :-<


                Try using a different VNC flavor. I can vouch for TighVNC as being fast
                even on a 56K line.


                --
                Alejandro López-Valencia
                http://dradul.tripod.com/
                The limits of my language are the limits of my world.
                (L. Wittgenstein)
              Your message has been successfully submitted and would be delivered to recipients shortly.