Loading ...
Sorry, an error occurred while loading the content.

Problem compiling vim 6.2 on QNX

Expand Messages
  • Stephen Rasku
    I get the following error when I try and compile Vim 6.2 on QNX: make[1]: Entering directory `/home/empress/srasku/vim62/src gcc -c -I. -Iproto
    Message 1 of 5 , Dec 8, 2003
    • 0 Attachment
      I get the following error when I try and compile Vim 6.2 on QNX:

      make[1]: Entering directory `/home/empress/srasku/vim62/src'
      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_PHOTON -g -O2 -o
      objects/buffer.o buffer.c
      In file included from buffer.c:29:
      vim.h:248: os_qnx.h: No such file or directory
      In file included from vim.h:1531,
      from buffer.c:29:
      proto.h:72: os_qnx.pro: No such file or directory
      In file included from vim.h:1531,
      from buffer.c:29:
      proto.h:207: gui_photon.pro: No such file or directory

      The files os_qnx.h, os_qnx.pro, and gui_photon.pro are nowhere to be
      found in the tar file. What can I do to resolve this?

      ...Stephen
    • Dan Sharp
      ... You need to get the vim-6.2-extra.tar.gz archive for the QNX files. Dan Sharp
      Message 2 of 5 , Dec 8, 2003
      • 0 Attachment
        Stephen Rasku wrote:
        >
        > I get the following error when I try and compile Vim 6.2 on QNX:
        >
        > make[1]: Entering directory `/home/empress/srasku/vim62/src'
        > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_PHOTON -g -O2 -o
        > objects/buffer.o buffer.c
        > In file included from buffer.c:29:
        > vim.h:248: os_qnx.h: No such file or directory
        > In file included from vim.h:1531,
        > from buffer.c:29:
        > proto.h:72: os_qnx.pro: No such file or directory
        > In file included from vim.h:1531,
        > from buffer.c:29:
        > proto.h:207: gui_photon.pro: No such file or directory
        >
        > The files os_qnx.h, os_qnx.pro, and gui_photon.pro are nowhere to be
        > found in the tar file. What can I do to resolve this?

        You need to get the vim-6.2-extra.tar.gz archive for the QNX files.

        Dan Sharp
      • Stephen Rasku
        That works. Thanks. However it seems to suffer from the same problem in that it hangs sometimes when it tries to run an external program. See:
        Message 3 of 5 , Dec 9, 2003
        • 0 Attachment
          That works. Thanks.

          However it seems to suffer from the same problem in that it hangs
          sometimes when it tries to run an external program. See:

          http://marc.theaimsgroup.com/?l=vim-dev&m=106996682921635&w=2

          In that message, it says the problem occurs when I try and open a new
          file. However, I think the real problem is because it does auto
          commands which cause it to run an external program.

          ...Stephen

          -----Original Message-----
          From: Dan Sharp [mailto:dwsharp@...]
          Sent: December 8, 2003 2:28 PM
          To: srasku@...
          Cc: vim-dev@...
          Subject: Re: Problem compiling vim 6.2 on QNX


          Stephen Rasku wrote:
          >
          > I get the following error when I try and compile Vim 6.2 on QNX:
          >
          > make[1]: Entering directory `/home/empress/srasku/vim62/src'
          > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_PHOTON -g -O2
          -o
          > objects/buffer.o buffer.c
          > In file included from buffer.c:29:
          > vim.h:248: os_qnx.h: No such file or directory
          > In file included from vim.h:1531,
          > from buffer.c:29:
          > proto.h:72: os_qnx.pro: No such file or directory
          > In file included from vim.h:1531,
          > from buffer.c:29:
          > proto.h:207: gui_photon.pro: No such file or directory
          >
          > The files os_qnx.h, os_qnx.pro, and gui_photon.pro are nowhere to be
          > found in the tar file. What can I do to resolve this?

          You need to get the vim-6.2-extra.tar.gz archive for the QNX files.

          Dan Sharp
        • Julian Kinraid
          Hi Stephen, ... I suspect your problem is a pty issue in QNX 6.1. Put set noguipty in your .vimrc and see if it helps. Julian
          Message 4 of 5 , Dec 9, 2003
          • 0 Attachment
            Hi Stephen,

            > However it seems to suffer from the same problem in that it hangs
            > sometimes when it tries to run an external program. See:
            >
            > http://marc.theaimsgroup.com/?l=vim-dev&m=106996682921635&w=2
            >
            > In that message, it says the problem occurs when I try and open a new
            > file. However, I think the real problem is because it does auto
            > commands which cause it to run an external program.

            I suspect your problem is a pty issue in QNX 6.1. Put 'set noguipty'
            in your .vimrc and see if it helps.

            Julian
          • Stephen Rasku
            I haven t had a problem all day. It seems to have worked. Thanks. ... From: Julian Kinraid [mailto:jkinraid@clear.net.nz] Sent: December 9, 2003 7:46 PM To:
            Message 5 of 5 , Dec 10, 2003
            • 0 Attachment
              I haven't had a problem all day. It seems to have worked. Thanks.

              ...Stephen

              -----Original Message-----
              From: Julian Kinraid [mailto:jkinraid@...]
              Sent: December 9, 2003 7:46 PM
              To: Stephen Rasku
              Cc: vim-dev@...
              Subject: Re: 6.2 Hangs on QNX (was Problem compiling vim 6.2 on QNX)


              Hi Stephen,

              > However it seems to suffer from the same problem in that it hangs
              > sometimes when it tries to run an external program. See:
              >
              > http://marc.theaimsgroup.com/?l=vim-dev&m=106996682921635&w=2
              >
              > In that message, it says the problem occurs when I try and open a new
              > file. However, I think the real problem is because it does auto
              > commands which cause it to run an external program.

              I suspect your problem is a pty issue in QNX 6.1. Put 'set noguipty' in
              your .vimrc and see if it helps.

              Julian
            Your message has been successfully submitted and would be delivered to recipients shortly.