Loading ...
Sorry, an error occurred while loading the content.

UTF8 on KDE3 (GTK vim)

Expand Messages
  • Ron Aaron
    Does anyone know how to get gvim to show utf8 text properly (non Latin characters) on KDE3.1.4 (Slackware 9.1 install)? I am having the unfortunate experience
    Message 1 of 8 , Nov 29, 2003
    • 0 Attachment
      Does anyone know how to get gvim to show utf8 text properly (non Latin
      characters) on KDE3.1.4 (Slackware 9.1 install)?

      I am having the unfortunate experience that ":set gfn=...whatever..."
      doesn't seem to have any effect, and the font selector which comes up is
      a KDE one which doesn't let me select font encoding.

      help!
    • Ken Shan
      ... I don t know how GTK Vim can show a KDE font selector. I use GTK Vim on Debian unstable, and it shows me a GTK standard font selector. The underlying
      Message 2 of 8 , Nov 30, 2003
      • 0 Attachment
        Ron Aaron <ron@...> wrote in article <20031130022446.GA14493@...> in gmane.editors.vim.devel:
        > Does anyone know how to get gvim to show utf8 text properly (non Latin
        > characters) on KDE3.1.4 (Slackware 9.1 install)?
        >
        > I am having the unfortunate experience that ":set gfn=...whatever..."
        > doesn't seem to have any effect, and the font selector which comes up is
        > a KDE one which doesn't let me select font encoding.

        I don't know how GTK Vim can show a KDE font selector. I use GTK Vim
        on Debian unstable, and it shows me a GTK standard font selector. The
        underlying text drawing is done by GTK with the help of Xft/Fontconfig,
        so if basic Gnome/GTK applications like Gedit can see your fonts, Vim
        should as well. (Over here, I can view and type a variety of scripts
        (Chinese, Japanese, Korean, extended Latin, etc.), and the fonts all
        fall back to reasonable defaults.)

        Perhaps you could set the XFT_DEBUG environment variable to a number
        like 2047 before starting Vim, and see if any debugging output is
        produced?

        --
        Edit this signature at http://www.digitas.harvard.edu/cgi-bin/ken/sig
        This Sunday is St Andrew's Day!

        International Human Rights Day * 2003-12-10 * http://www.un.org/rights/
      • Mikolaj Machowski
        ... If you are using gvim you should get gtk-font-selector. Now encoding and font are separated. You need to choose font, _and_ :set enc=utf-8. Of course it
        Message 3 of 8 , Nov 30, 2003
        • 0 Attachment
          Dnia Sunday 30 of November 2003 03:24, Ron Aaron napisał:
          > Does anyone know how to get gvim to show utf8 text properly (non Latin
          > characters) on KDE3.1.4 (Slackware 9.1 install)?
          >
          > I am having the unfortunate experience that ":set gfn=...whatever..."
          > doesn't seem to have any effect, and the font selector which comes up is
          > a KDE one which doesn't let me select font encoding.

          If you are using gvim you should get gtk-font-selector.
          Now encoding and font are separated. You need to choose font, _and_ :set
          enc=utf-8. Of course it will work only when font has unicode glyphs
          (misc-fixed r00lez ;)

          It works similar for kvim.

          m.
        • Ron Aaron
          ... I get something ... else, I think. The font s presented are not all monospace. I don t know if this is an artifact of having installed OpenOffice. ... I
          Message 4 of 8 , Nov 30, 2003
          • 0 Attachment
            On Sun, Nov 30, 2003 at 02:04:00PM +0100, Mikolaj Machowski wrote:
            >> I am having the unfortunate experience that ":set gfn=...whatever..."
            >> doesn't seem to have any effect, and the font selector which comes up
            >> is a KDE one which doesn't let me select font encoding.
            >
            > If you are using gvim you should get gtk-font-selector.

            I get something ... else, I think. The font's presented are not all
            monospace. I don't know if this is an artifact of having installed
            OpenOffice.

            > Now encoding and font are separated. You need to choose font, _and_
            > :set enc=utf-8. Of course it will work only when font has unicode
            > glyphs (misc-fixed r00lez ;)

            I installed Misc-Fixed but vim doesn't seem to like it. Doing 'set
            gfn=Misc-Fixed' doesn't result in anything. Even if I use the fully
            qualified font name.

            I can only assume there is some sort of configuration "issue", but I
            used to use gvim on an earlier Linux distro with no problems at all.
            ARGGGH!!!
          • Mikolaj Machowski
            ... Gvim for GTK2 can display non-monospaced fonts. Of course they looks ugly but it is possible to view text with Times or Arial :) ... Proper value for this
            Message 5 of 8 , Nov 30, 2003
            • 0 Attachment
              Dnia Sunday 30 of November 2003 19:43, Ron Aaron napisał:
              > On Sun, Nov 30, 2003 at 02:04:00PM +0100, Mikolaj Machowski wrote:
              > >> I am having the unfortunate experience that ":set gfn=...whatever..."
              > >> doesn't seem to have any effect, and the font selector which comes up
              > >> is a KDE one which doesn't let me select font encoding.
              > >
              > > If you are using gvim you should get gtk-font-selector.
              >
              > I get something ... else, I think. The font's presented are not all
              > monospace. I don't know if this is an artifact of having installed
              > OpenOffice.
              >
              Gvim for GTK2 can display non-monospaced fonts. Of course they looks
              ugly but it is possible to view text with Times or Arial :)

              > > Now encoding and font are separated. You need to choose font, _and_
              > >
              > > :set enc=utf-8. Of course it will work only when font has unicode
              > >
              > > glyphs (misc-fixed r00lez ;)
              >
              > I installed Misc-Fixed but vim doesn't seem to like it. Doing 'set
              > gfn=Misc-Fixed' doesn't result in anything. Even if I use the fully
              > qualified font name.

              Proper value for this font is:
              se gfn=Fixed\ 18

              (of course you can choose other size)

              Note: some combinations of gtk2 and fontconfig wern't compatible with
              this font. I like it because IMO this is best utf-8 font for Linux.
              There are several other utf-enabled fonts (sorry don't remember names),
              eventually you can import from Windows Courier New (but it have narrower
              choice of glyphs).

              > I can only assume there is some sort of configuration "issue", but I
              > used to use gvim on an earlier Linux distro with no problems at all.

              Yeah. This is problem with Linux. Few good fonts and very different ways
              of configuring them. Not talking about Vim here. It have different
              goals, but if you have to configure font-settings in three different
              places to get everything working... :/

              m.


              --
              LaTeX + Vim = http://vim-latex.sourceforge.net/
              Vim-list(s) Users Map: (last change 26 Nov)
              http://skawina.eu.org/mikolaj/vimlist
              Are You There?
            • Ron Aaron
              ... When I do this, the font does change - but I cannot see my Hebrew text. Try inputing character 0x05d4 (Ctrl-V u05d4) and see if you can see the character.
              Message 6 of 8 , Nov 30, 2003
              • 0 Attachment
                On Sun, Nov 30, 2003 at 08:46:19PM +0100, Mikolaj Machowski wrote:
                > Proper value for this font is:
                > se gfn=Fixed\ 18


                When I do this, the font does change - but I cannot see my Hebrew text.
                Try inputing character 0x05d4 (Ctrl-V u05d4) and see if you can see the
                character. I see only blank spaces :-<


                > Note: some combinations of gtk2 and fontconfig wern't compatible with
                > this font. I like it because IMO this is best utf-8 font for Linux.
                > There are several other utf-enabled fonts (sorry don't remember
                > names), eventually you can import from Windows Courier New (but it
                > have narrower choice of glyphs).

                What codepages does it cover? Perhaps that is my problem... ah,
                according to the web page, code 0x05xx is not yet covered :-<

                I used to use gnu-unifont but I can't seem to get gvim to use a bdf
                font!

                > Yeah. This is problem with Linux. Few good fonts and very different
                > ways of configuring them. Not talking about Vim here. It have
                > different goals, but if you have to configure font-settings in three
                > different places to get everything working... :/

                Yes, it is frustrating. Especially when I know that what I want to do
                is basically trivial.

                Thanks,
                Ron
              • GI
                ... it works fine for me! (i get a funny O with an accent on top. is that the correct charector?) i run redhat 9.0 with gvim 6.2. it works for me with gfn set
                Message 7 of 8 , Nov 30, 2003
                • 0 Attachment
                  > When I do this, the font does change - but I cannot see my Hebrew text.
                  > Try inputing character 0x05d4 (Ctrl-V u05d4) and see if you can see the
                  > character. I see only blank spaces :-<

                  it works fine for me! (i get a funny O with an accent on top. is that
                  the correct charector?)

                  i run redhat 9.0 with gvim 6.2. it works for me with gfn set to both
                  Monospace\ 12 and Fixed\ 18.

                  Maybe its a problem with the installed fonts on your machine?

                  GI
                • Mikolaj Machowski
                  ... Courier New? I don t know. But misc-fixed covers 0x05xx. Screenshot at priv. m.
                  Message 8 of 8 , Dec 1, 2003
                  • 0 Attachment
                    Dnia Monday 01 of December 2003 02:25, Ron Aaron napisał:
                    > On Sun, Nov 30, 2003 at 08:46:19PM +0100, Mikolaj Machowski wrote:
                    > > Proper value for this font is:
                    > > se gfn=Fixed\ 18
                    >
                    > When I do this, the font does change - but I cannot see my Hebrew text.
                    > Try inputing character 0x05d4 (Ctrl-V u05d4) and see if you can see the
                    > character. I see only blank spaces :-<
                    >
                    > > Note: some combinations of gtk2 and fontconfig wern't compatible with
                    > > this font. I like it because IMO this is best utf-8 font for Linux.
                    > > There are several other utf-enabled fonts (sorry don't remember
                    > > names), eventually you can import from Windows Courier New (but it
                    > > have narrower choice of glyphs).
                    >
                    > What codepages does it cover? Perhaps that is my problem... ah,
                    > according to the web page, code 0x05xx is not yet covered :-<

                    Courier New? I don't know. But misc-fixed covers 0x05xx.
                    Screenshot at priv.

                    m.
                  Your message has been successfully submitted and would be delivered to recipients shortly.