Loading ...
Sorry, an error occurred while loading the content.
 

bug/feature request: normal! i\\e

Expand Messages
  • Mikolaj Machowski
    Hello, This is some inconsequence/incapability. Looks like it is not possible ... returns i with cursor on i after but ... returns i e How to put i e
    Message 1 of 3 , Nov 25, 2003
      Hello,

      This is some inconsequence/incapability. Looks like it is not possible
      to enter \e:

      :normal! i\e
      returns
      i " with cursor on i after <Esc>
      but
      :normal! i\\e
      returns
      i\\e
      How to put i\e with :normal?

      Also unexpected limit on string length.
      I have
      let @z =
      \.'and here'
      \.'2k chars'
      \.'dispersed through 10 lines'

      But
      put = @z

      Gives E15: [string too long]

      How can I put long string with many \ in buffer?

      m.
      --
      LaTeX + Vim = http://vim-latex.sourceforge.net/
      Vim-list(s) Users Map: (last change 13 Nov)
      http://skawina.eu.org/mikolaj/vimlist
      Are You There?
    • Gary Johnson
      ... Do you have this problem if you start vim as vim -N -u NONE ? When I do that and execute ... I get e alone on the first line. This also works for me if I
      Message 2 of 3 , Nov 25, 2003
        On 2003-11-26, Mikolaj Machowski <mikmach@...> wrote:
        > Hello,
        >
        > This is some inconsequence/incapability. Looks like it is not possible
        > to enter \e:
        >
        > :normal! i\e
        > returns
        > i " with cursor on i after <Esc>
        > but
        > :normal! i\\e
        > returns
        > i\\e
        > How to put i\e with :normal?

        Do you have this problem if you start vim as

        vim -N -u NONE

        ?

        When I do that and execute

        :normal! i\e

        I get

        \e

        alone on the first line. This also works for me if I start vim
        without any options. I think you have a problem with one of your
        plugins, although I can't explain why the '!' doesn't seem to be
        protecting you from plugin mappings. I'm using

        :version
        VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Sep 28 2003 11:01:59)
        Included patches: 1-14, 76, 101-103, 106

        Gary

        --
        Gary Johnson | Agilent Technologies
        garyjohn@... | Wireless Division
        | Spokane, Washington, USA
      • Mikolaj Machowski
        Sorry, problem was with my settings. m. -- LaTeX + Vim = http://vim-latex.sourceforge.net/ Vim-list(s) Users Map: (last change 13 Nov)
        Message 3 of 3 , Nov 26, 2003
          Sorry, problem was with my settings.

          m.
          --
          LaTeX + Vim = http://vim-latex.sourceforge.net/
          Vim-list(s) Users Map: (last change 13 Nov)
          http://skawina.eu.org/mikolaj/vimlist
          Are You There?
        Your message has been successfully submitted and would be delivered to recipients shortly.