Loading ...
Sorry, an error occurred while loading the content.

Re: Modeline, not modeline

Expand Messages
  • Gary Johnson
    ... Which version are you using? For vim-6.2, $VIMRUNTIME/ftplugin/mail.vim already contains: Don t use modelines in e-mail messages, avoid trojan horses
    Message 1 of 3 , Nov 6, 2003
    View Source
    • 0 Attachment
      On 2003-11-06, Mikolaj Machowski <mikmach@...> wrote:
      > Hello,
      >
      > As many of readers here I am using Vim for almost everything :)
      > Today I encountered unwelcomed (but expected) behaviour.
      >
      > When editing some usenet message with
      > Subject: vim: arrays
      >
      > and Subject in third line I've got message: not such option.
      >
      > I would suggest adding to ftplugin/mail.vim
      > set nomodeline

      Which version are you using? For vim-6.2,
      $VIMRUNTIME/ftplugin/mail.vim already contains:

      " Don't use modelines in e-mail messages, avoid trojan horses
      setlocal nomodeline

      Gary

      --
      Gary Johnson | Agilent Technologies
      garyjohn@... | Wireless Division
      | Spokane, Washington, USA
    • Mikolaj Machowski
      ... Yes. I see it. But this is really strange. What could cause message about not existing option? OK. I am not able to reproduce this, next time maybe :) m.
      Message 2 of 3 , Nov 7, 2003
      View Source
      • 0 Attachment
        Dnia Friday 07 of November 2003 08:21, Gary Johnson napisaƂ:
        > On 2003-11-06, Mikolaj Machowski <mikmach@...> wrote:
        > > Hello,
        > >
        > > As many of readers here I am using Vim for almost everything :)
        > > Today I encountered unwelcomed (but expected) behaviour.
        > >
        > > When editing some usenet message with
        > > Subject: vim: arrays
        > >
        > > and Subject in third line I've got message: not such option.
        > >
        > > I would suggest adding to ftplugin/mail.vim
        > > set nomodeline
        >
        > Which version are you using? For vim-6.2,
        > $VIMRUNTIME/ftplugin/mail.vim already contains:
        >
        > " Don't use modelines in e-mail messages, avoid trojan horses
        > setlocal nomodeline

        Yes. I see it. But this is really strange. What could cause message
        about not existing option? OK. I am not able to reproduce this, next
        time maybe :)

        m.
        --
        LaTeX + Vim = http://vim-latex.sourceforge.net/
        Vim-list(s) Users Map: (last change 12 Sep)
        http://skawina.eu.org/mikolaj/vimlist
        Are You There?
      Your message has been successfully submitted and would be delivered to recipients shortly.