Loading ...
Sorry, an error occurred while loading the content.

Re: Bug#211894: more on vim-gtk2: no cyrillics

Expand Messages
  • Bram Moolenaar
    ... There are a few GTK-2 specific problems. Main issue is that font names are completely different. People using the traditional X11 font names will have to
    Message 1 of 3 , Sep 24, 2003
    View Source
    • 0 Attachment
      Norbert Tretkowski wrote:

      > > More:
      > >
      > > When launched gvim from vim-gtk1 I can select a font with cyrillics
      > > and I can see the cirillics in the document. When I start gvim from
      > > vim-gtk deb I select "Select font..." and in the following window I
      > > can see the cyrillics, but after "OK" I still cannot see the
      > > cyrillics in the document - the font seems to change, but is not
      > > using the correct code page.
      >
      > Bram, have you ever heared about problems with the gtk2 gui? I really
      > don't know if these are really vim related problems, or problems with
      > gtk2.

      There are a few GTK-2 specific problems. Main issue is that font names
      are completely different. People using the traditional X11 font names
      will have to figure out what font name to use instead (and maybe have to
      install new fonts).

      Here is my current list of GTK 2 problems:

      - ":sp" ":q" leaves cursor on the cmdline. Setting 'writedelay' to one avoids
      it.
      - DND doesn't work with KDE?
      - Combining UTF-8 characters not displayed properly in menus (Mikolaj
      Machowski)
      - Composing characters under the cursor sometimes disappear. Looks like they
      are displayed on the next character.
      - Moving the scrollbar while there are closed folds doesn't work properly.
      (Moshe Kaminsky, 2003 Jun 3)
      - Searching for bitmaps for the toolbar doesn't work as with other systems.
      Need to explicitly use "icon=name". (Ned Konz, Christian J. Robinson)
      - Find dialog buttons are greyed out (when compiled without Gnome). (Jeremy
      Messenger) Patch from David Necas.
      - "gvim --help" outputs GTK help in UTF-8 in a non-UTF-8 terminal. (Thierry
      Vignaud)
      - Bold font characters leave pixels behind when moving the cursor over them.
      ":set guifont=Monospace\ Bold\ 16" (Keith R. John Warno, 2003 Aug 27)


      --
      "Making it up? Why should I want to make anything up? Life's bad enough
      as it is without wanting to invent any more of it."
      -- Marvin, the Paranoid Android in Douglas Adams'
      "The Hitchhiker's Guide to the Galaxy"

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Help AIDS victims, buy here: http://ICCF-Holland.org/click1.html ///
    Your message has been successfully submitted and would be delivered to recipients shortly.