Loading ...
Sorry, an error occurred while loading the content.

Re: Toolbar icon failure in GTK2 Vim

Expand Messages
  • Bram Moolenaar
    ... The normal toolbar icons show up fine. But perhaps this todo item is the problem: - Searching for bitmaps for the toolbar doesn t work as with other
    Message 1 of 5 , Sep 4, 2003
    • 0 Attachment
      Steve Hall wrote:

      > Several people have contacted me saying that referenced individual
      > icons fail in the GTK2 Vim toolbar. (Can't test for myself.) Didn't
      > notice this on the ToDo so I thought I'd point it out.

      The normal toolbar icons show up fine. But perhaps this todo item is
      the problem:

      - Searching for bitmaps for the toolbar doesn't work as with other systems.
      (Ned Konz, Christian J. Robinson)

      > BTW, I notice on http://www.opensky.ca/gnome-vim/todo.html that GTK2
      > support is now merged in Vim CVS. Does this mean distros might start
      > including it by default? Yikes, I hope my bug can be fixed first!

      GTK 2 will be selected if your GTK is 2.2.0 or newer. The 2.0.x series
      had too many problems. There are a few GTK 2 problems, but not too
      many. The main problem is that nothing has been fixed recently (Daniel
      Elstner disappeared)

      --
      GUARD #1: Where'd you get the coconut?
      ARTHUR: We found them.
      GUARD #1: Found them? In Mercea? The coconut's tropical!
      ARTHUR: What do you mean?
      GUARD #1: Well, this is a temperate zone.
      The Quest for the Holy Grail (Monty Python)

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Help AIDS victims, buy here: http://ICCF-Holland.org/click1.html ///
    • Ned Konz
      ... Just for reference, what I found was that I had to change my source from: amenu 1.172 ToolBar.TVO/7 7 to: amenu icon=TVO/7
      Message 2 of 5 , Sep 4, 2003
      • 0 Attachment
        On Thursday 04 September 2003 04:02 am, Bram Moolenaar wrote:
        > Steve Hall wrote:
        > > Several people have contacted me saying that referenced
        > > individual icons fail in the GTK2 Vim toolbar. (Can't test for
        > > myself.) Didn't notice this on the ToDo so I thought I'd point it
        > > out.
        >
        > The normal toolbar icons show up fine. But perhaps this todo item
        > is the problem:
        >
        > - Searching for bitmaps for the toolbar doesn't work as with other
        > systems. (Ned Konz, Christian J. Robinson)

        Just for reference, what I found was that I had to change my source from:

        amenu 1.172 ToolBar.TVO/7 <LocalLeader>7

        to:

        amenu icon=TVO/7 1.172 ToolBar.TVO/7 <LocalLeader>7

        That is, I had to use an explicit icon= statement.

        --
        Ned Konz
        http://bike-nomad.com
        GPG key ID: BEEA7EFE
      • Steve Hall
        ... Yes, this works for me, thanks much for the hint. -- Steve Hall [ digitect@mindspring.com ]
        Message 3 of 5 , Sep 6, 2003
        • 0 Attachment
          On Thu, 2003-09-04 at 11:07, Ned Konz wrote:
          > > Steve Hall wrote:
          > > > Several people have contacted me saying that referenced
          > > > individual icons fail in the GTK2 Vim toolbar. (Can't test for
          > > > myself.) Didn't notice this on the ToDo so I thought I'd point
          > > > it out.
          >
          > Just for reference, what I found was that I had to change my source
          > from:
          >
          > amenu 1.172 ToolBar.TVO/7 <LocalLeader>7
          >
          > to:
          >
          > amenu icon=TVO/7 1.172 ToolBar.TVO/7 <LocalLeader>7
          >
          > That is, I had to use an explicit icon= statement.

          Yes, this works for me, thanks much for the hint.


          --
          Steve Hall [ digitect@... ]
        Your message has been successfully submitted and would be delivered to recipients shortly.