Loading ...
Sorry, an error occurred while loading the content.

Re: Bug? in Polish v:lang and menu

Expand Messages
  • Mikolaj Machowski
    ... But with 6.1 v:lang returns properly string Polish_Poland.1250 m. -- LaTeX + Vim = http://vim-latex.sourceforge.net/ Vim-list(s) Users Map: (last change 27
    Message 1 of 5 , Aug 3, 2003
    • 0 Attachment
      On Sun, Aug 03, 2003 at 12:53:31PM +0200, Bram Moolenaar wrote:
      > > I took gvim-6-2-57.zip
      > > OK. Thus it makes "official" Vim bug.
      > > Here is quick fix for that. But it should be done on Vim code level.
      > > Problem can affect other Windows style encodings.
      > >
      > > m.
      > >
      > > --- vim62/runtime/menu.vim 2003-05-04 22:58:58.000000000 +0200
      > > +++ /mnt/win_f/vim62/menu.vim 2003-08-02 18:43:44.000000000 +0200
      > > @@ -40,6 +40,9 @@
      > > " Remove "@euro", otherwise "LC_ALL=de_DE@euro gvim" will show English menus
      > > let s:lang = substitute(s:lang, "@euro", "", "")
      > > menutrans clear
      > > + if s:lang =~ "polish"
      > > + let s:lang = "polish_poland.1250"
      > > + endif
      > > exe "runtime! lang/menu_" . s:lang . ".vim"
      > >
      > > if !exists("did_menu_trans")
      > I would guess your problem is not caused by Vim, because Vim doesn't
      > make up this string. It comes from your environment. Thus somehow you
      > have selected codepage 852 in your Windows settings.
      > If you want to overrule the language that Vim uses you can set
      > 'encoding' to "cp1250" and use the ":language" command to set the
      > locale.

      But with 6.1 v:lang returns properly string Polish_Poland.1250

      m.
      --
      LaTeX + Vim = http://vim-latex.sourceforge.net/
      Vim-list(s) Users Map: (last change 27 May)
      http://skawina.eu.org/mikolaj/vimlist
      Are You There?
    Your message has been successfully submitted and would be delivered to recipients shortly.